Jump to content
Chronic

KS16X latest v1.07 firmware was released

Recommended Posts

I hope one can say, well on time to Chinese National Day and not, we quickly botched something together under time pressure, before we have 7 days off. :efefb6a84e:

Well, I'll see or feel if everything is good, did the update from 1.0.6 to 1.0.7 and wait for good weather.

Share this post


Link to post
Share on other sites

Trying to get it to upgrade, but no dice so far. I click the upgrade button and then the app just hangs. Tried laying it on either the right or left side, but nothing. The animation spins but it never shows a progress bar or anything.

Hoping to try it out on the way home from work today!

Edited by redfoxdude

Share this post


Link to post
Share on other sites
24 minutes ago, redfoxdude said:

Trying to get it to upgrade, but no dice so far. I click the upgrade button and then the app just hangs. Tried laying it on either the right or left side, but nothing. The animation spins but it never shows a progress bar or anything.

Hoping to try it out on the way home from work today!

Did you download the app from kingsong website? If not do that 👍

Share this post


Link to post
Share on other sites
1 hour ago, Chronic said:

The Kingsong iOS application is buggy and doesn't work properly.

If you want to upgrade the firmware, I recommend Android OS

good luck

KS-16X Firmware V1.07 Features:
1. Adjust speed limit starting voltage, optimizing speed limit algorithm, safer to ride
2. Add output power, safer to ride in low-voltage status
3. Add hall optimized algorithm, more smooth to ride, more stable at high speed
4. Add new balance algorithm, accelerater faster, riding feeling will not be affected by voltage
5. Activate 100% power of the fan on the controller when headlight is ON and bluetooth music is ON, to improve heat dissipation
1.Add turning light function
2.Automatically adjust between high beam and low beam, including brightness
3.Can click power button to switch high beam or low beam
4.Add auto power off function, default 120 minutes(this function will be not activated during riding or playing music status)
5.Fan activated when controller temperature reach 45 centigrade with 50% power, 100% power when exceed 65 centigrade
6.Fix the bug that some voice report is still working when close voice speak switch
7. Add output power alarm, it will beep 4 times when over 88%
8. With 1.06 also Front light Automatic is wrong.... The dimming is perfect but when speed Up only max. 80% light Output...when Switch Manual to light on 100% Output....can you make dimming also to 100%;or over 20kmh to 100% light Output...this is nice Feature
9. Fix forward/backward shaking problems of some wheels

IMG_2744.thumb.JPG.aa0c57ddd6d61b0bb72622e320fb2563.JPG

 

IMG_2756.thumb.PNG.10fbae2c66a852732fc31bb5a7d43b0a.PNG

I was right it does accelerate faster 😬 and smoother , I've done 53 miles today i run it down to empty . I so want to update from 1.05 it did feel a better ride but i don't want to be throttled to early .i wonder if this is 100% test firmware or they have tweaked the bottom end of the battery 🤔. ,,, What shall i do 🙁 

Share this post


Link to post
Share on other sites
14 minutes ago, stephen said:

Did you download the app from kingsong website? If not do that 👍

Just cleared the cache and app data and uninstalled Play Store version, and installed the one from KingSong's website. Same behavior unfortunately =[

Upgrade button disappears, and back button makes warning popup about interrupting the upgrade. But it just keeps spinning.

Screenshot (Sep 30, 2019 10_23_39 AM).png

Edited by redfoxdude

Share this post


Link to post
Share on other sites

In my experience, the king song app is sketchy, both iOS and android.  The old version was more reliable for me.  

Share this post


Link to post
Share on other sites
1 hour ago, buell47 said:

and not, we quickly botched something together under time pressure, before we have 7 days off.

I already got the first bug.
Night Light > Auto Mode (ON)
Night Light flashing > Close flashing Mode (OFF)

The headlight is dimmed as described, but as soon as you start driving it gets brighter and starts flashing. At a standstill the lights are dimmed again.
If you don't want to have a flashing headlight you have to leave the AUO MODE and switch manually at the power button.

Problem is solved, this only happens if one let the wheel spinning on an stand. If it`s on the ground all is working fine. :efefc8626c::laughbounce2:

Edited by buell47

Share this post


Link to post
Share on other sites
3 hours ago, stephen said:

I was right it does accelerate faster 😬 and smoother , I've done 53 miles today i run it down to empty . I so want to update from 1.05 it did feel a better ride but i don't want to be throttled to early .i wonder if this is 100% test firmware or they have tweaked the bottom end of the battery 🤔. ,,, What shall i do 🙁 

I honestly didn't feel any difference between 1.05; 1.06 and the testfirmware.

I'm at 850km now, +-50 on 1.06 and +-100 with testfirmware but I was glad I had the opportunity to return to 1.05.

If the weather wasn't so bad these last days, I would've hit the 1k km milestone allready :(

I wanna test 1.07 but I've got to be sure I can reverse to 1.05.

So far I've had a blast on my 16x apart from those few days on 1.06. :w00t2:

 

Edit:

No longer able to login with the special kingsong software, so 1.05 it is :yawn:

 

Edited by Slashebeest

Share this post


Link to post
Share on other sites

I'll try to upgrade to 1.07 next weekend.  I'm just starting on a KS-16X (1.05), and don't have high speed / long distance requirements.  ie, I won't notice anything ...

Edited by xorbe

Share this post


Link to post
Share on other sites

Its ok i just copied it to my video post 😁😁

 

Share this post


Link to post
Share on other sites

I upgraded and went for a ride. Calibration and all..

Confirm that accelerates better and more smoothly, but huge problem:

Violent whobbling if descending at more than 40kmh. Terrible experience. Had to repeat that like 10 times to make sure it wasn't me or something in the way I rode the street down. No dough there's gonna be many riders going down the next week's... OMG!! Scary.. really.. WTF? This wheel seams to want to go under 40kmh .. so much power and there's no way to enjoy it :( here's a video. 

Very careful. I do not recommend the upgrade 

 

Edited by Acácio Nuno Bernardo

Share this post


Link to post
Share on other sites

Got it installed using an old Nexus 5 at my workplace. Good thing we have a bin of these things hahahaha!

It took a while to do system updates on the Nexus though, because the KingSong app wouldn't run without crashing on opening. So maybe it would have worked on my Pixel 2 XL and I just needed to wait? 🤷

Here's hoping the throttling is much improved and I can enjoy the wheel even more! Curious to feel the updated balancing algorithm as well.

Share this post


Link to post
Share on other sites
6 minutes ago, Acácio Nuno Bernardo said:

I upgraded and went for a ride. Calibration and all..

Confirm that accelerates better and more smoothly, but huge problem:

Violent whobbling if descending at more than 40kmh. Terrible experience. Had to repeat that like 10 times to make sure it wasn't me or something in the way I rode the street down. No dough there's gonna be many riders going down the next week's... OMG!! Scary.. really.. WTF? This wheel seams to want to go under 40kmh .. so much power and there's no way to enjoy it :( here's a video. 

Very careful. I do not recommend the upgrade 

 

What firmware was you on before , are you sure your just not accelerating faster so your braking faster and getting the wobbles, if you control the wobbles rather than just braking hard  try putting 1 leg against the wheel or just ease off the pedals a bit ,,,

Share this post


Link to post
Share on other sites
20 minutes ago, redfoxdude said:

Got it installed using an old Nexus 5 at my workplace. Good thing we have a bin of these things hahahaha!

I wish we had a bin of those laying around. There is a project I wanted to try out called NetHunter that can use a Nexus 5. :D

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Acácio Nuno Bernardo said:

I upgraded and went for a ride. Calibration and all..

Confirm that accelerates better and more smoothly, but huge problem:

Violent whobbling if descending at more than 40kmh. Terrible experience. Had to repeat that like 10 times to make sure it wasn't me or something in the way I rode the street down. No dough there's gonna be many riders going down the next week's... OMG!! Scary.. really.. WTF? This wheel seams to want to go under 40kmh .. so much power and there's no way to enjoy it :( here's a video. 

Very careful. I do not recommend the upgrade 

 

What tire are you using?

Edited by EvoKnvl
Clarification

Share this post


Link to post
Share on other sites
Posted (edited)

 I installed mine and just rode around the yard and down my long driveway, I'm new so I'm not riding fast but I didn't feel anything different to be honest, but again, I'm new and slow, I'm anxious to hear what others are experiencing.

As far as the wobbling that was mentioned above, I wonder if it's something that can be "tuned" out in the settings?

Edited by RetroThruster

Share this post


Link to post
Share on other sites

No extensive test here, but I just updated firmware to 1.07 on iOS. I was previously on V1.06.  No problems at all installing.  Worked on the first try.  Performed horizontal calibration and went out for a quick test tonight.  After riding 1.06 earlier today, I can say the acceleration seems smoother. 

Share this post


Link to post
Share on other sites
11 hours ago, stephen said:

What firmware was you on before , are you sure your just not accelerating faster so your braking faster and getting the wobbles, if you control the wobbles rather than just braking hard  try putting 1 leg against the wheel or just ease off the pedals a bit ,,,

Today I did a new calibration and rode 2 miles and seamed better. No whobbling this morning. I will keep you posted. 

Share this post


Link to post
Share on other sites

Its pissing down here so i can't test 😖:angry:

Share this post


Link to post
Share on other sites
15 hours ago, Acácio Nuno Bernardo said:

I upgraded and went for a ride. Calibration and all..

Confirm that accelerates better and more smoothly, but huge problem:

Violent whobbling if descending at more than 40kmh. Terrible experience. Had to repeat that like 10 times to make sure it wasn't me or something in the way I rode the street down. No dough there's gonna be many riders going down the next week's... OMG!! Scary.. really.. WTF? This wheel seams to want to go under 40kmh .. so much power and there's no way to enjoy it :( here's a video. 

Very careful. I do not recommend the upgrade 

 

That looks like the brake wobbles I encountered from the beginning with this wheel. Not firmware related. Just speed related. For me there were 2 solutions: run very low pressure on your tire and it will be gone, or swap the tire. I swapped tires and for me the problem is solved.

Then again this is a big ME post. It's a personal thing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...