Jump to content
Chronic

KS16X latest v1.07 firmware was released

Recommended Posts

17 minutes ago, RoadRunner said:

To keep it short, just stick with 1.05. :D

I like the way you think :cheers:

Share this post


Link to post
Share on other sites
5 minutes ago, Marty Backe said:

I like the way you think :cheers:

Me too. :laughbounce2:

Share this post


Link to post
Share on other sites
16 minutes ago, Marty Backe said:

I like the way you think :cheers:

Can someone direct me to a place in this forum that explains how to revert back from 1.07 to 1.05?

Share this post


Link to post
Share on other sites
51 minutes ago, Joshua Z. Tabin said:

Can someone direct me to a place in this forum that explains how to revert back from 1.07 to 1.05?

You can't. That's why some of us aren't moving from 1.05.

Share this post


Link to post
Share on other sites
59 minutes ago, Joshua Z. Tabin said:

Can someone direct me to a place in this forum that explains how to revert back from 1.07 to 1.05?

Why you want to go back to 1.05? Details please.

Some people are saying that 1.07 is good. 

Share this post


Link to post
Share on other sites

Do I regret going to 1.07 from 1.05, maybe, but, I"m new and the 1.07 is fine for now, I just hope that when I get up to speed, either there will be a new firmware or I'll have the ability to go back to 1.05, here's to hoping, fingers crossed....  Reason for me is that I don't feel like the 1.07 climbs the hills in my yard as well, but, I have been playing with tire pressures so that might be a factor (I"m 215lbs),  it just seems to not be as willing to climb as quickly as before.

Edited by RetroThruster

Share this post


Link to post
Share on other sites

So after updating to 1.07 I can no longer access the Speed Setting from the iOS app (kingsong_NEW 1.3). When tapped, a load spinner animation appears for 1 or 2 seconds and nothing happens.. So, if you're an iOS user you may want to wait for Kingsong's next app to be approved by Apple.

I tried to load the app onto an old Android phone I have lying around, but it just crashes after the splash screen is displayed. This phone is pretty old though. It has Android 4.4.2 on it and can't be upgraded.

Luckily I had already set my speed settings to something I'm more or less happy with before upgrading.. Otherwise this might really suck.

This screen recording shows me tapping the Speed Setting button twice on the main screen, and then twice in the "Setting" screen.

 

Edited by lioku
Fix YouTube embed

Share this post


Link to post
Share on other sites
4 hours ago, Joshua Z. Tabin said:

Can someone direct me to a place in this forum that explains how to revert back from 1.07 to 1.05?

Here is an old trick that was used back in the day. Problem is, my 16x hasn't arrived yet so I cant test it myself. Also do not have the precious 1.0.5 file. Any volunteers? :)

Share this post


Link to post
Share on other sites
1 hour ago, Tinkererboi said:

Here is an old trick that was used back in the day. Problem is, my 16x hasn't arrived yet so I cant test it myself. Also do not have the precious 1.0.5 file. Any volunteers? :)

Do you just need the 1.05 bin file

have you got a server set up etc  👍

Edited by stephen

Share this post


Link to post
Share on other sites
1 hour ago, stephen said:

Do you just need the 1.05 bin file

have you got a server set up etc  👍

I don’t have the 1.05 bin file — where do I get it?

What “server setup” do you mean?

Share this post


Link to post
Share on other sites
3 hours ago, stephen said:

Do you just need the 1.05 bin file

have you got a server set up etc  👍

Built a few simple websites for school before. Putting your file on a free wix site should work. Then trick the app to download from there instead of kingsong server.

.. well I need my wheel too or the app won't detect a 16x and initiate the download 🤣 

Hope it works.. all purely theoretical 🙈

Share this post


Link to post
Share on other sites
35 minutes ago, Tinkererboi said:

Built a few simple websites for school before. Putting your file on a free wix site should work. Then trick the app to download from there instead of kingsong server.

.. well I need my wheel too or the app won't detect a 16x and initiate the download 🤣 

Hope it works.. all purely theoretical 🙈

In already on 1.05😁

Share this post


Link to post
Share on other sites
11 hours ago, RetroThruster said:

Do I regret going to 1.07 from 1.05, maybe, but, I"m new and the 1.07 is fine for now, I just hope that when I get up to speed, either there will be a new firmware or I'll have the ability to go back to 1.05, here's to hoping, fingers crossed....  Reason for me is that I don't feel like the 1.07 climbs the hills in my yard as well, but, I have been playing with tire pressures so that might be a factor (I"m 215lbs),  it just seems to not be as willing to climb as quickly as before.

Double check your ride settings.

Share this post


Link to post
Share on other sites
6 hours ago, stephen said:

Do you just need the 1.05 bin file

have you got a server set up etc  👍

Can you share the 1.05 file?

I will just try it

Share this post


Link to post
Share on other sites

Getting very close to upgrading to 1.07 from 1.05 only that it might solve the only issue I’m currently having;  Just waiting on a new Android phone that arrives today.

An intermittent heavy throttling, even after a fresh charge or above 80 volts.  It just comes on suddenly- I had mentioned in another thread that I thought it was caused by the Bluetooth music being on  and searching for my device.  After turning that off it seemed to fix it but now it still comes back,..I have found that simply shutting the wheel down then powering back on un-throttles it.

i have been very satisfied with speeds between 18 and 25 mph and never really have the need to go more than 15 miles per day so I think I’ll be fine with the new throttle limitations, you think?  I charge up at work and usually come in with 79 or more volts still.  I weigh only 135 (61.2k) pounds and always carry a backpack weighing about 10.  

On the lighter side:

People on the path act very strange, often giving unusually & unnecessary wide berths for me to pass, old folks just freeze, deer-in-the-headlights.  I already caused this one skateboarding dude to crash & burn but, again, he didn’t need to go that far out of the way.  Most folks are thrilled to see it though, often waving or cheering like I’m some kind of super hero, lol.  Most cars have been quite tolerant but the few that haven’t get really angry & agro, bang on the horn then speed by recklessly. 

Edited by CampDylan

Share this post


Link to post
Share on other sites
31 minutes ago, CampDylan said:

Getting very close to upgrading to 1.07 from 1.05 only that it might solve the only issue I’m currently having;  Just waiting on a new Android phone that arrives today.

An intermittent heavy throttling, even after a fresh charge or above 80 volts.  It just comes on suddenly- I had mentioned in another thread that I thought it was caused by the Bluetooth music being on  and searching for my device.  After turning that off it seemed to fix it but now it still comes back,..I have found that simply shutting the wheel down then powering back on un-throttles it.

i have been very satisfied with speeds between 18 and 25 mph and never really have the need to go more than 15 miles per day so I think I’ll be fine with the new throttle limitations, you think?  I charge up at work and usually come in with 79 or more volts still.  I weigh only 135 (61.2k) pounds and always carry a backpack weighing about 10.  

On the lighter side:

People on the path act very strange, often giving unusually & unnecessary wide berths for me to pass, old folks just freeze, deer-in-the-headlights.  I already caused this one skateboarding dude to crash & burn but, again, he didn’t need to go that far out of the way.  Most folks are thrilled to see it though, often waving or cheering like I’m some kind of super hero, lol.  Most cars have been quite tolerant but the few that haven’t get really angry & agro, bang on the horn then speed by recklessly. 

You'll be fine updating tbh you have nothing to lose, it's s good firmware and I'm over 200lbs you'll be fine you'll actually get better speed than me cause you won't hit the voltage limit as quick👍 go on be a super hero and report back 😁 

Ps what do you mean by heavy throttling

Edited by stephen

Share this post


Link to post
Share on other sites
5 minutes ago, stephen said:

what do you mean by heavy throttling

In the initial thread I had posted that it felt like I lost 2/3 of the torque.  The first time it happened I was trying to ride through some deep, spongy grass when it started to feel like molasses and flopped weakly so I had to jump off.  Putting on the concrete again it was very slow in everything, acceleration, braking, speed.  I'd heard a while ago that 1.05 had issues with playing music affecting performance so I turned the Bluetooth music off and it seemed to rectify the problem - only to return the next day.  Simply turning it off then on again fixes this.  

Share this post


Link to post
Share on other sites
10 minutes ago, CampDylan said:

In the initial thread I had posted that it felt like I lost 2/3 of the torque.  The first time it happened I was trying to ride through some deep, spongy grass when it started to feel like molasses and flopped weakly so I had to jump off.  Putting on the concrete again it was very slow in everything, acceleration, braking, speed.  I'd heard a while ago that 1.05 had issues with playing music affecting performance so I turned the Bluetooth music off and it seemed to rectify the problem - only to return the next day.  Simply turning it off then on again fixes this.  

Have you done the Bluetooth patch to try rectify this just incase it is a problem or was it done from supplier

Edited by stephen

Share this post


Link to post
Share on other sites
13 minutes ago, stephen said:

Have you done the Bluetooth patch to try rectify this just incase it is a problem or was it done from supplier

I have not.  I was under the impression that the BT patch was included with the 1.06 upgrade and we all know what else that came with so I've stuck with 1.05 that my 2nd Batch wheel came with.

Share this post


Link to post
Share on other sites

The BT patch directly updates the BT module. So independent of the firmware updates for the control board.

You should make the BT patch quickly. I had no fun with the 16X without the patch either.

 

 

Edited by buell47

Share this post


Link to post
Share on other sites
1 minute ago, buell47 said:

The BT patch directly updates the BT module. So independent of the firmware updates for the control board.

 

 

 

Can you walk me through the procedure?

Share this post


Link to post
Share on other sites

and here you can download the patch:

 

Edited by buell47

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...