Jump to content

Recommended Posts

Hey all!

Starting a new topic, as I couldn't find similar issue.

Our loved miniPlus not charging. The green light is on PSU and noting on the unit. I have checked for the damage, and nothing I found, we always ride carefully, no water damage either. The PSU is almost new and I always charged/connected with care. I have emailed customer support, but not really hopeful of any help, considering previous experience.

Anyone experienced this? I don't know where to start, all the cables, connectors, look good, unit is barely used, around 60mil on clock only.

 

Link to comment
Share on other sites

34 minutes ago, jojo33 said:

Where did you bought your PLUS (segway europa? other?)

maybe the adapter is dead ?

 

Adapter doesn't look dead as green light is there, like it finished charging.  Bought it online on segway.ie.

Link to comment
Share on other sites

8 hours ago, denzil said:

Segway is the worse company to deal with

you don't experienced french ninebot customer service last year ....:barf:

only the new segway europe service here ... http://eu-en.segway.com/contact-us

open a new ticket, 

it's really amazing that segway-ninebot in europe has such a bad customer service, Segway Ninebot want be the first in the world, they really dont care for his foreign (look from china) customers, except in USA, it's different, but Europe....

Link to comment
Share on other sites

13 hours ago, jojo33 said:

you don't experienced french ninebot customer service last year ....:barf:

only the new segway europe service here ... http://eu-en.segway.com/contact-us

open a new ticket, 

it's really amazing that segway-ninebot in europe has such a bad customer service, Segway Ninebot want be the first in the world, they really dont care for his foreign (look from china) customers, except in USA, it's different, but Europe....

I have opened a ticket, 5 days ago, no answer yet, I'm thinking of exercising my consumer rights and return the unit altogether through different channels. I can't believe such a company can have little to none customer service. Surely I won't buy any of segway products ever.

Edited by denzil
Link to comment
Share on other sites

Oh crap, the bottom battery does not detach right? They kind of sealed it all up, I think, for the.most part....

Any ways, you blew an internal fuse from the charger port on the bms board, hense the no charging...I doubt you can fix it,it is a tiny surface mount resistor, (real stupid). I have a pro, and had to bypassed it with an external actaul fuse and holder...yours will probably be allittle tougher to get at, maybe... It'll be Segway real irresponsibility if they don't fix it!

Link to comment
Share on other sites

On 8/18/2018 at 6:05 AM, MetricUSA said:

Oh crap, the bottom battery does not detach right? They kind of sealed it all up, I think, for the.most part....

Any ways, you blew an internal fuse from the charger port on the bms board, hense the no charging...I doubt you can fix it,it is a tiny surface mount resistor, (real stupid). I have a pro, and had to bypassed it with an external actaul fuse and holder...yours will probably be allittle tougher to get at, maybe... It'll be Segway real irresponsibility if they don't fix it!

I have a feeling they don't. I have submitted support ticket, 2 weeks ago, called them number of times, with one actually went through, only to promise they called me back, hopeless :(

Next stage, I suppose, is a small claims court :(

 

 

 

Link to comment
Share on other sites

Segway Ninebot Europe have really a true communication issue with his customers

It's a big issue, there's nobody at the head of Segway Ninebot Europe, if an dramatic accident ocurre with a Segway device, nobody will take their own responsability front customers

we need an customer association i think

Link to comment
Share on other sites

On 8/10/2018 at 7:20 PM, denzil said:

Adapter doesn't look dead as green light is there, like it finished charging.  Bought it online on segway.ie.

I believe the charger could still be the culprit, even if it shows green light. Broken chargers are relatively common in my experience (though I don't have a Ninebot) and it is relatively easy to test/fix.

  • Upvote 2
Link to comment
Share on other sites

48 minutes ago, jojo33 said:

@denzil  

try with segway netherland, because segway europe is based in Netherland 

marjolein.hessing@segway.eu.com

Dennis Hardholt
President Segway EMEA

 

Thanks Jojo33. I would really appreciate any help, to spend €800 and not be able to use the device after only 60km, its really frustrating.  I PM'ed you the details. 

Edited by denzil
Link to comment
Share on other sites

14 minutes ago, Mono said:

I believe the charger could still be the culprit, even if it shows green light. Broken chargers are relatively common in my experience (though I don't have a Ninebot) and it is relatively easy to test/fix.

I really hope its a charger, it will be an easy fix, if it is. The unit itself works just fine, but only have 10% battery left.

Link to comment
Share on other sites

Well @denzil here a good new ! Segway Europe ansewered to my request for you, below the message from Segway Europe

 

Dear Joris,
 
We are very sorry to hear this, we are immediately contacting the customer and will solve it with him.
 
The contact form that was filled in by the customer is not related to the webshop, therefore it took a longer time to reply unfortunately. If he would have contacted our online shop through this link:https://shop.segway.com/ie-en/contact-us
others.jpg
Customer support: Blenheim House, Buckenham Road. NR17 1NQ Attleborough. United Kingdom. Telephone: +353 766 805406. Email: support-ie@segway.eu.com
shop.segway.com
the issue would have been solved by our team already. We are sorry this confusion has caused this delay. We will deal with this service issue with high priority.
 We will solve the issue with the customer accordingly.
 
Marjolein Hessing
 
Marketing Communication manager
Segway Europe

:lol:

Link to comment
Share on other sites

Thanks man, appreciated it very much! But I'm not that hopeful. I spoke to Segway UK today and they promised many times that someone will contact me TODAY to resolve it, well its an end of a day and no one has. I'm pretty much loosing my hope.

Link to comment
Share on other sites

 

43 minutes ago, jojo33 said:
The contact form that was filled in by the customer is not related to the webshop, therefore it took a longer time to reply unfortunately. If he would have contacted our online shop through this link:https://shop.segway.com/ie-en/contact-us
Marjolein Hessing
 
Marketing Communication manager
Segway Europe

:lol:

And this is not actually true, this is exactly the form I used, its been two weeks now since I posted it.

Link to comment
Share on other sites

Yes, thanks jojo33 for your help, Segway finally answered to my email and looking for a faulty unit return, soon they receive it - ship a new one. But it proven to be a challenge to ship that heavy unit also containing batteries under personal account. They offered to organise collection, so I asked for this, I'll keep you posed soon I receive a new unit, hopefully.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...