Jump to content

EUC World App Connection issue (Black Circle)


Recommended Posts

I am trying to connect my Begode T4 Pro to the EUC World app on my Google Pixel 8 Pro. I am able to connect to the Begode app and install the latest firmware. But when I use the Begode app it crashes all the time. So I want to use the EUC World app. When I connect the EUC World app my wheel connects for a second then disconnects. I have tried a couple troubleshooting methods. The first, I deleted and reinstalled the app. Second, I open the app turn on my wheel try to connect and then I turn off my wheel turn it back on and try to connect again but no luck. Third, I tried clearing cache memory for the EUC World app and it doesn't,t work. Below are screenshots showing the steps I took trying to connect my wheel. 

If anyone can help that would be great. If anyone knows the developer and can send him this discussion that would be great!

 

Screenshot_20240530-142618.png

Open the EUC World app

 

Screenshot_20240530-142644.png

 Clicked the Bluetooth button and select GotWay_000033

 

 

Screenshot_20240530-142653.png

Click connect button with no password because Begode doesn't have a password on the wheel

 

Screenshot_20240530-142702.png

The EUC connect button goes green for 1 seconds and then switches to black and seems disconnected.

  • Like 1
Link to comment
Share on other sites

1 hour ago, ejfinger said:

The EUC connect button goes green for 1 seconds and then switches to black and seems disconnected.

Make sure the Begode app is not running in the backround. 

Link to comment
Share on other sites

11 minutes ago, Paradox said:

Make sure the Begode app is not running in the backround. 

I just retested making sure the Begode app was forced closes before trying to connect again. But that didn't not help unfortunately.

  • Like 2
Link to comment
Share on other sites

Posted (edited)
1 hour ago, ejfinger said:

I just retested making sure the Begode app was forced closes before trying to connect again. But that didn't not help unfortunately.

Try a different phone.  It could be a bad bluetooth card inside the wheel too. 

Edited by Paradox
Link to comment
Share on other sites

3 hours ago, ejfinger said:

The EUC connect button goes green for 1 seconds and then switches to black and seems disconnected.

The bluetooth in my 18XL is very weak.  I have to velcro the phone to the top of the wheel to stay connected.  Try moving the phone very close to the wheel.  If it connects gradually move away and see how far you can go. 

Link to comment
Share on other sites

I have the same issue with my new commander mini with the latest.

Steps Taken to Troubleshoot:

  1. Ensured that Bluetooth is enabled on my smartphone.
  2. Verified that no other Bluetooth devices are connected that could interfere with the connection.
  3. Restarted both the Commander Mini and my smartphone multiple times.
  4. Forced closed the Begode app and DarknessBot to avoid any conflicts.
  5. Cleared cache and data of the EUC World app, and uninstalled and reinstalled the app.
  6. Attempted to pair the EUC directly through the EUC World app by scanning for devices.
  7. I have no issues connecting with the DarknessBot or Begode app with my commander mini but I don't wanna use those app. 

I paid premium for EUC World and I would like to use it with my new wheel

video of what's going on

  • Like 1
Link to comment
Share on other sites

On 5/30/2024 at 9:00 PM, ejfinger said:

If anyone can help that would be great. If anyone knows the developer and can send him this discussion that would be great!

Send an issue report from the app menu. I've noticed that Begode started to use different Bluetooth module that is currently not supported by the EUC World. I'm working on adding support for these modules, so detailed technical info that may be stored inside a issue report would help.

  • Like 2
Link to comment
Share on other sites

On 6/3/2024 at 1:52 AM, Seba said:

Send an issue report from the app menu. I've noticed that Begode started to use different Bluetooth module that is currently not supported by the EUC World. I'm working on adding support for these modules, so detailed technical info that may be stored inside a issue report would help.

I sent an issue from the app few days ago, I included as much information as I could but I'm not sure what kind of technical information you would need exactly?

I sent information about the EUC I had that was working with EUC world and the one that doesn't

What kind of technical information would help you?

Link to comment
Share on other sites

10 minutes ago, syslol said:


What kind of technical information would help you?

@Seba

Link to comment
Share on other sites

26 minutes ago, syslol said:

I sent an issue from the app few days ago, I included as much information as I could but I'm not sure what kind of technical information you would need exactly?

I got everything I needed, thanks. Seems yout T4 is using another BLE module that is not yet supported by EUC World. I will work on this, so maybe next EUC World update will include support for your T4.

Link to comment
Share on other sites

Posted (edited)
5 minutes ago, syslol said:

I don't have Begode T4, I have a Extreme Bull Commander Mini 

So it seems that you didn't sent me an issue report. When I wrote about T4, I was referring to issue report sent by another user (probably @ejfingerThe only info I got that may match your problem is from Pascal, containing only desctiption of the problem. This is not an issue report. To send an issue report you have to open EUC World menu, scroll down to Support and tap on Report issue.

Edited by Seba
  • Like 1
Link to comment
Share on other sites

1 hour ago, Seba said:

So it seems that you didn't sent me an issue report. When I wrote about T4, I was referring to issue report sent by another user (probably @ejfingerThe only info I got that may match your problem is from Pascal, containing only desctiption of the problem. This is not an issue report. To send an issue report you have to open EUC World menu, scroll down to Support and tap on Report issue.

Thanks for being awesome, Report issue submited

Link to comment
Share on other sites

I have a good news - I have just tested support for new BLE modules and it works. I hope to release an update within next few days.

  • Like 3
Link to comment
Share on other sites

On 5/30/2024 at 12:00 PM, ejfinger said:

If anyone can help that would be great.

I have tried many watches. Everyone always has connection issues. Until I use this Motorola flip and its likes, no more dis-connection issue. Check it out, just a little more expensive!

Health watch euc.jpg

Link to comment
Share on other sites

On 6/3/2024 at 1:52 AM, Seba said:

Send an issue report from the app menu. I've noticed that Begode started to use different Bluetooth module that is currently not supported by the EUC World. I'm working on adding support for these modules, so detailed technical info that may be stored inside a issue report would help.

I just got a Begode Extreme and have had a different issue that I'm hoping might be related. I can't connect to EUC World unless I first connect to the Begode and then switch to EUC World without force closing the app. It is like the Begode app needs to do the handshake first and then it will work. Should I still submit the issue in the app or would this likely also be related to the module you are working to support?

Link to comment
Share on other sites

10 hours ago, enpixelate said:

I just got a Begode Extreme and have had a different issue that I'm hoping might be related. I can't connect to EUC World unless I first connect to the Begode and then switch to EUC World without force closing the app. It is like the Begode app needs to do the handshake first and then it will work. Should I still submit the issue in the app or would this likely also be related to the module you are working to support?

I think it's related, but you can send me an issue report so I can verify this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...