Jump to content

Recommended Posts

I am selling my ks18xl I'v 333mi/537km on the wheel. The wheel rides great, super smooth and reliable. some minor scratches on the footpads and sides of the wheels. This is a great wheel to start and grow with. I am asking for $1100.

Share this post


Link to post
Share on other sites
Posted (edited)

How old is it?  Have you had any problems with the lift sensor or the trolley handles?   What has been your range on it?  Is it white or black?  Does it charge to 100% and hold it when not being used? Does it charge to the full 84V? thanks for your answers in advance.  And lastly it's a XL and not an L right?  I have been fooled once before on this.

Edited by Paradoxedgewater

Share this post


Link to post
Share on other sites

Assuming that it is actually an XL and checks out functionally, sounds like a great deal.

Share this post


Link to post
Share on other sites

yes this is an XL. It is the rubber black style. I ordered it back in Jan 2019 from Jason at ewheels.com. I rarely charge it to 100%. The only time I do that is when I know I'm going on a 20+ mile trip. I try to keep it around 70% when I'm not going to ride right away. The lift sensor has been working perfectly for me.  Right now at 85% charge it is at 82v.

I took some pictures of the wheel but not sure how to upload it to this post.

Share this post


Link to post
Share on other sites

Without charging it to 100 percent the battery balancing system has not had a chance to do its job.  The battery balancing works when it is near 84V.  It tops off the batteries to make sure they all have an equal charge.  I suggest you charge to 100% at least once a month when using it.  Less when storing it.  Could you charge it up and let me know if it charges to 84V?  Battery balancing also takes place after the green charge light comes on so you should leave it on the charger for an hour after the green light comes on when balancing the batteries.  (once a month).  I am in edgewater so I may want to take a look at this EUC. 

Share this post


Link to post
Share on other sites

I just charged my 18L up and the red charging light on the charger stayed red for 30 minutes after the app reported 100% battery.  The battery continued charging up to the 84.2v. 

As long as it charges to 84v.  its good.  they are not perfectly calibrated so your wheel might be slightly different.

Let me know with a screenshot of the app showing the voltage. 

KingsongA.jpg

Share this post


Link to post
Share on other sites

Hi all, it looks like my account has a limited number of replies for both public and private messages. Please reach out to me at darkdwhite.prime@gmail.com for any further questions.

 

Thanks

Kevin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...