Jump to content

V12 Automatic Headlight ...Not!

Jeff Earl

Recommended Posts

Curious if anyone else has a V12 with an inoperative automatic headlight. I've been enjoying an otherwise perfect V12 for about two weeks now. Loving it so far, but the headlight only works in manual mode. I can operate the headlight at all intensities (off, low beam, high beam, both) but in automatic mode it never illuminates regardless of the ambient light level--even in pitch black conditions. I've tried adjusting the threshold values in the app as well. ...no luck.

Upgrading the firmware to V1.4.5 made no difference either. I carefully dissected the case and traced the connections from the photo resistor to the contact PCB in the top cover. Measuring the resistance across the contacts seemed to show a normal operating range ( ~200 ohms -> 380k ohms) from light to dark. I assume the problem is deeper in the control circuitry, but have not pulled the main controller yet. Since everything else is fine, I'm reluctant to start scraping off the Silastic and disconnecting harnesses. And unless there's something brutally obvious (like a smoked component) I'm not sure I have the expertise to diagnose the issue any further.photo-resistor2-lr.thumb.jpeg.bcfda00e39bbf3da63823f65570349cf.jpegphoto-resistor1-lr.thumb.jpeg.28ab5380d55bc351c813ffd783c0e7fc.jpeg

Does anyone else's V12 suffer from the same defect? I've been in contact with Jason and team at EWheels and they have been extraordinarily responsive, as usual. A big shout-out to them!  

Given there are many other new V12 owners with far more serious issues to resolve, I suspect this will take quite a while to prioritize and fix. Nevertheless, It could be helpful to know if this is just a one-off failure, or a more prevalent problem with the V12 design or implementation. Has anyone else seen this problem? Any other insights or ideas to share?

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

I am having the same problem, after a couple of weeks that auto lights worked just fine now they turn on only manually. 

Where is the light sensor situated? I'm not able to see it.
However sometimes if I turn on the EUC in a low light environment the lights turn on and work correctly, that makes me think it's a software or calibration problem.
How did this ended up for you?

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

The sensor is right in front of the power button--maybe 1.5-2cm forward. You really cannot see it from the outside; even with a strong flashlight. I needed to replace the motherboard to get mine working. The motherboard is mounted above the motor controller board in the electronics module. You may want to view some of the on-line tear-down videos of the V12 before you decide to repair it yourself. It's not that difficult, but there are a lot of screws and connectors involved, and some of the connectors have the nasty habit of detaching from the circuit board rather than separating cleanly at the pins. Good luck.

  • Upvote 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...