Jump to content

18L Trolley handle stuck open at half way


Recommended Posts

Hi All, I just got this wheel and the handle was working normally and all of a sudden got stuck half way down and both lower parts of the struts will not move down with the handle button pressed in.

I can see the locking pins on the upper part move in and out with the button but the lowers won’t budge.

any ideas on a fix ?

 

thanks 

Link to post
Share on other sites
4 minutes ago, TomOnWheels said:

What color ? Gray or black ? If gray then it's an old version, incredibly fragile... You should contact your seller for an upgraded version.

Grey - and bought second hand so not sure I can get any warranty 

Link to post
Share on other sites

Just fixed this issue on an 18xl. You will likely need to open up the side of the trolley that is stuck and press in a metal peg in the inner rail of the trolley. 

Link to post
Share on other sites
6 hours ago, TomOnWheels said:

What color ? Gray or black ? If gray then it's an old version, incredibly fragile... You should contact your seller for an upgraded version.

This! And get big pedals while you're at it. Mine is an 18L and came witht he grey bars and they were finicky. I ordered the updated black (2 pairs) and install wasnt too bad. Just DO NOT use loctite near your palstic shell. After 1000 miles, the upgraded trolley still works perfectly and my backup set is waiting...waiting...waiting to be of use someday. Just be careful with the lift sensor and don't overtighten it. Freaking amazing wheel, I dont regret buying it as my first wheel and it's still my fav after over a year. Oh, and the big pedals are awesome. Very comfy, not much need to add grip or spikes to these. NIce and flat angle, big surface, perfect compliment to the already uber comfy 18L. Don't forget a ROllNZ cover, when you want to look great, protect the wheel, AND increase comfort.

Edited by ShanesPlanet
Link to post
Share on other sites

Ok so I stripped out the struts so I could access the lock pins in the lower struts and both were  jammed.

I got one strut working but no chance on the second strut.

I drilled out the 3mm peg at the bottom of the strut and slid out the mud section that houses the lick pin mech.

it’s worn and jammed up beyond repair unless someone has an old grey strut I can take one out of.

looks like I’ll be ordering some black ones

60FF3B25-D8D0-44C3-9C8D-0AC4808ED988.jpeg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...