Jump to content

KS18L will not turn on new out of box...help!


Tmankins
 Share

Recommended Posts

I'm new to the forum as a member, but have been reading posts and learning about EUC's here for over a year now and finally got the nerve to purchase a new Kingsong KS18L from Jason at ewheels last Friday. The wheel was drop shipped from California on Saturday and arrived at my house last night with no apparent damage to the shipping box.  I unpacked the wheel, held it upright and turned it on and the wheel started beeping two quick beeps with a 2 second pause, no lights or charge level indication or self leveling, just constant beeping.  I looked online without success for any Kinsong audible alarm codes and nothing to be found so wondering if anyone on the forum has any advice.  Another weird thing is that if the unit is off, charger plugged in and I grab the handle, it will start beeping once every three seconds and then if I hit the power on button, the beeps change to a repeating 2 short beeps, one beep then 2 short beeps and repeats this until I turn it off.  If it is on and I roll the wheel, the beeps are 1/sec continuous until I stop rolling it and then it goes back to its original beeping.  The headlight/taillight on each side will briefly turn red when rolling it but no LED's.

I tried connecting my phone (galaxy S4, BT at 4.0, Android at 5.0.1) and it see's both the KS18L and the audio Bluetooth systems, but will only connect to the audio and I can play music and watch the LED's flash to the music, but it will not connect to the wheel itself which could be helpful in troubleshooting it.  Tried may times cycling power etc. Bluetooth on/off and could not get connected.  I put the wheel on its charger for over 6 hours thinking maybe the alarm was an indication of too low battery, but it's still doing the same thing. 

I sent Jason an email last night, but haven't heard anything back yet and since I want to get the wheel going and start learning how to ride it, I was wondering if anyone else has had a similar problem and what the fix was.  I'm guessing it could be a controller board replacement issue or maybe a connection that came loose in transit, but at this point I have no idea and the Kinsgsong.com website has  zero useful troubleshooting information so any help would be appreciated.  I currently feel like I purchased a mediocre $1800 Bluetooth speaker with LED's and my excitement for finally pulling the trigger and purchasing a EUC and learning how to ride it has been crushed.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

21 minutes ago, Tmankins said:

I tried connecting my phone (galaxy S4, BT at 4.0, Android at 5.0.1) and it see's both the KS18L and the audio Bluetooth systems, but will only connect to the audio and I can play music and watch the LED's flash to the music, but it will not connect to the wheel itself which could be helpful in troubleshooting it.  Tried may times cycling power etc. Bluetooth on/off and could not get connected.  I put the wheel on its charger for over 6 hours thinking maybe the alarm was an indication of too low battery, but it's still doing the same thing. 

Have you given the KS app all Rights? Like Location, Bluetooth etc? Thats important that it is allowed to check Location.

Normally i would say this Sounds like the -unfortunatly- known "Serial number forgotten" Problem, which is easy fixable, but in the end still Needs the Wheel to be able to contact to the app.

Whatever: Try connecting the Wheel to the app….try download a "Bluetooth Tracker" app...this app should be able to "see" the Wheel.

It must say something like "KS18L2Bxxxxxxxx" when recocgnizing the Wheel.

 

But whatever: Jason is the Right Person to contact!

If it is the "forgotten Serial number Problem" he might be able to help online...if it is something worse, you might Need sending it back...

 

 

Edited by US69
  • Upvote 1
Link to comment
Share on other sites

@Tmankins

Sorry,  forgot something!

Do you have a sticker on the Wheel, which says something like: "go into app and unlock the Wheel" ? 

Lately KS send their Wheel "app locked"....to Prevent them from powering on in the box!!!

 

So continue connecting it to the app...you have the latest app, or??? V.150 on Android....White/orange user interface! With the old green app you will not be able todo anything…

 

Edited by US69
  • Upvote 3
Link to comment
Share on other sites

3 minutes ago, US69 said:

@Tmankins

Sorry,  forgot something!

Do you have a sticker on the Wheel, which says something like: "go into app and unlock the Wheel" ? 

Lately KS send their Wheel "app locked"....to Prevent them from powering on in the box!!!

 

So continue connecting it to the app...you have the latest app, or??? V.150 on Android....White/orange user interface! With the old green app you will not be able todo anything…

 

What about all the beeps? Do you have a cheat-sheet that defines what all the different beeps mean, like what we have for Gotway???

Link to comment
Share on other sites

8 minutes ago, Marty Backe said:

What about all the beeps? Do you have a cheat-sheet that defines what all the different beeps mean, like what we have for Gotway???

No, not yet….but after reading the thread once again, i am quite sure it is just the lock Alarm....Music can be played, LEDs working, the 18L can be seen on BT as a Wheel....

Perhaps really the old KS app is used which can not unlock the Wheel! Unfortunatly Jason has old Infos on his Website where he recommends using the old app to Speedunlock the Wheel!

But thats no Speed unlock...it is a lock which prevents the Wheel from powering on...On the correct app you just have to push one button and you are Ready to go!

There are Stickers on the Wheel saying "unlock me in app first"...….

Edited by US69
  • Like 1
  • Upvote 1
Link to comment
Share on other sites

9 minutes ago, Marty Backe said:

What about all the beeps? Do you have a cheat-sheet that defines what all the different beeps mean, like what we have for Gotway???

Aaah, and btw.: There is mostly only one "outside" Alarm for KS (beside normal Speed Beeps)

That is the 4 LED on...Serial number forgotten...

All the rest: Hall sensors A and B, Motor temperature etc etc and also missing Serial number are in the meanwhile diagnosed by the app...under "detailed Parameters"

Edited by US69
  • Like 1
Link to comment
Share on other sites

Thanks for the replies. 

The unit does have a sticker that indicates the wheel needs to be unlocked before use which I figured I could do when I got the KS app connected, but my Bluetooth on my phone will not connect to the wheel and has the error: unable to communicate with KS-18L-06xx. I've connected to countless Bluetooth devices with my phone and tried all of the tricks I've used in the past to get it to connect, but no luck.  I worried that the battery might not be taking a charge as the charger never turned green, so I just now took the cases off and measured each battery separately by unplugging from the unit and they each read 81.9vdc which should be pretty close to full charge.

The weird problem with the wheel being plugged into the charger and beeping when I touch the plastic handle has me concerned as it doesn't do this when the charger is not plugged in and almost like my static discharge when touching the handle sets something off which makes me wonder if there is a pinched wire or something that started shorting out in transit.  I'm retired with a degree in electronics and have 35 years of experience with design, troubleshooting and repair of much more complex devices and systems than this, but I usually had a schematic and a good user manual to help out, but this thing I feel like I'm flying blind.

  • Like 1
Link to comment
Share on other sites

Maybe I'm trying to connect Bluetooth incorrectly.  On all devices that I have connected to in the past, I turn on Bluetooth and scan for devices and then select the device and hit connect.  Does this wheel require the KS app to initiate the Bluetooth connection or something?  The audio player connects fine just like I have always done with other devices.

Link to comment
Share on other sites

1 hour ago, Tmankins said:

Maybe I'm trying to connect Bluetooth incorrectly.  On all devices that I have connected to in the past, I turn on Bluetooth and scan for devices and then select the device and hit connect.  Does this wheel require the KS app to initiate the Bluetooth connection or something?  The audio player connects fine just like I have always done with other devices.

You do not connect to the wheel via your phone bluetooth, like you do with a Bluetooth speaker, keyboard, etc. Except of course if you want to use the KingSong Bluetooth speaker. In that case, on your phone, look for KingSongMusic, or something similar.

For monitoring and controlling your wheel, you launch the KingSong phone app and the app will then connect to the wheel.

  • Upvote 1
Link to comment
Share on other sites

 

24 minutes ago, Marty Backe said:

You do not connect to the wheel via your phone bluetooth, like you do with a Bluetooth speaker, keyboard, etc. Except of course if you want to use the KingSong Bluetooth speaker. In that case, on your phone, look for KingSongMusic, or something similar.

For monitoring and controlling your wheel, you launch the KingSong phone app and the app will then connect to the wheel.

Marty is correct.  You need to download the app first. 

I got the KingSong app a month before I got my wheel and it took Two months to get the app working on my iphone.  I can see a good reason for frustration.  It kept telling me “lovely notice wrong number” 

I got the DarknessBot working  in 5 minuets but that won’t help unlock the wheel. 

  • Like 1
Link to comment
Share on other sites

I installed the Kingsong app from the Kingsong.com website for Android last night and when I launch the app, it turns my phones Bluetooth on but fails to connect to the wheel with a "failed to connect" error message, but does connect to the audio Bluetooth and the wheel annunciates that Bluetooth is connected. I have removed the side covers and top cover and looked for issues on the wheel like loose connections or pinched wires and everything looks good.  There are two blue LED's on the controller board that blink and when the phone connects to the audio app one of them quits blinking.  There are also 4 red LED lights on the control board that are on solid.  Not sure what they are indicating as Kingsong doesn't seem to have any information on such things as alarm codes or LED error codes. I'm not sure what to do at this point.  I've thought about trying to borrow someone else's smart phone to try out, but everyone I know has an iPhone.

US69 mentioned allowing the KS app all rights, but I was unable to find anything in the app that is configurable like that and don't know how to check for the version, but it is the one that is on the Kingsong.com site for Android with a grey background and speedometer colored from green to orange.  

I am now officially insane as everyone knows the definition of insanity is trying the same thing over and over while expecting different results.

Link to comment
Share on other sites

3 hours ago, Tmankins said:

Maybe I'm trying to connect Bluetooth incorrectly.  On all devices that I have connected to in the past, I turn on Bluetooth and scan for devices and then select the device and hit connect.  Does this wheel require the KS app to initiate the Bluetooth connection or something?  The audio player connects fine just like I have always done with other devices.

As others said...you lounch the app....if no automatic connect is happening...you tap “connect” button....

A new screen will appear...you have to tap into the white “search” field above (not very intuitive)...

then your wheel serial number should show up..tap it...done...connected!

 

For the rights:

That is not set in the app...you have to set that in general settings of android...Location allowed?

 

When hou have the right app...after connecting you just tap the Unlock button...done!

 

Now after all your explanation and the sticker on your wheel...you are certainly just in lock mode...have todo the unlock button. Thats it..

 

Sorry for your troubles....

 

EDITED....

Edited by US69
  • Like 2
  • Upvote 1
Link to comment
Share on other sites

Thanks for the help US69.  I have the grey background orange speedometer app and it has a Bluetooth icon that has the text "disconnected"  that when I touch it, the app goes to a screen that says it's searching for the device and it just continues without finding anything. Frustrating.

Link to comment
Share on other sites

10 minutes ago, Tmankins said:

Thanks for the help US69.  I have the grey background orange speedometer app and it has a Bluetooth icon that has the text "disconnected"  that when I touch it, the app goes to a screen that says it's searching for the device and it just continues without finding anything. Frustrating.

Yeah...and when you are on that next screen...you have to tap into the searching field (which is totally counterintuitive...but will do the job!!!)

  • Upvote 1
Link to comment
Share on other sites

2 hours ago, Tmankins said:

Thanks to all for the help.  US69, I did like you said and ended up tapping on the "searching" wording on the Bluetooth screen and it brought up the KS18l and I was able to connect and unlock the EUC and the beeping stopped, so thanks for hanging in there to help me out. Counterintuitive is and understatement. 

I have to go to an event and when I get back I will put the wheel back together and see if it starts self leveling etc. like a good EUC should.

 

Thanks again for all of the help.  This is a great forum with really helpful individuals.  Now, if the wheel works correctly I can go to the next level and try not to do bodily harm to myself trying to learn how to ride this thing.

Tom.

I think you owe @US69 a good stout German beer :D

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...