Jump to content

KS14c: connected to the app —> crashed and locked!

Denny Paul

Recommended Posts

Hey all. Need some help. 

So I bought a 2nd hand KS14c from a reputable member recently, it worked flawlessly for a half hour. Had a blast. Then I tried connecting to the app. 

I checked to see the latest firmware of the EUC through the app, the app said it was up to date, no update required. Then the wheel suddenly turned off on its own with a nearly full charge. 

Now I can’t turn the wheel on. No lights or sound upon pressing the button. If I hold the power button down I can connect to the Bluetooth speakers and play music, the wheel won’t balance thought there is a little resistance to rolling, and I can connect to the app but it seems to be a restricted amount of info. As soon as I release the power button I lose all of the above functions and the unit seems to turn completely off. Some screenshots are posted as links below. 

Can anyone shed some light? Previous owner suggests trying to figure out the last compatible version of the app with the 14c which makes sense. Anyone know?





Thanks. Sincerely appreciate any and all help.

Edited by Denny Paul
Link to comment
Share on other sites

I'm actually the seller. 

This is what I wrote him.

The present KS application may be incompatible with the KS14c. It's connected, but apparently not playing nice. There should be a screen that shows the complex serial number, maybe under settings?

You should see many settings including the firmware version. Especially the firmware version. And the mileage.

I suspect you'll need to get an older version of the KS app, then reconnect properly to it. Then when you see the firmware version number exposed, that should allow the wheel to be reset to be rideable. I hope.

I recommend posting on the forum, perhaps in general or modifications, along with the screenshot you sent me. And asking for the last known KS application that's compatible with the KS14c. That might knock the wheel out of its apparently frozen state.

I also wonder if a forced firmware update bricked the wheel.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...