Jump to content

New Firmware bricked my KS-16B ?


Recommended Posts

Hi all.

I have read others having the same issue on the sport model.
Did a firmware update today, the android app crashed at 13%.

The lights on the side of the wheel just show up as static white and it is not self balancing when i turn it on.
I can still connect via bluetooth but i get no battery status etc.
The attached screenshots show what happens when i try to upgrade again.

(I used a screenshot posted by someone here earlier but i get the excact same screen on my phone)
I have tried 2 samsung and 1 hawei phone, also tried a huawei tablet. (tried app version 1.50 and 1.52) 



Link to comment
Share on other sites

Unfortunatly there also was a bug in the app, that sometimes give a update prompt, while there is no real new update available. 

So perhaps this happened here....servers should be online...

you should contact your seller, he should be able to supply you the „engeneer app“ , with that App you can reset the firmware.

If for any reason the seller can not help, contact me by PN...

Link to comment
Share on other sites

Thanks @US69 for that quick reply .
The servers were up, i analyzed the traffic on my network and saw that there were no issues there.

I can't send PMs since i am a new member and don't have enough posts/rep yet.

I called the reseller in my country and they told me they did not know how to use the 'Engineer App',
so if you could PM me the instructions or another way to contact you that would be awesome.

Thanks again :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...