Jump to content

EUCO - Faulty control boards?


Ben_
 Share

Recommended Posts

Hey everyone,

I was browsing the /r/ElectricUnicycle subreddit and saw a post of a memo sent out by EUCO saying that the last two batches of V11's delivered to them had faulty control boards. It continues saying that the faulty boards caused cutoff during normal riding, and especially while braking. Has anyone heard of this? Do we know if eWheels batches have been affected? I just bought a V11 from eWheels in the last 2 weeks and really don't want to send it back.

bjgug6dd4ld61.jpg?width=640&crop=smart&a

Original reddit post

  • Like 1
Link to comment
Share on other sites

From what I read on the forum's FB page, the V11 eWheels received is not as impacted to the point that they have to do the same thing as EUCO did.

My controller was dead-on-arrival, causing the wheel unable to power on. Rode the wheel for a month and it's fine so far.

I'm sure they will sort this out if this happens to you.

Edited by madbikes
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...