Jump to content

Recommended Posts

Would love to hear feedback from others but in November I purchased the Segway S-Plus. After getting the product it would not allow me to complete the tutorial.. (it would get stuck on the remote part and I would complete the 5m but the “next” button wouldn’t pop up so I could never fully unlock it.) after weeks of trying to deal with terrible customer service from Segway and trying to reset it I was told I would have to send it back because there was a glitch in the software... I did that and got a new one sent back which luckily worked great! Then my Car and my Segway was stolen a short time ago... I reordered the S-Plus and now it’s having the EXACT SAME PROBLEM!! This is a 850$ machine and this is now twice where it can’t get past the tutorial... I have already tried to factory reset this one twice and delete the app and it’s still getting stuck on the tutorial... I would love to hear if others are having similar problems because this is ridiculous in my opinion... (on top of it a supervisor was supposed to reach out within 24 hours after I called a few days back and I’m sure you can guess that did not happen either) I hate to be a complainer but I just wanna fix the problem because I rely on this machine for work...


Link to comment
Share on other sites

6 hours ago, Sportz112 said:

I hate to be a complainer

Non, you are not a complainer

Our Mini needs often a " Do it yourself attitude "


Waiting someone experienced your issue, i will try to help you

1/ were you able to download the latest firmware version? Or app is locked with the tutorial ?

2/ have you finish remote control tutorial ? Could you try Switch between tutorial s and again launch remote tutorial ?

3/ try lock and unlock your mini with remote and with app

4/look for the old hard reset with your plus

5/  i think tutorial step by step dont load correctly and dont send user data correctly to ninebot server, all is ok about 4g connection with the app ?

6/ good to clear cache and close app like you did

7/ Android phone can not allow many autorisation for the app, please check if all autorisation are ok for ninebot segway App

8/ try after turn off, disconnect steering connector, turn on, turn off and reconnect

Sometime there is overload with the steering

9/ after   totaly sign out in the app,  change région (take Europa) and login, search for firmware, try tutorial (european server)

Because i could one time download a usa firmware version not released in Europe

Last week in Europe we get a new firmware

With a firmware Always tutorial is integrated with.

10/ your mini is correctly activated ? 

In each case try and try again launch tutorials and do it again (remote too), switch

I have understood its a firmware issue but all i have sugest before could bring 

You can read similar issue with mini pro

(Sorry i cant delete topic 412 its a paste error)




Link to comment
Share on other sites

Hey jojo33,

Thanks for taking the time to try and help... I did the above steps mentioned and unfortunately no luck... I completed the first 2 tutorials but unable to finish the remote... Right when I connected the Segway for the first time it asked me to update to new software... I did that. is there a way I can delete that software and start with the bare bones? 

Link to comment
Share on other sites

Update... Apparently the choice of app is a huge problem to the puzzle? I factory reset it for the third time but this time downloaded the Segway “global” app... Not sure if I was supposed to be using this all along? But the tutorial is complete and Segway is unlocked!! Thanks for helping me thru the problem



  • Like 1
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...