Jump to content

V10F Red Battery Lights after 2.2.8 Upgrade


Recommended Posts

I recently bought a V10F from a friend. The serial starts with 124. He told me he opened the unit once to add additional water proofing (following official instructions, presumably).... but otherwise rode it a total of <5 miles. He said he never actually used it in wet conditions. This is my first EUC, but I have some experience with electric scooters.

When I got it, everything seemed normal, save for a flat tire from being unused for a year.

I charged it and upgraded the firmware. At this point, weird things are happening.

1. The battery display, instead of showing a blue battery outline with 5 sections, it consistently displays one red section at the bottom, and one yellow section on top of that. Additionally, the Red Exclamation Mark is always lit. The battery outline is not shown, or displays very faintly.

2. The speakers will connect to Bluetooth, but no other sounds play. No power up/down/handle button sounds at all.

3. The App tells me battery is full, and diagnostics say the wheel is good. Headlamp turns on/off fine. Brake light activated as expected.

4. It seems to self balance and ride normally. However, if you just tap the power button once, it stays on for 1-5 seconds, then powers itself down, all while showing the same red+yellow battery lights.

5. Except, occasionally when powered on, it seems to drift it’s balance forward/back, almost as if it can’t seem to find “flat”

6. I’ve tried recalibrating the wheel when on its side (after the update). No luck. I’ve tried power button + handle button, no luck. I’ve tried erasing the flash, no luck (but minor changes to reported issues).


here’s an image of the display, taken from a video.





anybody have any idea what’s wrong or how to fix?



Super exciting to be rolling around asap!

Link to comment
Share on other sites

  • 4 weeks later...

It really seems that the update compromised everything, as you said the problems began after you updated it.

I bricked my V10F by just uploading custom suonds via inmotion app, I suppose the same may happen with a non successful firmware update.

Reach out to inmotion, I wish you to solve your problem effortlessly👍🏻

If you want to direclty replace the main board, I am not sure which of the two boards on the wheel stores the firmware, so I hope inmotion or some other riders will come in to help you😊

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...