Jump to content

King Song S18 (KS-S18) won't turn on [SOLVED]


Recommended Posts

My KS-S18 fell over on its side onto a rock, which chipped the top shell. When I righted the EUC, I couldn't turn it on. Even after removing the top shell, holding down the power button does absolutely nothing. No lights, no sound, no LEDs on the control board. Dead as a door nail.

I don't see anything physically damaged in the electronics. The charger turns red (charging) when I plug it in, but nothing else happens.


I desperate for advice on how to fix this. Any advice?

Edited by Kayvon
Link to comment
Share on other sites

6 hours ago, Kayvon said:

I figured it out! You're not going to believe this...

It's a single component on the control board marked Q27. That's a small NPN transistor with a G1 marking.

Hopefully this is useful to someone else in some way.

a picture would be nice too ;)

Link to comment
Share on other sites

  • Kayvon changed the title to King Song S18 (KS-S18) won't turn on [SOLVED]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...