Jump to content

flashing eror codes 3 then 9 after mod

Recommended Posts

So I had my ninebot mini working as a mule to pull a wheelchair.  I have a big dog and I cannot walk fast enough to exercise him.   I made an extension bar that connected to the knee pads to try and control it.  It sometimes got away from me.


I tried a more serious mod, and I took the wheels of the mini and replaced the wheelchair wheels. 

I made a foot brace to hold the mini body, and had it so that it pivoted on some pipe that I put in the original wheel mounting blocks on the mini.  I extended the wires from the wheels, including the 5 control wires.   

When I powered up the mini I get 3 flashing lights followed by 9 lights. 

I inverted it and powered it on, hoping that a reset would fix it….. No good.  Even upside down I get 3 flashes followed by 9 flashes.

I looked for error codes, and see some listed, but none had a 3 followed by 9.


I hope that I did not blow the board. (I did have trouble getting the control cables disconnected and I ended up pulling the cable and the tan sleeve on both sides  

I can try putting it all back together, but before I do that I wanted to see if anyone can tell me what the error code is.   I have soldered the leads and sensors to disconnects on both ends. 

 I suspect that it is a communication error and it does not like the extension of the control leads. (I guess that is I hope it is this, better than a blown board)  I did use cat5 twisted pair cable to try and keep noise down…..  It could also be that it does not like the loss of the longer power cables.   I used 14 gage wire, which as abut as big as I could fit in the body.  I did fit disconnects on the power leads so I could make the extension section heaver…..

But I first wanted to find out what the error code is. 

Any help would be appreciated. 


Link to comment
Share on other sites

Based on the error codes published, if i interpret correctly 3 flashes followed by 9 flashes as 39, then it that would indicate a motor sensor failure. If there are 3 sensors per wheel, then it would indicate sensor 1 on wheel 2 possibly.  Don't know if left or right would be wheel 2. If there are not 3 sensors in each wheel, then my guess has no basis for identifying the sensor. 

Check your connections, is all i can suggest, the low signal sensors might be affected if the wires were extended too far, but i suspect good wire and connections could extend then 10cm-30cm without issue.

It's possible that it uses the motor wires for sensing the motor, 3 armature wires per motor? If so it would be wire 1 on wheel 2.  

Good luck, sounds cool, i'd love to see pictures if you get it working.  


  • Upvote 1
Link to comment
Share on other sites

Thanks for the help.


That is actually what I was hoping for. 

I wired it up using some cat5 cable and put in an rj45 disconnect (that I added an extra wire to get the 5 sensors).  I robbed these out of an old modem that I had.

I did the disconnects to try and make it easy to collapse and take apart.

I to try and get it running, I may double up on the wires and remove the disconnect. 

If that works, I will add in a db25 connector at the motor and leave the soldered connection to the motor in place. 


If I get it working I ill add some pictures


I will also see if I have any of it working as a mule. 


I made good use of a stainless salad bowl as a large spherical bearing with some fiberglass as the second part.


It snowed up here in Anchorage last night, and I just finished plowing the drive.  I also got a chance drive my snowmachines (my daughter corrects me, up here is =is NOT a snow mobile)....


One of them worked, the other needs a new throttle cable....


I onder if anyone has tried an electri snowmobile...... it would be hard on the batteries.... but it sure would be nice to never have to worry about them starting up...... .

Link to comment
Share on other sites

Well, I put the original sensor leads back, and connected the mini back to stock configuration.


I still get the 39 error.


I check the connectivity from the 5 sensor wires to the test pads on the mother board, and they are all good.  So it is not at the connection to the mother board. 

Since the test pads are on the back side of the mother board, I am pretty sure that I did not pull any of the leads at the motherboard end out.


So now I guess I will have ot check the control wires back to the inside of each motor.  I may have put to nuch stress on a wire and broke it off going into the motor.


The motherboard is marked HA  HB and HC


I assume hat this is Hall Effect sensor and if the error is on sensor 1, it is probably HA.... but I will try to check each of the leads.


I have to you tube how to get into the motor assembly.



By the way, I extended the leads about a meer total (by the time I ran it out of the pad, down the length of the chair and across to the far motor. 


I ran all wires out one side so that I could pivot the mini out of the way to get into the chair.

Link to comment
Share on other sites

I took one motor completely apart and   scrapped off some of the insulation on the hall effect sensors.  

All of the wires on this motor traced as good with no shorts

For those interested

Black is ground

Red is 5V dc


First (left) hall is Gray,   Black, and Red

Second is Red, Black Yellow

Third is Green, Black Red.

So I reassemble led the motor and tried to test the output:

I provided 5 v to red, and ground to black.  I then spun the motor, and expected to see some voltage on the Yellow, Green, and Greay…. Nothing on any of the 3 leads (should have been AC, but looked for both ac and dc.)

It was a cheap digital meter, so I tried an equally cheap analogue one… nothing.


I have a scope at my dad’s, but that is down in Missouri, and I am in Alaska.


I then tested it like a diode, thinking that it was a PNO (or NPN) junction.

I forget the details, but one way (could have been positive on ground measured resistance with the other one)….. I got a mid-range reading on the analogue meter at the 10 ohm scale.  I reversed the leads and got a high reading.  This was the same for all 3 sensors on each of the motors.......

So I do not think that I messed up the sensors or broke a lead


I did have a small section of the extension wire soldered to each end of the original wiring.  I may try to remove it in the next day or so and retest. 


I am beginning to suspect that when I original pulled the sensor wires, and had not properly released the locking tabs; I may have messed up the mother board.  This is looking more likely


BUT there are small test pads by each connector, and I have tested the connectivity from each of the wires to the test pad, and it is 0 ohms.  So not so sure.

 This may be a a multi- layered board, and I could have messed up an internal layer of the board.


It has been a long frustrating day, and I have some more DR appointments tomorrow.  I will try to update this when I know more. 


Any suggestions welcome.  Pretty sure that I was doing the functional ctest correctly, but not sure.


I was using a USB power supply to get the 5 colts, but it was measuring stable at 5.013 volts.

Link to comment
Share on other sites

11 hours ago, Wilsonintexas said:

I provided 5 v to red, and ground to black.  I then spun the motor, and expected to see some voltage on the Yellow, Green, and Greay…. Nothing on any of the 3 leads (should have been AC, but looked for both ac and dc.)

I think that this requires an additional pull-up.
On the mainboard this is a 2.2KR resistor provided

see the original circuit diagram...



Greeting Donald

Link to comment
Share on other sites

From the diagram, it looks like they put 5 volts to it, and it drops to ground.  That may explain why I had trouble testing it.   I will have to look into that more..... later.


for now


It has been a frustrating few days. 


I reconnected the motors to the short original leads  and the mini started up fine.

I noticed that one of the sensor leads was not totally seated, so I rewired it to the extension and it failed with a 39 again.

I then tried what I thought was a heaver gage wire and I was back to the error 39.   I then doubled up the wire on the 3 sensor wires and still error 39.

The sensors should be 5 volt pulled high.   I may be getting crosstalk or the longer lead is a delay in the signal timing.  the original  extension I used was a cat5 cable with twisted pair.   But I was not careful  the use of the different pairs.


I think that the mother board just does not like the extended leads. 

I will heck  on some other forums that deal with home built motors and see if they have any recommendations.   

If anyone here has recommendations let me know.


For now I will put it back to standard configuration and use it as a mule.  I will try to get pictures of that sometime.


Frustrating, I really wanted to get it working. 


There is another forum on electric wheelchairs, and they have a controller that works for brushless motors.  But it will cost a lot to get the controller and all of the extra parts needed.   I think I could reuse the battery pack. 


I will have to see how the money looks over the next few months.





Link to comment
Share on other sites

I did some more testing......

I am kicking myself, I hjad it working by taking it back to the original configuration, but then tried to extend the leads again, thinking I had just crossed the wires.  Back to Error code.


So I took it back to original config, and I still have the error code.   (39)


I then swapped the motors around, and the error code went to 36.


So It looks like it is a problem with the first sensor that is now motor 1.  I assume that it is hall a on the current left motor (based on the diagram above.


I have a pair of new motors coming, that I won on ebay.  After I get it working, I may take the motor apart ans see if I can trace down the problem.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...