Jump to content

Recommended Posts

Let's see if I can make this short. Had more charge than I noticed so going down a hill with the regenerative charging killed the fuse and capacitors. Thanks to Jason at ewheels I ordered a replacement board, replaced it, and I'm back on the road. ?

IMG_1439.JPG

IMG_1440.JPG

IMG_1441.JPG

Share this post


Link to post
Share on other sites

Did you ignore warnings, or did the wheel allow you to ride without beeping until something broke?

Share this post


Link to post
Share on other sites
4 hours ago, Oswald Valentine-Lopez said:

Let's see if I can make this short. Had more charge than I noticed so going down a hill with the regenerative charging killed the fuse and capacitors. Thanks to Jason at ewheels I ordered a replacement board, replaced it, and I'm back on the road. ?

IMG_1439.JPG

IMG_1440.JPG

IMG_1441.JPG

Cannot see it very well but it looks that there is nothing wrong with the capacitors. It looks like the battery+ cable came unsolvered and sparked. 

Difficult to see. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...