Jump to content

Recommended Posts

Any idea when V8F support is coming?  I got it a week ago,  it seems to appear as V8 on iOS app :) Thanks!

Share this post


Link to post
Share on other sites
13 hours ago, Trevor Phillips said:

How do I get on the beta for this app?

send me your Apple ID email in DM;)
We'll add you after we fix Gotway data reading issue.
 

11 hours ago, Ben Kim said:

ah i was about to post an issue where Gotway wheel data wasn’t displayed on connection but it looks like this fixed it. 

I'm afraid still not. 
We don't have any Gotway wheel, and were thinking that we fixed data reading problem when published 250 build. But we still have a problems, some testers can't read Gotway data.

I think Ilya fix it in next build. 

Edited by december11

Share this post


Link to post
Share on other sites
8 hours ago, genesisx2 said:

Any idea when V8F support is coming?  I got it a week ago,  it seems to appear as V8 on iOS app :) Thanks!

Send logs, please!
(In DarknessBot - Settings/About/Share logs) (please, add a subject - V8F.)
And it would be great if you can provide screenshots with Dashboard tiles and Settings/Device. 

Edited by december11
add how-to send logs instructions

Share this post


Link to post
Share on other sites

What's new in beta 5.6-251:
- Improved UI for riding mode changing
- Gotway: Fixed connection

Share this post


Link to post
Share on other sites
On 1/15/2020 at 6:54 AM, Ben Kim said:

ah i was about to post an issue where Gotway wheel data wasn’t displayed on connection but it looks like this fixed it. 

Fixed in last build.

Share this post


Link to post
Share on other sites
16 hours ago, december11 said:

Fixed in last build.

I see some new categories regarding calibration and riding mode being detailed now on Gotway. I also noticed the speedometer limit has raised to 42 mph

Unfortunately anything changed will be lost upon killing of the app. will this be addressed in the future? 

Share this post


Link to post
Share on other sites
6 hours ago, Ben Kim said:

I see some new categories regarding calibration and riding mode being detailed now on Gotway. I also noticed the speedometer limit has raised to 42 mph

Unfortunately anything changed will be lost upon killing of the app. will this be addressed in the future? 

Absolutely!

One of our Russian testers will lent us MTen 3 for several days. It’s help finally add normal support for Gotway. 🤗 

For MTen 3 at least😄 But, AFAIK all Gotway has one protocol. 
In future, we’ll add manual model selection, it let us use a specific features for different models. But this is a far future. 

For next version our priority is Kingsong calibration and all Gotway data reading improvement. 
@Trevor Phillips, Are your new MTen 3 data reading? 

And for version 5.7 it’s will be Gotway settings, I guess. 

Share this post


Link to post
Share on other sites
On 1/15/2020 at 7:09 AM, december11 said:

Send logs, please!
(In DarknessBot - Settings/About/Share logs) (please, add a subject - V8F.)
And it would be great if you can provide screenshots with Dashboard tiles and Settings/Device. 

Just sent the logs with V8F in the subject!

Share this post


Link to post
Share on other sites
2 hours ago, december11 said:

 

@Trevor Phillips, Are your new MTen 3 data reading? 

And for version 5.7 it’s will be Gotway settings, I guess. 

I checked version 251 and it said device not supported 

Share this post


Link to post
Share on other sites
12 hours ago, Trevor Phillips said:

It can see the device 

 

but not supported 

D9C189AE-F5C8-4CA8-AC8F-AFA717A318C0.png

The new Gotway party will be supported in next version

Share this post


Link to post
Share on other sites
On 8/7/2019 at 6:15 AM, mrelwood said:

Issues with DarknessBot that weren’t there a year ago, but are quite troublesome today. Don’t know when they changed exactly though.

- The app crashes at every fourth launch or so.

- The app loses connection and stops recording data after about a minute of switching off the display.

- After connecting, the app hangs for 10-30 seconds.

- If the wheel is powered off and back on while connected to DB, phone notification says that the wheel is connected. However, if I then open the app, it is not connected, and it didn’t record any data.

- After connecting (and after the 10-30s hang), it takes a long time to show both the total and current mileage.

- Battery level doesn’t seem to update properly, at least when low on battery on the MSX. DB keeps showing 8% despite if I accelerate or ride at a steady speed.

I’ve been running the DarknessBot betas, but the issues were there on the App Store version as well. Using iPhone 6 (currently on iOS 12.3.1), wheels MSX 84V and KS-16S.

This is exactly one of my issues.

Heres a summary of three issues I d love to hear others about solving if possible guys n gals

 

1. Nikola Plus: Iphone + Darknessbot doesn't seem to log anything after my phone is in my pocket and the screen eventually locks.

upon opening the app post ride, the unit is disconnected and nothing is logged?

2. MSX 100v 1245Whr: Upon connection attempt it identifies MSX as incompatible Hardware. (It had connected previously). Any fixes?

3. What alternative options are there to view speed etc on a watch other than an Apple Watch.? (I cant see myself spending that cash on latest watch which wont touch my skin during rides and may be damaged  easily if i face-plant.. any alternatives for iPhone connection or direct wheel connection guys? Is Darkness bot backward compatible with older apple watches?

Any solutions for the above  issues greatly appreciated Riders.

Warmest regards

Paul

 

Edited by RayBanMonster

Share this post


Link to post
Share on other sites

This is an excellent idea for future, especially for European riders with ever stricter speed limits and enforcement. Please add to the wishlist. 
 

 

Share this post


Link to post
Share on other sites
5 hours ago, RayBanMonster said:

This is exactly one of my issues.

Heres a summary of three issues I d love to hear others about solving if possible guys n gals

 

1. Nikola Plus: Iphone + Darknessbot doesn't seem to log anything after my phone is in my pocket and the screen eventually locks.

upon opening the app post ride, the unit is disconnected and nothing is logged?

2. MSX 100v 1245Whr: Upon connection attempt it identifies MSX as incompatible Hardware. (It had connected previously). Any fixes?

3. What alternative options are there to view speed etc on a watch other than an Apple Watch.? (I cant see myself spending that cash on latest watch which wont touch my skin during rides and may be damaged  easily if i face-plant.. any alternatives for iPhone connection or direct wheel connection guys? Is Darkness bot backward compatible with older apple watches?

Any solutions for the above  issues greatly appreciated Riders.

Warmest regards

Paul

 


1. What is your current iOS version? 
Have you ever noticed: any empty tile (with no value) on Dashboard? Sometimes Gotway don't sent whole data, and if you have any empty tile, e.g. Total distance, you logs will be empty. 
How long you have this issue? 

2. Yes, we'll fix it in next version. 

3. Currently we don't support any wearable devices but Apple Watch. 
For Apple Watch minimum is WatchOS 2.2 (I think, even the first Apple Watch is supported). 
In nearest future we don't consider to add support for any other watches, we have a plans to redesign AW app. 
But we don't rule out in future to add other watches. If we receive a many request for it from users, and if the device will have a quite good API for it, we'll add supporting for it. But for now, we have another important problems what should be fixed, like normal Gotway supporting and V10F connection problem. 
What wearable device you have? 

About connection without iPhone, directly to watches: wearable devices has so many restrictions, so we don't consider making standalone app in nearest future. 
 

Share this post


Link to post
Share on other sites
2 hours ago, UniVehje said:

This is an excellent idea for future, especially for European riders with ever stricter speed limits and enforcement. Please add to the wishlist. 
 

 

Ok, I add it to wishlist. We also can add Siri shortcut for this for fast adjusting. 

Share this post


Link to post
Share on other sites

What's new in beta 5.6-252:
- Added new calibration screen in Settings
- Gotway: Saving last changed max speed and riding mode
- Gotway: Fixed connection to new batch
- Gotway: Fixed calibration

IMG_0032.thumb.PNG.4c900adc4460bbce35ff5919f8ef9011.PNG

Edited by Ilya Shkolnik

Share this post


Link to post
Share on other sites
5 hours ago, Trevor Phillips said:

thanks 

new Mten3 now working!

Great! Thank you for tests)

Try to change speed settings too, please.

Share this post


Link to post
Share on other sites
12 hours ago, december11 said:

Ok, I add it to wishlist. We also can add Siri shortcut for this for fast adjusting. 

Thank you! Good idea adding Siri shortcut. A button on the watch app (or Flic -type button support) would be great also. 

BTW, is there a possibility to create my own shortcuts for DarknessBot or can I only use the ones preprogrammed on the app? I'm thinking using Siri to change riding modes. 

Share this post


Link to post
Share on other sites
4 hours ago, UniVehje said:

Thank you! Good idea adding Siri shortcut. A button on the watch app (or Flic -type button support) would be great also. 

BTW, is there a possibility to create my own shortcuts for DarknessBot or can I only use the ones preprogrammed on the app? I'm thinking using Siri to change riding modes. 

Only preprogrammed

Share this post


Link to post
Share on other sites

What's new in beta 5.6-253:
- Release Candidate
- KingSong: Added 18LH support

Edited by Ilya Shkolnik

Share this post


Link to post
Share on other sites
14 hours ago, UniVehje said:

A button on the watch app (or Flic -type button support) would be great also. 

We waiting for our Flic2 button already a half-year:popcorn:. As soon as it arrived, we finally can add supporting for it. 
In last year, we'd decided to add supporting when second generation will be released, as the first Flic has poor API at that time. But, maybe we can add supporting the first generation too, when we could get it. :)

Edited by december11

Share this post


Link to post
Share on other sites
On 1/19/2020 at 11:30 AM, december11 said:


1. What is your current iOS version? 
Have you ever noticed: any empty tile (with no value) on Dashboard? Sometimes Gotway don't sent whole data, and if you have any empty tile, e.g. Total distance, you logs will be empty. 
How long you have this issue? 

2. Yes, we'll fix it in next version. 

3. Currently we don't support any wearable devices but Apple Watch. 
For Apple Watch minimum is WatchOS 2.2 (I think, even the first Apple Watch is supported). 
In nearest future we don't consider to add support for any other watches, we have a plans to redesign AW app. 
But we don't rule out in future to add other watches. If we receive a many request for it from users, and if the device will have a quite good API for it, we'll add supporting for it. But for now, we have another important problems what should be fixed, like normal Gotway supporting and V10F connection problem. 
What wearable device you have? 

About connection without iPhone, directly to watches: wearable devices has so many restrictions, so we don't consider making standalone app in nearest future. 
 

Hi December11 ( Thanks)

1.Yes empty Tiles (with spinners). on IOS 13.3 had this since I cleared out trips files because I didn't know how to start a new trip. Ill try a new trip and see if the data starts to save it.  Am I right in thinking, iPhone screen lock shouldn't break the link?

2. thank you. fix acknowledged in new updates for 1000v MSX connection

3. ok understood, so apple WatchOS 2.2 is supported (perhaps I could put the older watch on a lanyard then because as I understand, latest watches need skin contact to register it as on and active I think.. I may be wrong).

 

 

Share this post


Link to post
Share on other sites
6 hours ago, RayBanMonster said:

Hi December11 ( Thanks)

1.Yes empty Tiles (with spinners). on IOS 13.3 had this since I cleared out trips files because I didn't know how to start a new trip. Ill try a new trip and see if the data starts to save it.  Am I right in thinking, iPhone screen lock shouldn't break the link?

2. thank you. fix acknowledged in new updates for 1000v MSX connection

3. ok understood, so apple WatchOS 2.2 is supported (perhaps I could put the older watch on a lanyard then because as I understand, latest watches need skin contact to register it as on and active I think.. I may be wrong).

 

 


1. Yes, you’re right, iPhone screen lock shouldn't break the connection between app and wheel. 
While you have empty tiles, your data will be losing🙁

Please, send us logs (in DarknessBot-Settings/About/Share logs) and add subject - no data Nikola Plus, it helps us to find your logs.

Trips started automatically, when you connecting to wheel after 6-8 hours without riding. Also, you can reset it manual - on Dashboard tap to “Current distance” tile. 

3. Hm, I don’t sure about it. I think you can turn off wrist detection function. To make it don’t asking for password all the time. But I never use my AW without wrist contact, so I can be wrong.
And you can setup Active time for last app, in General/Wake screen (can have another path, I see on watchOS 6) settings, AW will show the last app when you raise your wrist. 



 

Edited by december11

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...