Jump to content
HJ

can't get firmware downloaded

Recommended Posts

Hi, quick issue that I'm having and would like to see if anyone has any ideas about it.  I have had my KS-18 for about a year now, and never have updated the firmware.  So yesterday I tried to do it, after updating the iphone 6 app.  Although it does connect and I can get the speed, temp, batt charge level, and make it beep when I press the little horn, I can't do anything towards the upgrading of the firmware.  On the firmware upgrade page it says that its "V0.00" version.  And also, there's no information on the serial number for the euc in the app once connected.  There is no download button, nothing else that I can press to activate.  Any ideas as to what I should do?

 

H

Share this post


Link to post
Share on other sites
26 minutes ago, HJ said:

Hi, quick issue that I'm having and would like to see if anyone has any ideas about it.  I have had my KS-18 for about a year now, and never have updated the firmware.  So yesterday I tried to do it, after updating the iphone 6 app.  Although it does connect and I can get the speed, temp, batt charge level, and make it beep when I press the little horn, I can't do anything towards the upgrading of the firmware.  On the firmware upgrade page it says that its "V0.00" version.  And also, there's no information on the serial number for the euc in the app once connected.  There is no download button, nothing else that I can press to activate.  Any ideas as to what I should do?

 

H

What is that KS18???

500Watt? 800Watt? 1200Watt? You bought it new?

Perhaps it is too old to be updated like some old KS14, which also have boards that are not updateable!

  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, HJ said:

its a KS-18, 1200W 1360wh

bought it new  

where? in china? about a year ago i have read something about a KS18 buyer who got a wrong control board in it....

Share this post


Link to post
Share on other sites

factory direct, but no problems with the control board at all

runs great, no issues

Share this post


Link to post
Share on other sites
1 hour ago, HJ said:

factory direct, but no problems with the control board at all

runs great, no issues

Then you should be able to ask Tina from KS directly....i would tip for a "wrong" controlboard with no update Features.....

Or you Forget about it...as it runs great as you said...if you install the newest Firmware under 45% Batterie you will be slowed down to 25kmh....

  • Upvote 1

Share this post


Link to post
Share on other sites

Slows to 25 km/h? Shucks, I may just keep the firmware I have. I don't really care about flashing lights per se

Share this post


Link to post
Share on other sites
3 hours ago, HJ said:

Slows to 25 km/h? Shucks, I may just keep the firmware I have. I don't really care about flashing lights per se

yip: 

numbers here are just "about"-ca, i dont have the exact "rules:

35-45%= 28kmh

20-35%=25kmh

slows down means beeping and tiltback set in, other than set in the app....

For safety.....but also:

version 1.23 has a great and smooth motor driver... nearly all users say a bit more punch and better acceleration

 

 

Edited by KingSong69

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×