Jump to content

Begode EX Shuts off suddenly while riding.......


Recommended Posts

Hey all. My EX shut off while riding without notice. Does not turn back on. Luckily, I was going slow, about 15 mph, only soreness and a big scratch. There's power to the board, enough to have to drain the main board caps of their 100v. Wheel takes a charge, yet does not turn on. The EX was at top charge. Only rode about one mile. No visible damage or burnt smell inside the wheel, yet the side with the electronics had lots of sand in it. I never opened this wheel before. I think it's possible that sand dust may have caused a short on the main board, inside was very dusty, causing the shutoff. So, I'm working with the seller for a fix. Hopefully, the EX will be back soon and well inspected and sealed up. Interior quality is good. No glaring issues or shortcuts other than a misaligned cover seal. Anyway, I thought this would be good info to share. Oh, I ride this wheel almost daily. Rides around 10-20 miles. Wheel has around 1000 miles on it. Peace from Maine USA...Guy

Link to post
Share on other sites

be sure to seal the back of the board, it's the most important thing, the motor hole is not a real issue untill you ride in crazy conditions

Link to post
Share on other sites
On 7/27/2021 at 3:21 AM, Guy said:

Hey all. My EX shut off while riding without notice. Does not turn back on. Luckily, I was going slow, about 15 mph, only soreness and a big scratch. There's power to the board, enough to have to drain the main board caps of their 100v. Wheel takes a charge, yet does not turn on. The EX was at top charge. Only rode about one mile. No visible damage or burnt smell inside the wheel, yet the side with the electronics had lots of sand in it. I never opened this wheel before. I think it's possible that sand dust may have caused a short on the main board, inside was very dusty, causing the shutoff. So, I'm working with the seller for a fix. Hopefully, the EX will be back soon and well inspected and sealed up. Interior quality is good. No glaring issues or shortcuts other than a misaligned cover seal. Anyway, I thought this would be good info to share. Oh, I ride this wheel almost daily. Rides around 10-20 miles. Wheel has around 1000 miles on it. Peace from Maine USA...Guy

Did you ever get any updates, or reasons why your wheel may have cut out, and wouldn't turn back on?  How many miles did you have on your wheel when the cut out occured?   

Link to post
Share on other sites
  • 1 month later...

Had same stuff happen on a 30 mins used, new exn.

Chinese customer support said it was motherboard failure and sent a new one which i installed 10 mins ago.

It was not it lol, an now what?

Any update on your issue?

Link to post
Share on other sites
11 hours ago, Oliee said:

Had same stuff happen on a 30 mins used, new exn.

Chinese customer support said it was motherboard failure and sent a new one which i installed 10 mins ago.

It was not it lol, an now what?

Any update on your issue?

Black Motherboard?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...