Jump to content

[solved] no light on my new 9B1 E+ with v1.3.0


Recommended Posts

so I just bought this 9b1 E+ N20. ( from a big store in France.... like french bestbuy )

I upgraded from 1.2.2 to 1.3.0 and started to ride. no problem.

After 2hours training with 2 other friends  (they are beginners), the unit took a small fall (no scratch). 

I had to try twice to turn it on and no light came up anymore. (no battery level and no light at all)

Has someone experienced this before ?

I checked the wire/battery and even tried to reset the devise ... it doesn't change anything !

I can still ride as normal and the app works fine, just had to pair again the blue thooth.


any idea ?

should I return and use the warranty?





Link to comment
Share on other sites

It could be a problem with the LED's which is similar to this thread. Since you just got the Ninebot, then better ask for a new replacement. Maybe you can give the reason that the LED's stop emitting after the 1.30 firmware update.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...