Jump to content

E+ won't turn on!


Recommended Posts

It's been working for a few days, and is running 1.3. This evening I tried to turn it on to do a quick practice ride, but when I pushed the power button the motor pulsed to pull it straight, it beeped, and the light ring turned on, then it just went dead. Nothing, no beeps or lights. I did a forum search and based on previous posts I disconnected and reconnected the battery, then tried again. Beep and lights, then completely dead again. I tried disconnecting three times and it finally started working, but now 30 minutes later it did it again. I did a visual inspection of the main board and I didn't see any damaged circuitry. 

Any Ideas? 

Link to comment
Share on other sites

Update! I think there is a wire loose on the battery because when it won't turn on I shake the whole euc left to right and then set it down and it let's me turn it on.  No shutdowns while riding, though. My current theory is that a partial connection is increasing resistance enough to prevent the bms from seeing enough voltage to start.

Can I slice off part of the plastic cover on the battery to check the connections without voiding my warranty? 

2 hours ago, SlowMo said:

This would be the second firmware 1.3.0 reported casualty.

The jury is still out. Possible. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...