Jump to content

KS 16X Weird charge behavior after crash


Recommended Posts

Hi, I am hoping to get some help from someone who have knoledge on topic of batterier, BMS an KS16X repairs.

My gf crash my wheel badly last week at probably around 20 miles/h. She didn't get hurt but the wheels did. I repaired a lot of things an put it back together. It now ride perfect but the problem is with charging...

When it charge, led on the wheel lit up normaly showing the charge state. The led on the charger is red wich is also good. It means the wheel is charging. When I look at the voltage on all apps it is going up at what appears to be a normal rate. But... on every apps I use, the amp reading is 0.3A. It sould normaly read around -1.5A during the charge.

When I ride, strangely the Amps reading is just fine.

After the crash, 1 of the batterie pack blue envelope was crack. I fix it with some Gorilla tape. While resting on the side during the fixes, the other pack just fall of the wheel, it was resting 1 side on the floor and the other side holding by the wires. It did not appear to have any damage appart from the 3M tape they use to hold it. On both pack I cleaned the tape and put new 1.

Does anyone know where the problem could come from? Is it a BMS or a Motherboard issue. More importantly, is there a safety issue there? I read that cells that are not well balanced are at risk of catching fire. Should I be concerned about that in that particular case?

Any feedback will be greatly appréciated.Txh

 

Link to post
Share on other sites

General rule of thumb, anything that is out of the oridinary usually means some thing is not right & should be checked thoroughly since your gf did crashed it. If you don't have any electronics background then i suggest that you send it back to your disributor/ dealer for checking.

If you know what you're doing then first check both pack's voltage with a multimeter, both should read about 84V when fully charge. If less usually means one or two of the 18650 is faulty. Also pay attention when charging, if the pack gets very hot during charging means one of the 18650 is shorted. Disconnect charger right away.

At this stage you have no choice but to open up the blue heatshrink wrapping & check through each individual 18650, it should read around 4.2V when fully charge. 4.2V x 20 cell = 84Volt. 16x uses 6 pack.

Also check each of the nickel strip, usually it will get disconnected after a major crash.

Link to post
Share on other sites
6 minutes ago, yuweng said:

 

At this stage you have no choice but to open up the blue heatshrink wrapping & check through each individual 18650, it should read around 4.2V when fully charge. 4.2V x 20 cell = 84Volt. 16x uses 6 pack.

Also check each of the nickel strip, usually it will get disconnected after a major crash.

16x has 2 packs 20s3p - when u tk apart pack u cannot access cells individually -only via spot welds on bms ( u can messure all cells there though). the pack is put together with plastic dividers that prevent access to nickel strips and individual cells unless u deweld from bms (not recommended!). pics from water damaged pack i opened up...

6F794A9F-93D8-43D7-998A-62FAD8BF00DF.jpeg

9CCEA69E-45C0-4D0F-8712-63F2895A885A.jpeg

2E058574-CB67-4838-9F5C-8C4BEDD3B865.jpeg

Link to post
Share on other sites

Thx for your imputs.

It is realy usefull. So I will remove the sides panel to be able to monitor better the batteries température while I fully charge theme and then I will check the voltage.

But first I have the théory that it might simply be a bug induced by the new Firmware Update. I did upgrade the firmware just after the réparations. Anyone know how to revert to a previous version?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...