Jump to content
WILSON-YT

RS19 HS - ewheels

Recommended Posts

Just paid my full payment to eWheels :D coming soon

Share this post


Link to post
Share on other sites
On 10/26/2020 at 6:54 AM, Darren0128 said:

Mine is not scheduled for delivery until Thursday the 29th.  Not sure why mine is taking soo long.   Glad you got yours quickly!  I cannot wait, been without a wheel for tooo long! (3 months is too long once you get bit by the EUC bug).  Curious if you have tried the dif. hardness settings yet?  It might help you dial it in if you can get the pedals to react closer to what your are already used to

 

  I will ring in with my experiences as this is my 1st Gotway/Keybe/Begode...(whats next?)  I do have EUCworld and that is my go-to app so far.

Ive been riding on mode 2, it feels like im sailing! (the icon for the setting is a sailboat, and rightfully so) . It takes a little bit of time to stop.

I will test the other modes out in the future. I dont have android to use EUC world b ut i hear that is top notch app to have.

 

Share this post


Link to post
Share on other sites

I just received mine today and have only ridden it across the kitchen a few times.  B-B-B-Big!  Hopefully, decent weather returns tomorrow.

Share this post


Link to post
Share on other sites

Just got mine today. One grub screw is loctited and I can't get it the pedal off to inspect inside. I'll be trying with a hairdryer to loosen it another day, but at least my fan works. 

Share this post


Link to post
Share on other sites

Anyone here tried the RS with the roll.nz MSP cover? I can’t get it to stay on to save my life. Maybe it’s incompatible. Probably sending it back. 

Share this post


Link to post
Share on other sites
1 hour ago, shellac said:

Anyone here tried the RS with the roll.nz MSP cover? I can’t get it to stay on to save my life. Maybe it’s incompatible. Probably sending it back. 

I sent mine back today. The design seemed flawed to me. I just dont understand how that little flap is expected to stay hooked with that corner edge on the bottom in an L shape. If that makes any sense to you.

I'll just be using baby proofing pads instead.

Share this post


Link to post
Share on other sites

I noticed the fan comes on after a couple minutes (regardless of the wheel being idle) and just stays on. Is that normal?

Sounds like a distant hairdryer or vacuum cleaner.

Also, that high pitch noise that is just always there is pretty annoying to me.

The sounds just come as a surprise to me because this is my first EUC and my Onewheel is so quiet.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...