Jump to content

MSP - Dead Bluetooth Module - On Arrival


Recommended Posts

This has to do with the batch that was delayed from Gotway, meaning the summer of 2020. 

Upon arrival the Bluetooth module was not working. Tested with different phones, and wheels, there is no issue on any device but the MSP. 

I managed to connect once, and took a screenshot. 

107961382_287708965994117_892167331961387685_n.thumb.jpg.3ebad010e659dbbf260c7283f56e065e.jpg
 

Voltage is displayed at 82.8V for an 100V MSP on a full charge. Euc World is properly configured, as the voltage is shown correct on an Nik+ and on an Mten3. The reply from Gotway is:
"Is the wheel unlocked first? In addition, a voltmeter is required to measure wheel voltage, not app Our motherboard has been updated with firmware. There will be errors in the unofficial version of app’s"
Yes the wheel is unlocked. Sadly i cannot verify with a voltmeter. So this might be my fault, we will see. Tried connecting to the official gotway app, but the singnal went dead. No luck since. 

Fun fact, The fan gave out in about 2 hours. Did not ride the wheel at all. Was just powering on to try and get a Bluetooth connection. The fan just gave out. 

I'd like your input on the Bluetooth module. Gotway replied: "Does the Bluetooth module flash after power on? The blue flashing represents the received signal, and the red is always on, indicating that the signal has been received"

At first there was no led powering on anywhere on the motherboard. After a few (hundreds) power on / off cycles i managed to get this "red always on". Still no Bluetooth signal coming from the wheel.  What does "signal has been received' mean? Who is the receiver? 

 

 

I am waiting for a new board, and wishing that i could just replace the Bluetooth module as i wish to avoid replacing the entire board. Any input would be great :)

 

 

Edited by Χρήστος Γεωργαμπλοπουλος
Link to comment
Share on other sites

Thanks for the tip. I did remove it and indeed, must be a contact issue. 

image.thumb.png.bbc40bbacc97dd17740f1a9d5e1e8600.png

This is on the motherboard side. Seems to be melted. 

In my case the module seems to be this little piggie. 

https://eggelectricunicycle.bitbucket.io/Flash_and_Debug_STM32--Flash_firmware_using_Bluetooth--ZS-040_Bluetooth_module.html

image.png.fa5ecc441c6c0e31ddc1bb2a7bbba213.png

I will then wait for the entire board. Try first the Bluetooth by itself, and then the entire board. 

  • Like 1
Link to comment
Share on other sites

  • 1 year later...
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...