Jump to content

KingSong App Gyro Angle Adjustment


me_neil
 Share

Recommended Posts

Has anyone else had the problem with the KingSong app (IOS) when you set the Gyro Angle Adjustment to any negative value and save, it automatically changes to 6545.9?

I'm on a KS16X using the latest IOS version of the app and 2.02 Firmware on the wheel.
The wheel doesn't seem to actually do anything in terms of actual adjustment. Just beeps, the app says 6545.9 and that's it.
If I put back to default it goes to 0. 

6e4gutT.jpg

Link to comment
Share on other sites

Hey @Jack King Song,

Yes kind of. After fiddling with it. I managed to get the gyro adjustment to work now as in the wheel is actually reacting to the slider and tilting.
It still has the issue where it displays that strange value (6545.9) when I go into the negative but the gyro adjustment works.

Not sure if there is a bug in the app on how it displays the value.
I notice you are using the degree ° character in the app. Maybe that is bugging out the field or it's expecting a whole number and passing negatives breaks the field display. Dunno... 
If you look at the Android screenshot above there is a degree symbol in the field but mine it's missing. Maybe that's bugging the app out.

For your programmers my Region on my phone is set to Canada. I know US and Canada formatting can sometime cause issues within apps.
Hope that helps.

Side note, While I've got your attention. Can you make it so the wheel doesn't beep every time I tap around the app. 
Kind of annoying while you are making adjustments it constantly beeping just navigating around adjusting settings.

Thanks for looking into it for me.

Cheers,

Neil

 

Link to comment
Share on other sites

37 minutes ago, me_neil said:

Hey @Jack King Song,

Yes kind of. After fiddling with it. I managed to get the gyro adjustment to work now as in the wheel is actually reacting to the slider and tilting.
It still has the issue where it displays that strange value (6545.9) when I go into the negative but the gyro adjustment works.

Not sure if there is a bug in the app on how it displays the value.
I notice you are using the degree ° character in the app. Maybe that is bugging out the field or it's expecting a whole number and passing negatives breaks the field display. Dunno... 
If you look at the Android screenshot above there is a degree symbol in the field but mine it's missing. Maybe that's bugging the app out.

For your programmers my Region on my phone is set to Canada. I know US and Canada formatting can sometime cause issues within apps.
Hope that helps.

Side note, While I've got your attention. Can you make it so the wheel doesn't beep every time I tap around the app. 
Kind of annoying while you are making adjustments it constantly beeping just navigating around adjusting settings.

Thanks for looking into it for me.

Cheers,

Neil

 

Please check your DMs.
Removing beep sounds is something that we are considering but have not made a decision to it yet. 

Link to comment
Share on other sites

1 hour ago, Jack King Song said:

Are you still experiencing this issue? 

I can confirm I get the same bug on the new iOS app. The pedal setting seems to stick but when I come back to change it again it shows that weird number and the slider is all the way to the right. 

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...