Jump to content

Kingsong 18XL strange issue (jerking) while strolling


Phong Vu
 Share

Recommended Posts

Hi everyone,

So in the last 2 days, my kingsong 18xl has developed a strange issue, i would like to ask if anyone knew/experienced the issue before?

So when I strolling the wheel in the store (handle extend highest), suddenly, the wheel turn off all lights, but still balancing, and then right after that, lock up, jerking a bit and then till to the front (like we set the pedals till to the front)

Reset the wheel and everything works normal again.

Beside that, the wheel still ride perfectly.

The issue happened 2 days ago in a grocery store, I tried to reproduce the issue after that but was not be able to.

I still ride the wheel since, but today, it happen again at the same grocery store.

I had opened the wheel right after I was home. Everything still looks solid, no cracked inner shell, axles bolts still tighten, no loose cables, mainboard looks good, battery looks good, handle is tight as well.

Put everything back. Tried to stroll the wheel around the block, nothing. Tried to ride the wheel a bit, solid.

Now, I’m have no idea, any suggestions could be greater appreciate. :( 

(One silly thing I noticed, the issue happened in the same grocery store, right after I enter the store and then right after I exited. Could be coincidence. Could be my paranoid. But If I got nothing, I will go back the the same store tmr just to see what will happen)

  • Like 2
Link to comment
Share on other sites

yeah, the anti theft system is also in my mind.

Clearly I don't have enough knowledge about how it can interfere with the gyro sensor.
(The only thing I can expand the lock up and hard till to the front is the gyro sensor detected something wrong, and the apply to the wheel behavior)

Link to comment
Share on other sites

This is well know issue with KS18L... and probably XL also. Electrostatics charges crash motherboard... In early firmware versions it was even worse, because motor was heating to an incredible temperature and the only way to stop it was to dismount the wheel and disconnect the battery... Depending version of your motherboard this issue was completely fixed by hardware modification or by some software fixes. 

  • Like 1
Link to comment
Share on other sites

3 hours ago, TomOnWheels said:

This is well know issue with KS18L... and probably XL also. Electrostatics charges crash motherboard... In early firmware versions it was even worse, because motor was heating to an incredible temperature and the only way to stop it was to dismount the wheel and disconnect the battery... Depending version of your motherboard this issue was completely fixed by hardware modification or by some software fixes. 

Thanks a lot for pointing me there, sound very similar for my case. Except for my case, it just lockup, but still responsive for button press, so turn it off/on and the wheel works again.
I wonder if the different is because mine is the newest version, on mostly latest firmware (2.0).
Maybe it's time to update to 2.02...
 

Quote

I suggest that everyone disable tension sensors and use the button until the problem is fixed.
It seems, sensors generate too many on/off events and controller cannot handle this high frequency control input.

This make a lot of sense, but nobody got this for a really long time, so I guess my trolley handle must be faulty somehow if this's really a root cause.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Phong Vu said:

Thanks a lot for pointing me there, sound very similar for my case. Except for my case, it just lockup, but still responsive for button press, so turn it off/on and the wheel works again.
I wonder if the different is because mine is the newest version, on mostly latest firmware (2.0).
Maybe it's time to update to 2.02...
 

This make a lot of sense, but nobody got this for a really long time, so I guess my trolley handle must be faulty somehow if this's really a root cause.

Yes it's because you have a recent firmware. KS fixed this dangerous situations where you had to dismount the wheel because otherwise it was about to take fire. (well almost). After firmware update, I already had and still having situation similar to your but now can switch off the wheel or it switch off on it's own. Switching off sensors had no impact for me... because it's an electrostatic isolation issue. Switching sensors was to prevent another bug where standing still your wheel suddenly loosing balance. Of course this was sometimes happening when you was standing on your wheel, without moving and for example waiting for a green light :-)

 

  • Like 1
Link to comment
Share on other sites

41 minutes ago, TomOnWheels said:

Also you are safe, because this happens only when pushing you wheel, never when you actually ride on it. :-) Some people said that KS18 don"t like shopping :-)

Thanks a lot, I'm glad that I'm not the only one (and especially I'm not paranoid :D ), since no one seems to mentioned this issue recently.

I'm still in learning period with this wheel specifically :) 

  • Like 2
Link to comment
Share on other sites

1 hour ago, null said:

Interesting issue with the magnetic portals, I'll switch it off when passing them then.

It's mostly about what is on the ground. Looks like synthetic surface is the worst. Happens to me twice in BHV at -1 level :-)

 

  • Like 1
Link to comment
Share on other sites

First off, 2.02 is out for us now? And second, yeah, this happened to me too. I posted about it. It used to happen in the grocery store across the road from my place a few time,a nd it suckeddddd. Scared the breaks out of me the first time. But the 2nd time, i just kinda waited as it hammered away. IT hasnt happened since i updated to 2.00

  • Like 1
Link to comment
Share on other sites

19 hours ago, TomOnWheels said:

It's mostly about what is on the ground. Looks like synthetic surface is the worst. Happens to me twice in BHV at -1 level :-)

 

Yeah, as recall, the grocery store I went to has huge entrance, so I see no anti-theft gate.
The must be something under the ground. And as you said, the issue only happen around the entrance.

16 hours ago, seage said:

First off, 2.02 is out for us now? And second, yeah, this happened to me too. I posted about it. It used to happen in the grocery store across the road from my place a few time,a nd it suckeddddd. Scared the breaks out of me the first time. But the 2nd time, i just kinda waited as it hammered away. IT hasnt happened since i updated to 2.00

I haven't check on 2.02 to be honest, I'm happy with 2.0.
The first time the wheel did this to me, I was making a turn, and the wheel decided to stop right there, so I dropped it.
After that, I kind of watch out why strolling, so it much more manageable.
( btw, the only place I got trouble with is Loblaws, since I saw that you're also in Toronto :) )

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...