Jump to content
Cuba Gonzalez

KS18XL 2200W motor

Recommended Posts

3 hours ago, Patton250 said:

My guess is the people that are having problems didn’t download the firmware from the soft tuner app. Or if they did they didn’t pick the 18HL firmware. I could be wrong as I’m wrong quite often and if you don’t believe me then ask my wife. Lol. But that would be my guess.

i got the 18LH firmware, multiple times lol

Share this post


Link to post
Share on other sites

I'm pretty sure @Rywokast knows what he's doing B)

My theory is that this comes down to some sort of hardware-firmware incompatibility. The way Kingsong and Gotway do incremental upgrades between batches of the same model, makes it a mess trying to sort out why things aren't working properly. For example, in the 18XL v1 there were:

  • pedal color and size upgrades
  • inner shell material and structural upgrades
  • trolley handle rack attachment upgrades
  • trolley handle sensor upgrades
  • headlight upgrades
  • control board upgrade to v1.3

I hope we can collect some data on the successfulness of people upgrading their 18XL from the various control boards versions:

  • v1.0
  • v1.1
  • v1.2
  • v1.3

 

Share this post


Link to post
Share on other sites
9 minutes ago, Asphalt said:

I'm pretty sure @Rywokast knows what he's doing B)

My theory is that this comes down to some sort of hardware-firmware incompatibility. The way Kingsong and Gotway do incremental upgrades between batches of the same model, makes it a mess trying to sort out why things aren't working properly. For example, in the 18XL v1 there were:

  • pedal color and size upgrades
  • inner shell material and structural upgrades
  • trolley handle rack attachment upgrades
  • trolley handle sensor upgrades
  • headlight upgrades
  • control board upgrade to v1.3

I hope we can collect some data on the successfulness of people upgrading their 18XL from the various control boards versions:

  • v1.0
  • v1.1
  • v1.2
  • v1.3

 

thanks, yea its not just black and white who knows what they could have changed during minor iterations, the situation is much worse with gotway who cant do firmware upgrades and admit to not even knowing wtf is going on because there are so many different iterations, it seems problems can arise from something as simple as shifting hardware around or changing it slightly.. unfortunately it seems there is nowhere near enough internal testing done by ANY euc manufacturer as they are all always doing iterative upgrades or changes.. it seems to be a bit of a crapshoot unfortunately and no one ever learns from their mistakes.. the 16X seems to be plagued by more things than the 18 ever was

 

Share this post


Link to post
Share on other sites
6 hours ago, Asphalt said:

I'm pretty sure @Rywokast knows what he's doing B)

My theory is that this comes down to some sort of hardware-firmware incompatibility. The way Kingsong and Gotway do incremental upgrades between batches of the same model, makes it a mess trying to sort out why things aren't working properly. For example, in the 18XL v1 there were:

  • pedal color and size upgrades
  • inner shell material and structural upgrades
  • trolley handle rack attachment upgrades
  • trolley handle sensor upgrades
  • headlight upgrades
  • control board upgrade to v1.3

I hope we can collect some data on the successfulness of people upgrading their 18XL from the various control boards versions:

  • v1.0
  • v1.1
  • v1.2
  • v1.3

 

Just out of curiosity so I don’t ever make the mistake again what exactly did I say that made you think I said he doesn’t know what he’s doing?

Share this post


Link to post
Share on other sites
11 hours ago, Patton250 said:

My guess is the people that are having problems didn’t download the firmware from the soft tuner app. Or if they did they didn’t pick the 18HL firmware. I could be wrong as I’m wrong quite often and if you don’t believe me then ask my wife. Lol. But that would be my guess.

@Patton250 Just a reference to the above statement, since Rywokast was one of the people having problems.

He's helped me out many times and his experience with wheels runs deep, so I give him the benefit of the doubt when it comes to installing the proper 18LH firmware.

Share this post


Link to post
Share on other sites
23 minutes ago, Asphalt said:

@Patton250 Just a reference to the above statement, since Rywokast was one of the people having problems.

He's helped me out many times and his experience with wheels runs deep, so I give him the benefit of the doubt when it comes to installing the proper 18LH firmware.

I apologize but I think you didn’t understand my question. You made it sound as though I said he didn’t know what he was doing and then you stepped in to save his honor in a way. :-). I was looking for an explanation as to my exact wording that triggered your thought process having to do with him specifically.  I suppose at this point it doesn’t matter. That’s not what I originally intended to relay so I’m sorry you misunderstood me.

Share this post


Link to post
Share on other sites

@Patton250, if your leaking air is slow try some slime (or slime like product) to fix it. I've pulled some things out of my tires and pumped em back up (like in @Marty Backe's video on fixing a tire with slime) and it worked. 

It wont fix valve stem cuts or slashes but small holes work just fine. 

I've also pinched tubes before when changing tires and it isnt cool having to take it apart a second time :cheers:

Share this post


Link to post
Share on other sites

there any way to see control board version number without opening the wheel ... ? :efef2e0fff:

Share this post


Link to post
Share on other sites
9 hours ago, Meserias said:

there any way to see control board version number without opening the wheel ... ? :efef2e0fff:

nope

Share this post


Link to post
Share on other sites
16 hours ago, Meserias said:

there any way to see control board version number without opening the wheel ... ? :efef2e0fff:

What @Rywokast said... Nope!

But we have a rough idea of when the factory switched them out, so if you can share your serial number then we can come up with one of the following;

  1. Your date is too early, so you will most likely have a v1.2 (which i believe was the board in the first production batch).
  2. Your date is way later, so should be a v1.3.
  3. You are dated right in the change window, so need to find yourself a screwdriver...

Share this post


Link to post
Share on other sites

@Rywokast Just out of curiosity did you try to run the old motor with the new firmware?

Share this post


Link to post
Share on other sites
6 hours ago, andress said:

@Rywokast Just out of curiosity did you try to run the old motor with the new firmware?

I did not, I wouldn't think that it would be compatible.. but now that you say it I wonder what would happen haha

Share this post


Link to post
Share on other sites
4 hours ago, Jonesq said:

It's so quiet! I didn't realize how nice it was to not hear that whine until I no longer had to listen to it.

Weirdly I kind of miss the old whine. It was kind of cute :roflmao:

Share this post


Link to post
Share on other sites
3 hours ago, brockj said:

Weirdly I kind of miss the old whine. It was kind of cute :roflmao:

I know... Right?

I use the pitch of the whine (and the "cadence" of a slightly off-centre tyre) to judge my speed.   :thumbup:

Share this post


Link to post
Share on other sites
4 hours ago, The Fat Unicyclist said:

I know... Right?

I use the pitch of the whine (and the "cadence" of a slightly off-centre tyre) to judge my speed.   :thumbup:

:laughbounce2:

Thats exactly what i do.

Share this post


Link to post
Share on other sites

Alright, my goal is to install the new motor and a new control board this week. Are there any specialty tools I'll need? I have all the allen wrenches and screwdrivers necessary. Like will I need that white glue stuff? Also, for those who have already swapped out the motor or control board, do you have any tips or words of wisdom? Any help will be appreciated. @Marty Backe @The Fat Unicyclist @Asphalt @brockj

Share this post


Link to post
Share on other sites
8 hours ago, Flyboy10 said:

Alright, my goal is to install the new motor and a new control board this week. Are there any specialty tools I'll need? I have all the allen wrenches and screwdrivers necessary. Like will I need that white glue stuff? Also, for those who have already swapped out the motor or control board, do you have any tips or words of wisdom? Any help will be appreciated. @Marty Backe @The Fat Unicyclist @Asphalt @brockj

It shouldn't take much longer than replacing an inner tube (which I've done on my 18XL). Maybe 2-hours. Most of the hard work will actually be installing the tube/tire on the wheel. Everything else is just snipping cable ties, etc. KingSong doesn't use the "white glue stuff" like Gotway does :thumbup:

Share this post


Link to post
Share on other sites

I sent my wheel in to be repaired and they updated the firmware to the new 18LH version. It works much better now. Today though I did another motor change on a second 18XL and I can't find any information on how to update to the new firmware. I have both the standard Kingsong app as well as the Kingsong Debug app. Neither one gives me a new firmware option. Where do I find this mysterious new firmware?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...