Jump to content

Weped GT50E Torque Feedback Questions


Recommended Posts

Hi Everyone,

Any GT50E owners in this sub? I just got mine, and I don't understand how the acceleration works. Even gassing it lightly, causes my front tire to lift off the ground about an inch. Anyone experience this?

I'm leaning forward with all my weight when I do this, so it's not me leaning back. I've also turned off fast start and still manage to lift off the ground about an inch when accelerating?

Second question: Is there anyway to go faster than 15 mph with turbo mode turned off? The only way I've found to exceed 15 mph is to keep turbo turned on, which I think has way too much torque - It causes my tire to lift off the ground even when rolling.

For example, I'll be rolling at 15 mph and give it gas with turbo mode turned on, causing my front tire to lift up.

Any feedback is appreciated as I'm a bit scared of using it.

Link to post
Share on other sites

Edit - Have confirmed that turbo mode has to be on to reach any speed above 15 MPH. Problem is still the kick when accelerating, it lifts the front tires off the ground, even when rolling. So if you're turning at lets say 6-7 MPH and then accelerate, you wipe out because the front tire comes off the ground.

Link to post
Share on other sites

l've been talking to Weped, so l'm going to assume you are too ...only just a guess, but sounds like inside your LCD throttle control it has been "speed pre-set" (P8 max output) for 15 mph & the torque setting (P9 battery save) is on 3 none, instead of 2 medium or 1 max ...&or you have 2 "grey wire" speed retard/limiting wires (15 mph) connected under the deck ...powerful scooter, going to take time for you to get used to it.

...l see near-new big e-scooters on our NZ online auction site Trademe regularly ...sellers are people that got a shock when they realised they were standing on a high-speed death-trap hanging on to a stick :cry2::cry2::angry: lol :laughbounce2:

ps. mmm, l cannot imagine what the turbo mode button has to do with enforcing a 15 mph speed limit, you should have a basic 1, 2 or 3 (speed step) on your LCD throttle control,  you can change by tapping your reset button ...easy peasy

pss. mmm, mmm, inside your LCD throttle control is (P7 slow start) 0-off 1 to 5 SLOW START

l've described the 5 options for making my korean minimotors Dualtron 3 as gentle as a lamb ...your korean Weped GT50E should be similar.

They seem to duplicate each other ...and also the turbo mode button.

We are interested in your customer conclusions about the GT50E after you have owned it for a little while & are familiar with it & how the oriental mind works.

Edited by stephenbadger
2 cents worth
Link to post
Share on other sites

@stephenbadger - thanks for taking the time to reply. The P Settings on Wepeds are different. There inst a throttle control (acceleration) like the DT. I own a DT and I'm familiar with the option.

p0 = tire diameter size. (10 = GPS Speed same)

p1 = Voltage. (450) 

p2 = Can not change. (15) 

p3 = Can not change. (1) 

p4 = km & mile change. (1 = mile) (0 = km)

p5 = Kick and go. (1 = ON)

p6 = Cruise mode. (0 = OFF)

p7 = Slow / Fast Start. (0 = Fast Start & 1 = Slow Start)

p8 = MAX Speed. (100) 

p9 = Electronic brake. (2 = MAX)

 

P7 is set to Slow Start

P8 is set t0 70% currently.

 

The problem I am having is the acceleration. I currently own a dual tron with 600 miles and I am able to accelerate to 30+ smoothly, meaning, the tires are on the ground at all times without jolts.

 

The weped on the other hand jolts when accelerating causing the front tire to lift into a wheelie for a second or two. This happens from a push start or even while rolling. For example, If' I'm doing 10 MPH and then want to accelerate to the max speed on mode 1 (18 MPH). The weped will jolt me at 10 MPH causing the front tire to lift off the ground up to 18 MPH.

 

It's a nice scooter, but its flawed as it, the acceleration/torque is always at 100% - This results it kicks when using it normally, I've had a few people test and the result was the same, no matter when the throttle is applied, there is a kick on the scooter, causing the front tire to come up about an inch off the ground.

 

 

Link to post
Share on other sites

You can ask questions on the site you bought it on www.wepedscooters.com ...hopefully the english speaking man is familiar with how the product works.

This bang, bang, bang on the accelerator is putting a strain on the resistors inside the 2 controllers.

The torque  P setting (battery save) appears to be completely missing from your P settings ...very strange indeed ...you're hammering the battery constantly.

You can ask questions or sell the scooter on www.reddit.com/r/ElectricScooters/ (post that gif with a brief headline "heading") ...finding other Weped owners is a problem, most of them live in South Korea or the Philippines.

On my Dualtron 3 ...

P0 = tyre [10] ...adjust to get exact GPS 9.3" ??

P1 = scooter voltage [60]

P2 = number of motor pole magnets [15]

P3 = don't know [0]

P7 = slow start [0 off, 1 to 5 slow start]

P8 = max output/speed [5 to 100%]

P9 = battery save/torque [1 max save, 2 med save, 3 no save]

PA = electronic brake power [0 off, 1 to 5 powerful]

......if the scooter voltage P1 is wrong, it affects when or if the battery shuts-down.

......check & click your p7 settings again is my best guess.

Edited by stephenbadger
2 cents worth
Link to post
Share on other sites

u/InterstellarReddit ...l can see you asking questions on Reddit, but getting no answers ...addressing your concerns to is Mr Cooper Klinger on wepedscooters.com is an excellent idea, as you are protected under their Warranty.

However, l suspect this may turn out to be the culprit responsible for what is annoying you about your new scooter ...

Weped GT50E SPECS

Max Speed : 45 mph ( limited in the USA to 15 mph via speed limiting wire ) ...should be 2 wires, 1 per controller, under the deck ...should be able to disconnect a connector on each wire.

:pooping: ...and that is my 2 cents worth, enjoy !!

Link to post
Share on other sites
  • 9 months later...
On 11/2/2019 at 9:25 AM, stephenbadger said:

u/InterstellarReddit ...l can see you asking questions on Reddit, but getting no answers ...addressing your concerns to is Mr Cooper Klinger on wepedscooters.com is an excellent idea, as you are protected under their Warranty.

However, l suspect this may turn out to be the culprit responsible for what is annoying you about your new scooter ...

Weped GT50E SPECS

Max Speed : 45 mph ( limited in the USA to 15 mph via speed limiting wire ) ...should be 2 wires, 1 per controller, under the deck ...should be able to disconnect a connector on each wire.

:pooping: ...and that is my 2 cents worth, enjoy !!

How do you do this ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...