Jump to content
Juggler

Kingsong 16x rear lights flashing on charge

Recommended Posts

I just received my new KS16x  which I won by watching and subscribing to Kuji's review and giveaway video on you tube.

I plugged in the charger to fully charge the wheel before venturing out on it for the first ride. All seemed fine although the KS app said 100% charged but the red light was still on on the charger.

So after a short test ride (13 miles) I plugged in the charger only to see the red rear lights flashing. It didn't do it the first time on charge so what's going on?

Share this post


Link to post
Share on other sites

eventually it will turn green, just wait a bit longer.

The rear lights flashing, did you update the firmware between your 2 rides ?

Share this post


Link to post
Share on other sites

Not too worried too much about the red light not turning green on the charger, probably should have waited longer but the KS app said it was 100% charged!

I updated the firmware during the initial charge, then went for a ride. Plugged in the charger after the ride and the rear lights started flashing!

 

 

Share this post


Link to post
Share on other sites

After 1.05 update. The rear red lights on 16x flashes when charging. If you're on iOS kingsong app, the battery level in app is wrong. I think the newest android app is suppose to be OK for better battery level.

Share this post


Link to post
Share on other sites
On 8/29/2019 at 5:25 AM, Juggler said:

I just received my new KS16x  which I won by watching and subscribing to Kuji's review and giveaway video on you tube.

I plugged in the charger to fully charge the wheel before venturing out on it for the first ride. All seemed fine although the KS app said 100% charged but the red light was still on on the charger.

So after a short test ride (13 miles) I plugged in the charger only to see the red rear lights flashing. It didn't do it the first time on charge so what's going on?

So you’re the guy that won....!

 

Anyway, as of fw1.05, the rear ref light blink during charging and continue to blink when your wheel is fully charged. 

Nothing to worry about. 

Share this post


Link to post
Share on other sites
On 8/29/2019 at 12:49 AM, Genghis said:

After 1.05 update. The rear red lights on 16x flashes when charging. If you're on iOS kingsong app, the battery level in app is wrong. I think the newest android app is suppose to be OK for better battery level.

Correct, battery level on Android is ok. 

Share this post


Link to post
Share on other sites
12 hours ago, Garrie Lim said:

So you’re the guy that won....!

I know... Right?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...