Jump to content
GeneralTurnover

Broken KS 18L - Please Help (Details Inside)

Recommended Posts

Posted (edited)

Hey all, so I bought this KS 18L off ebay about a month ago. It came with the EUC and 2x chargers, that's it, no manual, and I figured I'd figure out how to learn it. I'm big into my esk8, so I use that all the time instead. Now, my decision became to sell this. I met up with someone earlier today, everything was good. To get back home, I used my esk8 while carrying this on the side with the power on. About a quarter mile from my place, something happened and the power seemed to have shut off as I was going ~20kmph on my esk8, snapping the handle and making me drop the EUC. I was pretty sure I had it charged to ~70% of so, so I don't think power was the issue. Of course I was in the middle of the street during this ordeal, so that was fun. I bought a new handle, and I guess I'll have to figure out how to put the new one on. NOW, the other issue is that the EUC refuses to turn on. The power still works, as in if I hold the power button, the red light will show. Is this because the handle is broken, and will be fixed once I install the new handle? Or is this a bigger underlying issue? ADDITIONALLY, the KS 18L since I received it will often do a double beep as I attempt to get on, and will not be balanced anymore. After a quick roll back and forth or something, it goes back to staying up straight. Why is this?

 

TLDR:

- Going to need to fix broken handle, any instructions for that? I just bought one.

- EUC will not power on now. If I hold down power button, the red light will show and that's it. Why is this, is there something else I need to fix?

- WHAT is with the double beep and what I imagine is the EUC recalibrating the balance? This happens almost every time someone tries to get on. As I tried selling it today, this made the guy completely fly forward off the EUC upon initially getting on it. Once someone is on and going though, it seems to be fine.

 

 

Thanks for any help passed my way!lo58vpys0xf31.jpg

Edited by meepmeepmayer
text was light grey - made it black

Share this post


Link to post
Share on other sites

This sounds to me like a motherboard issue.... I think you should contact a repair centre... Also just before doing that, I will first try to put connect the charger and then try to connect to your wheel with android or ios app... It that works you should check if there is any fault displayed,  if serial number is present, etc..

  • Like 1

Share this post


Link to post
Share on other sites

Thank you, you're the first to mention the motherboard or a service center. I never even conected via the app, so I'm attempting that as I write this post.

  • Like 2

Share this post


Link to post
Share on other sites

As an update to the post I just attempted to create, since I can't turn on the device (only the light comes on when I hold the power button), I can't connect the the app. I guess I'm going to have to take an uber to one of the shops though, since I don't have a car and carrying 55lbs a few miles will be excruciating and next to impossible for me.

  • Like 1

Share this post


Link to post
Share on other sites
  • This sounds very much like a board issue. Not sure what the double beep is, but it's either also from the board malfunction or unrelated.
  • You need a new board, simple as that. Nothing to repair here. Something clearly failed without good reason, that can pretty much only be the board.
  • To repair the handle, you just need new parts. Depends on what exactly is broken. No need to bring it to a repair shop (which is the only thing a repair shop could possibly help you with - anything electronics related needs someone specifically working with EUCs), that's just a lot of effort for little to  no gain.

I'd contact Jason at ewheels.com or maybe euc.nyc (closer EUC seller) for a board, the handle parts, and maybe some info (or you send the wheel in for a paid repair). Also don't underestimate asking your ebay seller first, in principle he should be able to help you too.

Kingsong themselves might be able to help you too. There's a support email address: support@szkingsong.com  (use simple and unambiguous English). Maybe @Micheal Shen (KS representative) can also give some tips. But the short version is, you need a new board and the handle parts, and after the repair either everything works (most likely) or you look into it further with a proven good board.

Share this post


Link to post
Share on other sites

@GeneralTurnover If you can't connect at all using app, then it's almost sure that your motherboard died.... when you connect KS18 to the charger, and even if the wheel is off, you should be able to connect... I guess your only option is to check with a repair service... Also I'm adding @US69 here as he is KS representative and may he have some ideas on what is going on...

Share this post


Link to post
Share on other sites
Posted (edited)

I wonder if a faulty state of a broken lift sensor could be the issue here after all. The lift sensors are at the very bottom of the trolley handle poles, one of which has detached completely. Is the double beep the same sound you used to get when lifting up the wheel?

If the other sensor gives a signal to the mainboard that it is being lifted, the wheel might not power up. And if the signal is intermittent, it would indeed stop balancing every now and then as long as the speed is below 4km/h or so. Once the wheel goes faster than that, the wheel is supposed to ignore the lift sensors, so that part sounds normal.

I would repair the handle (and possibly the related lift sensor) first before getting yourself a new mainboard. Just in case.

Edited by mrelwood
  • Upvote 3

Share this post


Link to post
Share on other sites

@GeneralTurnover

This may help a bit, I have spare handle bars if you want them. Free of charge, if the shipping is cheap enough for you from Ireland.

They need to be fixed as explained on this article :

 

But if you can afford it you're better off getting the new version handle bars which work better. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...