Jump to content

Recommended Posts

Hi, 

i recently bought a V10 but the charger is not doing it’s job. Just looking for someone around with a V10 charger so that i can try to charge and se whether it is a charger or battery issue. I live in Perth. 

Thanks 

guillaume

Share this post


Link to post
Share on other sites

Hi Guillame,
On the off-chance you're having the same problem as these other guys, see if my advice in this post might help:

link

In short, several parts of the charger are typically loose and won't charge properly. To fix it, make sure the parts I mention in that post are seated properly.  Hope this helps.

 

Share this post


Link to post
Share on other sites

Hi thanks for your help. I made sure all parts of the box are seated properly but the charger still doesn’t work (remains green when supposed to charge). I tested it and measured the expected 85V out of the box... Now liaising with the reseller to try to get a new charger. Frustrating :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...