Jump to content
Jim Martin

Nikola 100v 1845 from China arrived but...

Recommended Posts

Well I just got my Nikola 100v 1845 wheel from China, but the box was opened and there was no charger, just a damn note saying I'm now a valued Ali customer.  So damn pissed off, but I guess it's my fault.  The thing is worthless without a charger.  UGH!

 

IMG_0894.thumb.JPG.a57202c8dfb1e3a924f7655a2af5e16d.JPG

Edited by Jim Martin

Share this post


Link to post
Share on other sites
3 minutes ago, Jim Martin said:

Well I just got my Nikola 100v 1845 wheel from China, but the box was opened and there was no charger, just a damn note saying I'm now a valued Ali customer.  So damn pissed off, but I guess it's my fault.  The thing is worthless without a charger.  UGH!

@Jim Martin, although it is obviously dis-heartening to have the wheel turn up without the charger all is not lost.  It has been posted elsewhere on the forums by others that the Nikola 100v Plus Does Not come with the charger in the box and that it will arrive separately in it's own box. 

The reason for this is that the 100v charger is much larger than the dedicated spot in the foam packaging, so it will arrive at some point. 

Some have at least stated that their Nikola Plus arrived with a 100% charge, so were able to have an initial test ride, but yeah bit of a bummer not knowing this beforehand!!!

Share this post


Link to post
Share on other sites
1 minute ago, fbhb said:

@Jim Martin, although it is obviously dis-heartening to have the wheel turn up without the charger all is not lost.  It has been posted elsewhere on the forums by others that the Nikola 100v Plus Does Not come with the charger in the box and that it will arrive separately in it's own box. 

The reason for this is that the 100v charger is much larger than the dedicated spot in the foam packaging, so it will arrive at some point. 

Some have at least stated that their Nikola Plus arrived with a 100% charge, so were able to have an initial test ride, but yeah bit of a bummer not knowing this beforehand!!!

WTF, why would they do this?  So I wait another month for the damn charger???

Share this post


Link to post
Share on other sites
Just now, Jim Martin said:

WTF, why would they do this?  So I wait another month for the damn charger???

Hopefully, it was sent at the same time as the wheel and my not be too far away.  You are not on your own, everyone that has just taken delivery from China has said exactly the same.  Does it at least have some charge in it, if so how much???

Share this post


Link to post
Share on other sites
3 minutes ago, fbhb said:

Hopefully, it was sent at the same time as the wheel and my not be too far away.  You are not on your own, everyone that has just taken delivery from China has said exactly the same.  Does it at least have some charge in it, if so how much???

Yep, it's at 99.2 Volts.  But not even worth riding if I get the high and then can't ride anymore.  I haven't gotten any tracking information on another package arriving from China so who knows where the hell it is.  I'm just about done with GotWay, they suck!

Share this post


Link to post
Share on other sites
13 minutes ago, Jim Martin said:

Yep, it's at 99.2 Volts.  But not even worth riding if I get the high and then can't ride anymore.  I haven't gotten any tracking information on another package arriving from China so who knows where the hell it is.  I'm just about done with GotWay, they suck!

I don't think it's fair to hold the manufacturer of the product responsible for the actions or inactions of a private aliexpress reseller, but i totally understand you being bummed out. A new one would be expensive on top of taking time to receive. 

Try to contact the aliexpress seller via their messaging system but keep the messages short and to the point and use as simple english as possible for best results wait one business day in between sending them new messages if they're yet to respond. Good luck.

Share this post


Link to post
Share on other sites
9 minutes ago, xiiijojjo said:

I don't think it's fair to hold the manufacturer of the product responsible for the actions or inactions of a private aliexpress reseller, but i totally understand you being bummed out. A new one would be expensive on top of taking time to receive. 

Try to contact the aliexpress seller via their messaging system but keep the messages short and to the point and use as simple english as possible for best results wait one business day in between sending them new messages if they're yet to respond. Good luck.

The manufacturer chose to ship out chargers separately because they don't fit in the box.  So who know where the hell my charger is, somewhere on a boat probably, thanks GotWay!

Share this post


Link to post
Share on other sites
1 hour ago, Jim Martin said:

WTF, why would they do this?  So I wait another month for the damn charger???

C.H.I.N.A.   They don't have the Western mindset :)

FWIW, I'm missing the charger too.

Share this post


Link to post
Share on other sites

Third owner missing the charger here :blink1:

My solution: while waiting for the normal charger to arrive, ordered the fast charger from ewheels, and it will arrive in couple days.

Share this post


Link to post
Share on other sites

Correct I just got mine and no charger in the box, it was shipped separately, an odd choice.

Share this post


Link to post
Share on other sites

BTW, I assume everyone's voltage readout on the side of the wheel is not working?

I surmise that Gotway designed the hardware for the 84-volt wheel and decided to be lazy and not make a new version for the 100-volt models. Just like they were lazy in not redesigning the packaging for the 100-volt charger.

Lame, but I'm not surprised.

Share this post


Link to post
Share on other sites
2 minutes ago, Marty Backe said:

BTW, I assume everyone's voltage readout on the side of the wheel is not working?

I surmise that Gotway designed the hardware for the 84-volt wheel and decided to be lazy and not make a new version for the 100-volt models. Just like they were lazy in not redesigning the packaging for the 100-volt charger.

Lame, but I'm not surprised.

My 100v Nikola shows the voltage on the side, and correctly.

Share this post


Link to post
Share on other sites
1 hour ago, edwin_rm said:

My 100v Nikola shows the voltage on the side, and correctly.

Thanks for that. Mine doesn't. And someone else posted that theirs didn't.

But great to know it's not a 100-volt wheel issue, just a broken meter.

Share this post


Link to post
Share on other sites
2 hours ago, Marty Backe said:

BTW, I assume everyone's voltage readout on the side of the wheel is not working?

I surmise that Gotway designed the hardware for the 84-volt wheel and decided to be lazy and not make a new version for the 100-volt models. Just like they were lazy in not redesigning the packaging for the 100-volt charger.

Lame, but I'm not surprised.

Mine shows 99.6 when first turned on.

Share this post


Link to post
Share on other sites
23 hours ago, edwin_rm said:

My 100v Nikola shows the voltage on the side, and correctly.

Same here

Share this post


Link to post
Share on other sites

OK, so it was just pointed out to me that the display shows "--.-" until the voltage drops below 100-volts. So when the wheel is fully charged it appears to not be functioning.

@maltocs, your voltage display is indeed working properly.

Share this post


Link to post
Share on other sites
23 minutes ago, Marty Backe said:

OK, so it was just pointed out to me that the display shows "--.-" until the voltage drops below 100-volts. So when the wheel is fully charged it appears to not be functioning.

@maltocs, your voltage display is indeed working properly.

At least we know there was a really good charge in it when received. It also shows you REALLY meant it when you said you don't really care about the existence of this LED for you not to notice after the range test.

Share this post


Link to post
Share on other sites
5 minutes ago, maltocs said:

At least we know there was a really good charge in it when received. It also shows you REALLY meant it when you said you don't really care about the existence of this LED for you not to notice after the range test.

Exactly. But after @Mrd777 mentioned the behavior (he has the 100-volt base model) I went and turned on your wheel to see ~88-volts.

I'll ask you in 6-months how often you use yours :)

Share this post


Link to post
Share on other sites
12 minutes ago, houseofjob said:

After thinking it through, I think it's possibly because they're using the same volt meter as 84V, so there's not extra digit for the 100's.

I think this is the same reason you can't right hobbyist's chargers for 100V reading.

You're absolutely correct. Just like Gotway didn't modify their box packaging to accommodate the bigger 100-volt charger, they also didn't bother to upgrade the Digital LED display.

Share this post


Link to post
Share on other sites
26 minutes ago, houseofjob said:

After thinking it through, I think it's possibly because they're using the same volt meter as 84V, so there's not extra digit for the 100's.

12 minutes ago, Marty Backe said:

Just like Gotway didn't modify their box packaging to accommodate the bigger 100-volt charger

:facepalm:

Share this post


Link to post
Share on other sites

Marty if you're ever wondering why I'm so picky about getting a new wheel... I'm supposed to pay 2k and upwards for this kind of **** or whatever disaster the Kingsong app/firmware is?!:eff04a58a6:

Share this post


Link to post
Share on other sites
46 minutes ago, Marty Backe said:

You're absolutely correct. Just like Gotway didn't modify their box packaging to accommodate the bigger 100-volt charger, they also didn't bother to upgrade the Digital LED display.

Good thing about all this: I no longer make common sense, mindless consumer assumptions any more when I get a wheel now, I always check for possible issues *smh.

Edited by houseofjob

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...