Jump to content
snuckit

Kingsong Firmware 1.13 Seems to have totally bricked my KS-18XL

Recommended Posts

Something is really wrong with my KS 18XL. I went to update the KS App to 1.13
 
As the firmware was updating, white lights, one at a time, would light up, showing the progress. After the firmware update to 1.13 was complete  (maybe?)  all the white lights remained lit, the power was on and the wheel seemed locked up. It was hard to move it back and forth. I could not get any response from it. All lights remained lit. I could not turn it off.
 
I restarted my phone to see if it would reload the firmware  - no change
I deleted and reloaded the KS App (Blue) - no change
I finally removed the case and unplugged the battery - both sides - lights went out.
But,
 
Now I can't get my wheel to power up and stay powered up
The Bluetooth on my iPhone says it is connected to KSMusic but no Sign of my wheel in the devices but I can access the app
 
If I hold the power button down I hear the speakers click on, the voice announces “bluetooth connected” and the KS APP seems to connect. But, as soon as I release the power button, the speakers make that click sound again and and the APP disconnects. The only way the wheel stays on ( or at least in a limited form)  is if I keep my finger on the power button. When I keep my finger pressed on the power button I can access the app and see what the stats are. 
 
The firmware stat says
 
Version 0.00
 
So, something is really wrong with my wheel and it seems and I cannot use my wheel at this point, at all. Any Thoughts?
 
Does anyone have any details on how to downgrade the firmware back to 1.12 using an iPhone or get past the "current one is the latest version - I know it" screen so I can try and get any firmware in this thing?

18xl dead 01.jpg

IMG_8928.jpeg

IMG_8929.jpeg

Share this post


Link to post
Share on other sites

Hi,

I had the same experience with my L 3 weeks ago. I bring back the wheel to the shop and unfortunately it has been totally impossible to connect using the « engineer app » these guys are using. Like for you the app was showing V0.00, which basically means there is no more firmware :(

The wheel has been finally repaired by KS Europe, the French KS représentative who, if I understood well, has used a cable connection to the motherboard. I am not totally sure of this « cable » connection as I heard it from the shop tenant as a description of what the workshop will do, not a report of what they have done actually to fix the problem. I got my 18L back in good shape 10 days after.

We suspected the cause could be unstability of the Bluetooth connection this wheel had before, now under the v1.13 this BT problem seems resolved.

Sorry but you probably need to contact your seller.

Paul

 

Share this post


Link to post
Share on other sites

I have been forwarded this thread link to KingSong Europe (Polish)
and I hope someone from KS support will post an workaround for your situation.

Share this post


Link to post
Share on other sites
Posted (edited)

Dear @snuckit,

If the application can connect to the wheel, this means it is not so bad.

Please contact to us directly on email support@kingsong.pl and I will try to help you ASAP.

Edited by EUniCycles.eu

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...