Jump to content

Recommended Posts

Posted (edited)

I imagine that's where I'm doing something wrong...

I start the app, activate the V8, press the BT icon on the app and then one by one try to pair the unknown devices.

Edited by Animation-Imp

Share this post


Link to post
Share on other sites
Posted (edited)

Uninstalling an App normally does not really delete / clean everything. 

The whole process should include Force Stop, Clear Cache, Clear Storage, Uninstall. 

Details may vary depending on your Android version / brand specific customizations / launchers, but that's what you are looking for, in a nutshell. 

Edited by Coco66

Share this post


Link to post
Share on other sites

I know, but in this case EUC World is a totaly new app with it's own cache, no?

So there shouldn't be any interferance from an old Wheellog install?

The frustrating part is Wheellog used to work... no issues what so ever.

Share this post


Link to post
Share on other sites

Thanks @Seba -I tested 2.0.1 first time. Tour info was always present - didn't disappear as with version 1.

Camera feature - really nice :)

What I realized is, that the percentage battery level is now too optimistic. I cross checked with wheellog. In version 1 EUC was always about 5% less than wheellog (which was correct in terms of rea battery level) - now EUC is about 3% more!! than wheellog. If trusting this new percentage, you are lost. Meaning you will have to walk the last kilometer!!

Anyway - great 'job'!

Share this post


Link to post
Share on other sites
2 hours ago, Animation-Imp said:

I start the app, activate the V8, press the BT icon on the app and then one by one try to pair the unknown devices.

By default EUC World app skips unknown BT devices during a scan (however you can change it in settings). It's because every EUC I know do have a name. Your EUC should appear on list as device which name starts with V8.

Share this post


Link to post
Share on other sites
5 minutes ago, MBIKER_SURFER said:

Thanks @Seba -I tested 2.0.1 first time. Tour info was always present - didn't disappear as with version 1.

It's because now entire map is a part of an app and isn't fetched from Internet. In fact only map tiles are fetched from Internet but they are then cached locally.

6 minutes ago, MBIKER_SURFER said:

Camera feature - really nice :)

Thanks :) I was asked by many users to add handy camera feature that would overlay most important ride information. I also wanted to make it easy to use during tour recording. Previously used default camera app required way too much operations to take a picture. I just wanted to make entire operation as easy and quick as possible, so it won't be distracting.

9 minutes ago, MBIKER_SURFER said:

What I realized is, that the percentage battery level is now too optimistic. I cross checked with wheellog. In version 1 EUC was always about 5% less than wheellog (which was correct in terms of rea battery level) - now EUC is about 3% more!! than wheellog. If trusting this new percentage, you are lost. Meaning you will have to walk the last kilometer!!

Please give it a try :) I don't think you'll end up walking the last kilometer :) Now it should give you 2-4 km of distance reserve after it shows 0 %.

Share this post


Link to post
Share on other sites

AVAS sound pack library can now be used with EUC World 2.0 for easy sound pack installation:

 

Share this post


Link to post
Share on other sites
Posted (edited)
27 minutes ago, Seba said:

By default EUC World app skips unknown BT devices during a scan (however you can change it in settings). It's because every EUC I know do have a name. Your EUC should appear on list as device which name starts with V8.

I only get unknown devices...

I'll try to pair with my wife's phone this evening so I can compare the behaviour.

Edited by Animation-Imp

Share this post


Link to post
Share on other sites
Posted (edited)
25 minutes ago, Animation-Imp said:

I only get unknown devices...

I'll try to pair with my wife's phone this evening so I can compare the behaviour.

Pairing is only needed for playing music on the EUCs speaker. For EUC World one has to connect from the app

ovaWaie.png

Once it's To start scanning press on the bluetooth icon in the topmost line of the app to get the menu to select your wheel.

Location services have to be allowed for the BLE system to work with EUC World (and every other app)!

Edited by Chriull

Share this post


Link to post
Share on other sites
3 minutes ago, Chriull said:

Pairing is only needed for playing music on the EUCs speaker. For EUC World one has to connect from the app

ovaWaie.png

Once it's scanning press on the bluetooth icon in the topmost line of the app to get the menu to select your wheel.

Location services have to be allowed for the BLE system to work with EUC World (and every other app)!

Yes, that's exactly what I'm doing.
But when scanning I only get unknown devices, no V8...

Share this post


Link to post
Share on other sites
2 minutes ago, Animation-Imp said:

Yes, that's exactly what I'm doing.
But when scanning I only get unknown devices, no V8...

EUC World is allowed to get location?

Does it work to connect to the V8 with other apps?

Share this post


Link to post
Share on other sites
Just now, Chriull said:

EUC World is allowed to get location?

Does it work to connect to the V8 with other apps?

Yes, I can record my route without the wheel connected.

And the V8 connects without issue with the standard Inmotion app.

Share this post


Link to post
Share on other sites
2 minutes ago, Animation-Imp said:

Yes, I can record my route without the wheel connected.

And the V8 connects without issue with the standard Inmotion app.

Inmotion app is stopped when you try to connect with EUC World? Afaik only one can be connected?

Share this post


Link to post
Share on other sites
Just now, Chriull said:

Inmotion app is stopped when you try to connect with EUC World? Afaik only one can be connected?

Yes, I even restarted the phone  before the attempt just to be sure that I start clean.
Thank you guys for helping to get to the bottom of this by the way :)

Share this post


Link to post
Share on other sites
2 minutes ago, Animation-Imp said:

Yes, I even restarted the phone  before the attempt just to be sure that I start clean.
Thank you guys for helping to get to the bottom of this by the way :)

You're welcome!

But seems i'm running out of ideas/possibilities :(

Just to reconsider - you pressed the bluetooth icon in EUC World app (circled in red in my picture, not the android system bluetooth icon) and got a window "Scanning..." like in my linked picture, but your V8 is not shown in the list?

But your wheel connects to inmotion app (running on your phone) and used to connect to wheellog.

EUC world has location permission as you can record tours and ?it shows other bluetooth devices in the "Scanning..." window?.

Maybe your V8 has a "strange" bluetooth name? Afaik one can rename ones wheel bluetooth name without restriction - maybe you can see it somehow with your inmotion app? Or you get the bluetooth identifier (xx:xx:xx...) with the inmotion app, as this is shown in the "Scanning..." list of EUC World too!

Share this post


Link to post
Share on other sites
3 minutes ago, Chriull said:

You're welcome!

But seems i'm running out of ideas/possibilities :(

Just to reconsider - you pressed the bluetooth icon in EUC World app (circled in red in my picture, not the android system bluetooth icon) and got a window "Scanning..." like in my linked picture, but your V8 is not shown in the list?

But your wheel connects to inmotion app (running on your phone) and used to connect to wheellog.

EUC world has location permission as you can record tours and ?it shows other bluetooth devices in the "Scanning..." window?.

Maybe your V8 has a "strange" bluetooth name? Afaik one can rename ones wheel bluetooth name without restriction - maybe you can see it somehow with your inmotion app? Or you get the bluetooth identifier (xx:xx:xx...) with the inmotion app, as this is shown in the "Scanning..." list of EUC World too!

Yes I'm afraid all of the above...
The identifier in the inmotion app is the device name (V8-and a alphanumerical code).

I haven't been able to determin the actual BT identifier of the wheel.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Animation-Imp said:

Yes I'm afraid all of the above...

Sorry - that's all i could think of.

Maybe @Seba has some more ideas? Maybe sometjing strange occured by implementing the new inmotion wheels?

Quote

The identifier in the inmotion app is the device name (V8-and a alphanumerical code).

Ok. Then the bluetooth mac is of no use... 

Quote

I haven't been able to determin the actual BT identifier of the wheel.

 

Edited by Chriull

Share this post


Link to post
Share on other sites

I rode this morning to work, tracked my tour with euc world, no problems.

Saw your new update, now it won't track my tour anymore.

It keeps showing my tour from this morning.

Normally it starts tracking as soon as euc world is connected, now it won't even start when i push the "play" button

Share this post


Link to post
Share on other sites

I just recorded a tour a few days ago, and it logged 3MB of data on the phone.  It always uploaded in the past, but didn't thins time.  I manually uploaded the CSV to euc.world but it won't let me create a tour from it.  Anyone have any ideas?

 

Share this post


Link to post
Share on other sites

@seba I'm glad, that the new version of your great app now supports the V8f. Everything works as usual except the reported milage. 146123,23 km  is quite a lot for a 1.8 km trip.
The recorded tour on the website shows the correct milage.
Anyway, thank you for your great work.

euc_world1.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, saw said:

@seba I'm glad, that the new version of your great app now supports the V8f. Everything works as usual except the reported milage. 146123,23 km  is quite a lot for a 1.8 km trip.
The recorded tour on the website shows the correct milage.
Anyway, thank you for your great work.

euc_world1.jpg

That is some great battery life!!! 1% for 146,000 km! :w00t2:

Edited by /Dev/Null

Share this post


Link to post
Share on other sites
56 minutes ago, Slashebeest said:

I rode this morning to work, tracked my tour with euc world, no problems.

Saw your new update, now it won't track my tour anymore.

It keeps showing my tour from this morning.

Normally it starts tracking as soon as euc world is connected, now it won't even start when i push the "play" button

Is the start button gray or white? EUC World now wait for GPS to lock on position. If there is no GPS signal, this button will be grey and inactive. You can swipe up on main screen to switch to GPS mode and see if there is blue GPS icon indicating that GPS signal is OK.

23 minutes ago, saw said:

@seba I'm glad, that the new version of your great app now supports the V8f. Everything works as usual except the reported milage. 146123,23 km  is quite a lot for a 1.8 km trip.

Thank you! I'll fix it ASAP (fortunately I still have a V8F for testing) and push update.

Share this post


Link to post
Share on other sites
1 hour ago, Seba said:

Is the start button gray or white? EUC World now wait for GPS to lock on position. If there is no GPS signal, this button will be grey and inactive. You can swipe up on main screen to switch to GPS mode and see if there is blue GPS icon indicating that GPS signal is OK.

 

It was indeed grey, will try it tomorrow :thumbup:

Share this post


Link to post
Share on other sites

Is it inpossible to get 80% alarm (battery) to work from gotway wheel?  Hard code to break? 

Share this post


Link to post
Share on other sites

Does anybody know where to find the full release log of EUC World since it was created (or at least 2.0 log)? I'm waiting for the promised addition of the GPS tracker into EUC World and the release log of the 2.0 version (which I didn't read) is no longer accessible at the Play Store (as it only shows the latest one: 2.0.1). Thanks! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...