Jump to content
Mossi

18XL How to set speed limit?

Recommended Posts

I just got my new 18XL and took it for a test ride. Unlocking and calibrating lift sensor worked as it should but I am not able to change the speed limit. Tried it for the first time after 5 km, didn't work. I drove now 20 km with constant tiltback and "Please decelerate!" wich is pretty annoying. I use app version 3.0.7 on android. I can move the sliders but I can't confirm.

Share this post


Link to post
Share on other sites
16 hours ago, Mossi said:

I just got my new 18XL and took it for a test ride. Unlocking and calibrating lift sensor worked as it should but I am not able to change the speed limit. Tried it for the first time after 5 km, didn't work. I drove now 20 km with constant tiltback and "Please decelerate!" wich is pretty annoying. I use app version 3.0.7 on android. I can move the sliders but I can't confirm.

This has been addressed before. You need to have higest speed set at the buttom slider. Any other speed setting must be lower than the slider below and higher than the slider above.

If this doesn't help let me know, and I post a screenshot tomorrow of my current setting.

Note: top speed is 20kmh if you hariden less than 5km. After that top speed can be set to 40kmh until you have 200km distance, at that point it can be unlocked to a topspeed of 50kmh.

Just checked my app version whitch is 1.54 for android. So either you are using old version or iOS? 

I just got version 3.0.7 installed last night.Screenshot_20190307-084628_Kingsong.thumb.jpg.318ff469a5cf2d369777722daa81dfff.jpg

This is my setting after riding 1300ish km on my wheel. I find riding faster too stressfull on my mind and knee (arthritis).

Edited by Unventor
Update with screenshot

Share this post


Link to post
Share on other sites

Yes I know how to set the sliders but I can't hit the confirm button. As I wrote I rode 20 km and I am using Android. I have this problem with 3.0.6 and 3.0.7. On the older app It says illegal equipment.

Share this post


Link to post
Share on other sites
8 hours ago, Mossi said:

Yes I know how to set the sliders but I can't hit the confirm button. As I wrote I rode 20 km and I am using Android. I have this problem with 3.0.6 and 3.0.7. On the older app It says illegal equipment.

I know from some time back you might have to disable wifi so you use mobile date to get a GPS location on some android phones (some have soversave settings that mess up the gps locater too). The app is trying to use your location data. If it can't get a GPS position the you can get the illegal hardware message.

Otherwise if I were you I would contact dealer. As they are you warranty point of contact. 

I would not download app from any other place that kingsong official app site (android app store or kingsong website, app section) as it is easy to search and get hacked using a unauthorized modded app to designed to hijack or hack your phone.

Share this post


Link to post
Share on other sites

I have this problem with the latest firmware and app on iPhone. I just got my new 18XL and rode 6 km on it. I think I should be able to lift the speed limit to 40 km/h but the app doesn’t allow it. 

What should I do?

Share this post


Link to post
Share on other sites
Just now, kasenutty said:

You using that new app that's all black inside? 

Yes, latest version

 

Share this post


Link to post
Share on other sites

I think I just unlocked mine with Darknessbot on IOS, then rode about 10 km and swapped back and it let me change max to 40. I'm not sure if it's 1, 2, 5, or 10 km for unlock. Do you have IOS? Try Darknessbot if so, otherwise maybe see if one these Android alternatives works like Darknessbot. 

Share this post


Link to post
Share on other sites
4 minutes ago, kasenutty said:

I think I just unlocked mine with Darknessbot on IOS, then rode about 10 km and swapped back and it let me change max to 40. I'm not sure if it's 1, 2, 5, or 10 km for unlock. Do you have IOS? Try Darknessbot if so, otherwise maybe see if one these Android alternatives works like Darknessbot. 

I’m on iOS and use DarknessBot. I couldn’t change the speed using DB at all. It connects but doesn’t show things correctly. 

Share this post


Link to post
Share on other sites

Sounds like you're just going to have Please Decelerate forever now :D 

 

Kidding, try adding a couple KM, try making sure the KS app is not connected to bluetooth whatsoever or even the KS Sound, and try connecting to Darknessbot. 

Share this post


Link to post
Share on other sites
1 hour ago, UniVehje said:

I have this problem with the latest firmware and app on iPhone. I just got my new 18XL and rode 6 km on it. I think I should be able to lift the speed limit to 40 km/h but the app doesn’t allow it. 

What should I do?

@US69 can you help with this?

Share this post


Link to post
Share on other sites

after I will (because now I have only 60KM done) drove 200km I can set the speed in DarknessBoot ?

or I will need to use KingSong app to unlock or press something. I'm asking this because I could create for me an valid account with any version or Kingsong app in my country.

Share this post


Link to post
Share on other sites
On 3/7/2019 at 2:04 AM, Mossi said:

Yes I know how to set the sliders but I can't hit the confirm button. As I wrote I rode 20 km and I am using Android. I have this problem with 3.0.6 and 3.0.7. On the older app It says illegal equipment.

I'm having this problem, too. My 18XL has about 160 km on it. I can change the speed settings in the KS app to above 20 kph  but the "confirm" button won't depress so the app won't push the new speed settings to my 18XL. When I go back into the speed settings, they're still capped at 20 kph.

Anyone have any ideas? 

BTW, I'm using the latest Android app and I'm on v1.11 firmware.

Share this post


Link to post
Share on other sites
58 minutes ago, rwent1 said:

I'm having this problem, too. My 18XL has about 160 km on it. I can change the speed settings in the KS app to above 20 kph  but the "confirm" button won't depress so the app won't push the new speed settings to my 18XL. When I go back into the speed settings, they're still capped at 20 kph.

You need to set speeds like this:

Screenshot_20190307-084628_Kingsong.thumb.jpg.318ff469a5cf2d369777722daa81dfff.jpg

And it might only work with app version 3.x.x

Share this post


Link to post
Share on other sites

So, let me be more precise.

My 18XL has greater than 5 km on it (78 mi = 125 km).

I can set my app up to show exactly what you are showing in your screen capture as well, and I can set any of the sliders to above 20 km/h as well. 

However, you see that [[ CONFIRM ]] button at the bottom of the screen? When I touch it, nothing happens. It doesn't change color, no confirmation 'click' -- nothing. It doesn't appear as though it was selected in any way. 

To confirm that nothing happens when I hit [[ CONFIRM ]], when I exit this screen and then come back into it, it only shows "20 km/h" again for all of the settings that I had previously adjusted upward.

Greater than 20 km.jpg

CONFIRM no work-ee.jpg

Share this post


Link to post
Share on other sites

You might need to force close app power off wheel. Or logout if app turn off wheel then login in the app and turn on wheel again. 

Why are you running version 3.0.7? Depending on firmware in wheel you might need newer app. 

On android the latest version is 3.1.3. 

Edited by Unventor

Share this post


Link to post
Share on other sites
5 hours ago, Unventor said:

You might need to force close app power off wheel. Or logout if app turn off wheel then login in the app and turn on wheel again. 

Why are you running version 3.0.7? Depending on firmware in wheel you might need newer app. 

On android the latest version is 3.1.3. 

I'm running v1.11, which is what the wheel came with. The KS app says that the latest firmware version is v1.13. I haven't burned this newest version because there are a lot of horror stories about bricked KS wheels, so I'm going by the adage "if it ain't broke, don't fix it".

Share this post


Link to post
Share on other sites
4 hours ago, rwent1 said:

I'm running v1.11, which is what the wheel came with. The KS app says that the latest firmware version is v1.13. I haven't burned this newest version because there are a lot of horror stories about bricked KS wheels, so I'm going by the adage "if it ain't broke, don't fix it".

You are still using an old version of the app. 

As a lot of bricked wheels, from firmware updating. I don’t see this reported here. Yes it can happen with any product you update, not just KS wheels. 

I still think you need to download latest app version. 

Share this post


Link to post
Share on other sites

I think you should download the latest app and do a firmware update. Make sure you disabled display rotation and your phone is charged. Set your display timeout to infinitely and don't touch your phone during update. Maby you should use mobile data instead of wlan. I did it several times and it worked well. How ever this will take a few minutes. Don't be impatient.

Share this post


Link to post
Share on other sites

I’m still a bit confused about this.

i only have 14 miles, and I’m not looking to circumvent the King Song safety feature...I just want to get rid of the tilt back and awful audio message.

do I use the OEM app or Darknessbot? What do I need to do?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...