Jump to content

Ninebot C+ Motor Controller Dead? NO POWER


DiZZy
 Share

Recommended Posts

Hello all.. 

I need some help to troubleshoot my no power problem on my C+.

The EUC does not power up when I press the red button.

The battery is fully charged, verified with volt meter.

The switch works, checked connection at the board input.

The wheel rotates freely, no problem with the motor phases/MOSFETS.

No led or lights on the board.

I unplugged the battery and hard cycled it. 

Tried the reset button trick..no luck.

 

It stopped working when the EUC fell over gently.

Does anyone know what parts to check on the board? I do have the equipment and skills to swap out components.

I tried to get it warrantied thru NINEBOT Spain, but they will not touch it since I bought it from Bestgear. 

I thought Ninebot had global warranty? Customer service in Spain is really bad especially thru the Authorized repair shop KPsport.

I do not want to buy a new board if there is a way to repair it.

Any suggestions? 

Link to comment
Share on other sites

Hi Eng62.. thx for your response. I checked the power coming into the mainboard and its correct 61VDC the same as the battery plug. I think my only option is to replace the board. 

The other problem is I need Ninebot to provide an activation code for the new board. Anyone every buy a board from Ebay?

Link to comment
Share on other sites

And on the board there is not any signs for overheating? Very strange!

I bought mainboard from Speedyfeet. The activating code was provided from Ninebot Europe. 

I bought it just in case I need it, when it was available. My E+ was sold with two working mainboards.

BTW, it is still available https://www.speedyfeet.co.uk/collections/ninebot-one-parts/products/ninebot-one-e-p-replacement-main-control-board

Edited by Ch.Eng.62
Link to comment
Share on other sites

  • 2 weeks later...

Ninebot China provided me an activation code and I entered it in the application, but the EUC lights still blink yellow. 

The C+ communicates with the application, can be locked, calibrated, see data, but the motor is not energized to balance. 

Has anyone had this same issue?

Link to comment
Share on other sites

<<SOLVED>>

After many days of getting the wrong activation codes from Ninebot China, they finally gave me the right code and it now works. I was able to activate my C+ using the android application.

It takes a while to find the right people at Segway Ninebot in China, but I have to say they tried hard to help me solve my problem. Very happy with the customer support. The customer support for Ninebot in Europe (Amsterdam) is horrible, they would not help at all since I did not buy from one of their stores.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...