Jump to content
Jean Dublin

KingSong 16X 1554Wh 2200W 16*3in (Released July 2019)

Recommended Posts

5 minutes ago, fryman said:

I understand you love the wheel and its acceptable to you (I may do the same one day). 25% or less before throttling should be acceptable.  KS is currently my manufacture of choice because of there quality and safety standards. It just seems we are lowering the bar for this wheel when I know KS can do better.

Kingsong won't go to 25% full throttle but hopefully the give us  full throttle down to 67-68v then 25mph below that etc etc

Share this post


Link to post
Share on other sites
1 hour ago, Unventor said:

Bring the wheel on your vacation. Or move to Nottingham. In the three years I lived there we only had 4 days of rain. IT did a 10 min in the morning and in the afternoon but not the hole day like in Sweden/Denmark. here it can rain more or less the hole day for a week 

She'd kill me if i could take the wheel away lol 😁.  For me personally I'd love to 😊

Share this post


Link to post
Share on other sites
6 minutes ago, stephen said:

Kingsong won't go to 25% full throttle but hopefully the give us  full throttle down to 67-68v then 25mph below that etc etc

Keep up the great work Stephen

Share this post


Link to post
Share on other sites
1 hour ago, fryman said:

Good example why Kingsong's engineers need to keep working on this wheel.  We know they can do better.

It’s voltage sag, any wheel or electric vehicle will encounter this....

Share this post


Link to post
Share on other sites
7 minutes ago, Mike Paolini said:

So I'm sad to report that on todays ride, using 906 firmware, and playing music I encountered the tilt forward, followed by tilt back problem at low speed.

The tilt forward was subtle and an first I thought I was imagining it, then it transitioned about about 5 seconds into a 15 degree tilt back that lasted a good 10 seconds, while I slowed to see what was going on and dismounted. It remained tilted back while I was dismounted for a good 5 seconds before returning to normal.

Headlight was off, LEDs were on, music was BT streaming (Bitter Sweet Symphony), battery about 60% speed about 10 mph.  Rider weight 220 pounds.  Smooth level blacktop.

One other clue or perhaps bug (e.g. maybe it is separate), the Average speed is higher than the max speed for the ride (iOS - current version of King Song App).  I was doing sprints prior to the problem, and can confirm that 27+ seems right.

Also seems like a good time to point the King Song App for iOS still hasn't been updated to show the correct power levels and voltage.  Likewise the Bluetooth clipping issues of the first .25 second has not been addressed either.  

 

IMG_3968.jpg

IMG_3969.jpg

Is 906 test firmware ?

Share this post


Link to post
Share on other sites
47 minutes ago, Mike Paolini said:

So I'm sad to report that on todays ride, using 906 firmware, and playing music I encountered the tilt forward, followed by tilt back problem at low speed.

The tilt forward was subtle and an first I thought I was imagining it, then it transitioned about about 5 seconds into a 15 degree tilt back that lasted a good 10 seconds, while I slowed to see what was going on and dismounted. It remained tilted back while I was dismounted for a good 5 seconds before returning to normal.

Headlight was off, LEDs were on, music was BT streaming (Bitter Sweet Symphony), battery about 60% speed about 10 mph.  Rider weight 220 pounds.  Smooth level blacktop.

One other clue or perhaps bug (e.g. maybe it is separate), the Average speed is higher than the max speed for the ride (iOS - current version of King Song App).  I was doing sprints prior to the problem, and can confirm that 27+ seems right.

Also seems like a good time to point the King Song App for iOS still hasn't been updated to show the correct power levels and voltage.  Likewise the Bluetooth clipping issues of the first .25 second has not been addressed either.  

 

IMG_3968.jpg

IMG_3969.jpg

Have other people reported similar behavior? Or is this only a problem with your hardware. My Z10, and others Z10's does this, but most people don't see it. So in the case of the Z10, it's a hardware issue not firmware.

Share this post


Link to post
Share on other sites
43 minutes ago, Adel said:

Is 906 test firmware ?

In his first sentence, @Mike Paolini states that it's the 906 firmware.

Share this post


Link to post
Share on other sites
24 minutes ago, Marty Backe said:

In his first sentence, @Mike Paolini states that it's the 906 firmware.

Correct, also shows in the device information screen shot as 906 (I'm beta testing for the post 1.06 version).

Share this post


Link to post
Share on other sites
1 hour ago, Marty Backe said:

Have other people reported similar behavior? Or is this only a problem with your hardware. My Z10, and others Z10's does this, but most people don't see it. So in the case of the Z10, it's a hardware issue not firmware.

It's problem on my hardware too. I swapped out my controller board to try to fix it, but that board died when I tried to update it to v1.06, so I don't know if it's any better.

Edited by Jon Stern

Share this post


Link to post
Share on other sites

One of my local riders is having similar problem: random tilt while BT streaming. (v1.06)

He's waiting for his 2nd control board replacement.

I just sold my MSX for 2nd 16X.... keep my fingers crossed :cry2:

Share this post


Link to post
Share on other sites
45 minutes ago, Hibiki Mr.H said:

One of my local riders is having similar problem: random tilt while BT streaming. (v1.06)

He's waiting for his 2nd control board replacement.

I just sold my MSX for 2nd 16X.... keep my fingers crossed :cry2:

Interesting. Why not keep the MSX for variety instead of having two identical wheels?

Share this post


Link to post
Share on other sites
3 hours ago, Mike Paolini said:

So I'm sad to report that on todays ride, using 906 firmware, and playing music I encountered the tilt forward, followed by tilt back problem at low speed.

The tilt forward was subtle and an first I thought I was imagining it, then it transitioned about about 5 seconds into a 15 degree tilt back that lasted a good 10 seconds, while I slowed to see what was going on and dismounted. It remained tilted back while I was dismounted for a good 5 seconds before returning to normal.

Headlight was off, LEDs were on, music was BT streaming (Bitter Sweet Symphony), battery about 60% speed about 10 mph.  Rider weight 220 pounds.  Smooth level blacktop.
 

 

Mike did KS state what the difference between 1.06 and the 906 test firmware you are using. My understanding was that the only change was going to be for the throttling speed, did they tell you otherwise ? So are you saying the random tiltback issue was still in 1.06 and still not fixed in 906 or is this new issue introduced by 906. Thanks.

Edited by Adel

Share this post


Link to post
Share on other sites
Just now, Marty Backe said:

Interesting. Why not keep the MSX for variety instead of having two identical wheels?

Very good question. MSX is the most reliable wheel i ever had. I originally bought my first 16X for my wife, so when we go out on the weekends she'll take 16X and i take MSX.

But now we both want to ride the 16X. :laughbounce2:

And the way we use our wheels involves a lot of transit between trains and EUC. MSX's trolley isn't very practical in crowd and 16X also takes significantly less space. (still very sad to let go my MSX) :cry2:

I would love to get a 16X"L" for myself so I don't have two identical wheels, but it doesn't seem like it has enough shell space to have a bigger battery version.....Or should i wait? Enlighten me, plz

Share this post


Link to post
Share on other sites
1 minute ago, Harvey Pooka said:

Pretty specific data on what happened. To be thorough, you need to test with other types of music . . . rap, country, classical, etc. :)

Actually, you were on point.
My fellow local rider claims the random tilt happens when playing at MAX volume with some BASS. (for some reason, i don't wanna try):roflmao:

Share this post


Link to post
Share on other sites

I cannot wait for the 1.07 throttling fix. It was a long ride home earlier hearing “Please slow down” over and over. 

Anyone know a timeline for release? 

Share this post


Link to post
Share on other sites
57 minutes ago, Hibiki Mr.H said:

Very good question. MSX is the most reliable wheel i ever had. I originally bought my first 16X for my wife, so when we go out on the weekends she'll take 16X and i take MSX.

But now we both want to ride the 16X. :laughbounce2:

And the way we use our wheels involves a lot of transit between trains and EUC. MSX's trolley isn't very practical in crowd and 16X also takes significantly less space. (still very sad to let go my MSX) :cry2:

I would love to get a 16X"L" for myself so I don't have two identical wheels, but it doesn't seem like it has enough shell space to have a bigger battery version.....Or should i wait? Enlighten me, plz

Oh. The missing piece of information was that you have two 16X's for two people :) Now it makes sense.

No, in my opinion you won't see a higher capacity 16X. KingSong has not made a wheel with more than 1600wh battery capacity.

Share this post


Link to post
Share on other sites
4 hours ago, Adel said:

Is 906 test firmware ?

 

4 hours ago, Mike Paolini said:

One other clue or perhaps bug (e.g. maybe it is separate), the Average speed is higher than the max speed for the ride (iOS - current version of King Song App).  I was doing sprints prior to the problem, and can confirm that 27+ seems right.
 

I can't help but wonder if you're on to something there.  You're not the first person to mention that avg > max math issue. Several have also mentioned getting dumped and hearing "please decelerate" after it is too late, and that the throttling which  is supposed to be proportional to demand doesn't seem to quite be that way in reality.

One can just imagine a situation where they are using the wrong variable(s) for some key calculations (say the average instead of max or vice versa) and the extra conservative throttling was put in place to add safety until the source of the error is discovered. Mistakes such as this are easy to make in code and sometimes hard to find.

Share this post


Link to post
Share on other sites
2 hours ago, Hibiki Mr.H said:

Actually, you were on point.
My fellow local rider claims the random tilt happens when playing at MAX volume with some BASS. (for some reason, i don't wanna try):roflmao:

Ever since I got the wheel pre V1.05 and had to do that BT update thingy, I was never at ease playing music whilst wheeling.  

I dunno why but when I’m wheeling and thinking of playing music over BT, I have this weird impending feeling that something bad is going to happen. 

Not exactly the most logical or scientific way of pin-pointing the problem but I’d like to trust my gut at the moment until the firmware is sorted out. 

Share this post


Link to post
Share on other sites
3 hours ago, Adel said:

Mike did KS state what the difference between 1.06 and the 906 test firmware you are using. My understanding was that the only change was going to be for the throttling speed, did they tell you otherwise ? So are you saying the random tiltback issue was still in 1.06 and still not fixed in 906 or is this new issue introduced by 906. Thanks.

I've asked kingsong on every email lol if they could provide the differences, all they told me was throttling started at 70v instead of 74v the rest I'm trying to find out by myself which makes it harder because I'm unknown to when tiltback kicks in ,, I've sent several emails with information and its limited response and say it will be passed on to engineers. They did say they wouldn't do throttling to start at 25% battery though

2 hours ago, prasket said:

I cannot wait for the 1.07 throttling fix. It was a long ride home earlier hearing “Please slow down” over and over. 

Anyone know a timeline for release? 

6 hours ago, Mike Paolini said:

So I'm sad to report that on todays ride, using 906 firmware, and playing music I encountered the tilt forward, followed by tilt back problem at low speed.

Did you ever do the Bluetooth update by usb?..... I've not played that much music while  riding  so i can't comment

Edited by stephen

Share this post


Link to post
Share on other sites

Got this from kingsong after asking them to reduce throttling to 68v throttling loaded , so working with the speeds we have on xt 9.06 it's not a bad compromise from my Tests so far and want to keep it safe still . More testing after my holiday .. But as in my last video 30 miles at full speed isn't too bad and still 47% battery left and still getting 25mph then 18 mph below 30% battery,

If your under 90kg and still on 1.05 it's upto you to update, but i wouldn't update untill you see what's in next update👍

 

Screenshot-20190912-094817-com-google-an

Share this post


Link to post
Share on other sites

 

Quote

One can just imagine a situation where they are using the wrong variable(s) for some key calculations (say the average instead of max or vice versa) and the extra conservative throttling was put in place to add safety until the source of the error is discovered. Mistakes such as this are easy to make in code and sometimes hard to find.

In my understanding the average speed per trip is calculated by the app, not the wheel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...