Jump to content
tscottn

18 XL BT and Sensor Issue..? Maybe?

Recommended Posts

Out riding my 18xl almost everyday this week around my neighborhood trying to unlock the full potential of the machine.    Today, for some reason the app would not stay connected.  When I would try to connect,  it would take a very long time to find the device.  After it found it , It would disconnect within a few seconds.  Couldent keep it connected at all.  Then I went home, rebooted my phone and the wheel and connected the app.  It stayed connected for a little while, and showed me this error regarding the sensor.  Turned the wheel off and on again and connected the app and the error was gone.   then it disconnected again for some reason.. not sure whats up,  since today is thew first time I have had any real issue with the app staying connected while riding.  Im wondering if something in the main board is faulty?  BTW, The wheel itself seems fine otherwise..  

 

also, is it normal for the app to say " Illegal Equipment" on the main page?  I know the KS app is not the best but this is the fist time I have had any issues staying connected to the wheel.  

 

Thanks in advance for any help.. 

 

IMG_5290.thumb.PNG.73220f84c9c4dc45a4f085599c3a628d.PNG 

 

 

IMG_5287.PNG

IMG_5289.PNG

Edited by tscottn

Share this post


Link to post
Share on other sites

I'm having some issue...cannot connect to wheel with king song app, or wheelog.  Both worked fine yesterday,  no connection at all today with both.

Multiple tries..

Share this post


Link to post
Share on other sites

I have had a similar notification on my 18 XL "Pressure Sensor B malfunction." I have never been able to get my calibration for the trolly handle killswitch to work and assumed it was because of that. Don't worry about the "illegal device" nonsense though. I think everyone is seeing that. 

Share this post


Link to post
Share on other sites

The "illegal device" bit is because the App doesn't recognise the wheel model. The new version (apparently out in a month or so) will resolve that.

Share this post


Link to post
Share on other sites
On 12/17/2018 at 3:11 PM, D3m0nzz said:

I have had a similar notification on my 18 XL "Pressure Sensor B malfunction." I have never been able to get my calibration for the trolly handle killswitch to work and assumed it was because of that. Don't worry about the "illegal device" nonsense though. I think everyone is seeing that. 

Yeah. What @The Fat Unicyclist said. I get the same message for my XL. It's no big deal. Just wait for the app upgrade and enjoy the ride in the meantime ;)👍.

Share this post


Link to post
Share on other sites

THIS JUST IN...

The new Android version of the King Song App is now available (I can't comment on the iOS version, as I am not Appleiterate) and it now recognises the new 1554 Wh 18L devices.

Download the Android version from the King Song website - https://www.kingsong.com/list-30.html  

If you have problems from there, I have also made it available here - https://www.roll.nz/content/22-apps

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 12/20/2018 at 1:51 PM, The Fat Unicyclist said:

THIS JUST IN...

The new Android version of the King Song App is now available (I can't comment on the iOS version, as I am not Appleiterate) and it now recognises the new 1554 Wh 18L devices.

Download the Android version from the King Song website - https://www.kingsong.com/list-30.html  

If you have problems from there, I have also made it available here - https://www.roll.nz/content/22-apps

1

Thanks for this!  My KS18 XL arrived today and I've spent the past few hours messing around with it.  After wrestling with the iOS app for quite a while, I switched to the Android app (thanks to your links) and it worked like a charm.  I tried to use the iOS app to change the speed and alarm settings, but never could get it to save my changes.  It just kept reverting to the Kingsong factory defaults.  In the process of failing to do what I wanted, it also generated sensor errors similar to what others were reporting upthread.  Argh!  The Android app made all those problems go away.  

  • Like 1

Share this post


Link to post
Share on other sites

@tscottn do you still have an issue connecting while riding outdoors with it being able to connect when stationary indoors? I have this exact same issue with my ks18xl.

Share this post


Link to post
Share on other sites
8 hours ago, Tangalang said:

@tscottn do you still have an issue connecting while riding outdoors with it being able to connect when stationary indoors? I have this exact same issue with my ks18xl.

yes  never was fixed.. still the same issue..  

Share this post


Link to post
Share on other sites

 

35 minutes ago, tscottn said:

yes  never was fixed.. still the same issue..  

A friend and I got XL's a week ago. He called me last night and said his wheel was doing the same thing. He was using DarknessBot on an iPhone 6.   I have not had the problem. Same phone  same app. He said it would constantly connect and disconnect. 

Edit : I have a iPhone 7 and my wife has an iPhone XR no problems ......yet.

Edited by RockyTop

Share this post


Link to post
Share on other sites
15 minutes ago, RockyTop said:

 

A friend and I got XL's a week ago. He called me last night and said his wheel was doing the same thing. He was using DarknessBot on an Ipone 6.   I have not had the problem. Same app same phone. He said it would constantly connect and disconnect. 

at first I thought it may be my phone, but my BT connects to all my other devices no problem.  I am guessing that the BT in the wheel is just faulty on some machines.  Maybe a firmware issue.. idk

Share this post


Link to post
Share on other sites
1 minute ago, tscottn said:

at first I thought it may be my phone, but my BT connects to all my other devices no problem.  I am guessing that the BT in the wheel is just faulty on some machines.  Maybe a firmware issue.. idk

I just realized I upgraded to the iPhone 7. My friend has the 6. Mine works fine so far. I will have to keep an eye on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×