Jump to content

S1 will not charge


tscottn
 Share

Recommended Posts

Hey all. Just took my niece for a 10 plus mile excursion. She rode the S1 and i rode the V8.  By the time we got back to the house the S1 had about 12% battery left and wouldn’t go over 5mph.  As soon as we got home i connected the charger.  the charger stays green  will not charge.    I took the covers off and tried disconnecting and reconnecting the batteries and same outcome.  At this point the charger stays green and won’t charge the wheel.  I am wondering if we ran the batteries too low?  Thanks for any suggestions.  

Link to comment
Share on other sites

1 hour ago, tscottn said:

Thanks..  i guess it was the battery temp cause it started to charge now.. thanks for the advice. 

Your welcome.. that's good to hear that it's charging now.  I have an S1 but have never tried charging it right after a ride.  Seems ninebot has some good protection for the batteries nowadays.

Edited by steve454
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...