Jump to content
HarpMudd

Weird rubber band popping out of my G3

Recommended Posts

Tonight I noticed this thick white rubber band popping out of the casing from underneath my G3’s handle. Maybe it came out during a recent light wreck. For those who have done their own repairs, what is the purpose of this? Is it a seal of some sort? Is it an involved process opening your wheel up and putting it back in place? My wheel appears to be functioning fine since I’ve noticed this. Thanks!

852EEE77-7203-47E1-ABCB-75157B705FDA.jpeg

  • Upvote 1

Share this post


Link to post
Share on other sites

I've had the issue of the rubber charge port cover coming out of it's hole.  If anyone has advice on how to get the bloody thing back in the housing, please let me know.  I've just about given up on it.  

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Hunka Hunka Burning Love said:

This video never gets old.  :w00t2:  I think it demonstrates taking the V8 apart.  You have to watch it a few times as it’s difficult to concentrate for some reason.

Ya know, you're right! That is weird! I had to watch it a few times as well! :roflmao:

Edited by Arbolest
  • Like 1

Share this post


Link to post
Share on other sites

Thanks..That is a good video! 😳 I never saw any rubber gasket though.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Gasket?  :popcorn:  What gasket?  Oh, in that case maybe take a look see at this video instead.

 

or maybe this one:

 

Edited by Hunka Hunka Burning Love

Share this post


Link to post
Share on other sites
On 8/3/2018 at 2:51 AM, mezzanine said:

I've had the issue of the rubber charge port cover coming out of it's hole.  If anyone has advice on how to get the bloody thing back in the housing, please let me know.  I've just about given up on it.  

Happened to me also, took me about 30 minutes fooling around with it to get it fixed.  I broke a toothpick in half and used the blunt/broken end to force the knobby end of the cover back through the hole.  I think I also used needle nose pliers to help out a bit.  Can't recall exactly how I used them, it was a few weeks back.  Yes... this getting it back in was a pain.

Share this post


Link to post
Share on other sites
20 hours ago, JBinBalt said:

Happened to me also, took me about 30 minutes fooling around with it to get it fixed.  I broke a toothpick in half and used the blunt/broken end to force the knobby end of the cover back through the hole.  I think I also used needle nose pliers to help out a bit.  Can't recall exactly how I used them, it was a few weeks back.  Yes... this getting it back in was a pain.

I opened up my wheel and when trying to put the gasket back in, I broke it, so I ended up ripping it out entirely.  I ended up just putting a few strips of electrical tape over-top of where the gasket used to be.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×