Jump to content

!!! Firmware or hardware problems with KS18L, wheels locking up while trolleying


Recommended Posts

  • esaj changed the title to !!! Firmware problems with KS18L, wheels dying
  • esaj pinned this topic
  • Replies 802
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

We've had (at least) seven reports of KS18L locking up (and in fact, heating up after locking) while the wheel has been trolleyed around. If this happens to you, as soon as possible, open the wheel an

Ok, latest News in "Lock issue"..... KS China has received the board of a French Customer which had the Problem....and found the issue on that specific board! It is a specific small Crystal

FYI, I just had lock up #2 while trollying. I have informed the seller. Disabling lift does not appear to fix.  

Posted Images

Updated some details in the first post, let me know of any further info that comes along or if there are errors in the post.

Edited by esaj
Link to post
Share on other sites
45 minutes ago, esaj said:

Updated some details in the first post, let me know of any further info that comes along or if there are errors in the post.

You do really an amazing job. Thanks. Also just as some extra info. I hate blinking leds on my vehicule so when it died the leds was off... It most likely a hardware design defect or maybe a mosfet defect... Anyway i asked Tina for some extra info...

Link to post
Share on other sites
On 7/5/2018 at 4:50 PM, esaj said:

We've had a couple of reports of KS18L dying (and in fact, heating up after dying) apparently while the wheel has been trolleyed around. The details so far aren't very precise, and it's unclear whether the new firmware version (1.07?) actually fixes this. I'll  update this post as we get more details.

@tinawong of King Song (the forum factory representative) has posted that they're aware of the issue and that their engineering team has worked some solution, along with (apparently) regression tests. But then again, @TomOnWheels posted that the two cases have been on different firmwares (1.06 and 1.07), so not sure if the fix is out yet. Be careful out there, if you can help it, maybe wait until they've officially called the "all clear" and released new firmware.

No exact reason for this is known (the "LED rings" have been mentioned having some issues, not sure if that's the cause), but apparently the wheel fries mosfets ("locked motor"), yet the short may cause a high current to continue running through the mainboard and motor, heating up the mainboard parts and phase wires. So likely atleast one from BOTH high- and low-side fets are gone at that point (current running through the high-side fet, then through two motor phases, and to ground through a low-side fet on another half-bridge, otherwise the motor cables shouldn't get hot?).

Notes:

-May cause mainboard and motor damage, and if battery cells heat up too much, there's a possible danger of fire

-If it is in fact the LEDs, first aid might be turning off the side LEDs (I don't have a KS18L, but I think they can be turned off from the app) Tom clarified below that in his case the side-LEDs were already off, so we're back to square one. Personal suggestion is that don't ride your wheel if you can until this is solved.

-Firmware update may not work with iOS? Borrow an Android phone from somewhere.

 

Related topics:

 

I am just considering the purchase of a King Song 18L, but I am wondering what options I have in the U.S. if my EUC needs repair? Even warranty work? Does it need to be shipped back to the manufacturer? Thanks!

 

Link to post
Share on other sites
4 hours ago, US69 said:

@esaj

The frying boards on the 18L where related to a problem with the LED lightring...a firmware problem, not app specified!

In seldom situation a Lightring pattern might bring the board into a loop...get stuck, overheating and frying because of this! So yes, even if the Leds where not working...this IS the problem...KS was able to reproduce the fault at their factory!

3 days after this issue was reported KS brought out FW 1.07 which fixed the issue!!!

Yes, but as @TomOnWheels stated above, the second case occurred with FW 1.07. Separate issue or the fix doesn't cover all the cases?

Link to post
Share on other sites
54 minutes ago, spmartin said:

I am just considering the purchase of a King Song 18L, but I am wondering what options I have in the U.S. if my EUC needs repair? Even warranty work? Does it need to be shipped back to the manufacturer? Thanks!

If you buy from an US reseller, such as eWheels (Jason), they'll take care of warranty repairs, if such are needed at some point. 

Link to post
Share on other sites
1 hour ago, phatmike said:

I hope  that this is a not problem related to the first batch of KS 18l. Some defective components or something like that

Well, this is not confirmed, but what I hear around for different KS people is that this is something that has to do with first batch and components providers... But this is just a rumour ! So please do not take it as an reality ! We already know that a extra temperature sensor was added in the 1st batch... There are and probably will be small changes in hardware...

Link to post
Share on other sites
3 hours ago, esaj said:

Yes, but as @TomOnWheels stated above, the second case occurred with FW 1.07. Separate issue or the fix doesn't cover all the cases?

as i understand it, kingsong was totally able to reproduce the fault and has fixed it.

WHEN there was an board fried with 1.07, at first i would call that an isolated case and not depending on the general problem.

When there are still amd more cases coming up about frying boards, even under 1.07, the exact scenarios need to be collected and reported to KS. 

Rumours dont help a lot, facts are needed. About an added temperature sensor: This has nothing todo with the faults...

The KS18L is on of the first wheels that has added an extra temperature sensor which is reading the motor temperature inside the wh eell'mmw An info which can be seen under More-detailed Parameters....

Link to post
Share on other sites

Updated the first post a bit again. Hopefully these are two isolated cases (one with the earlier firmware problem, one with maybe hardware issue in the 1st batch?). Still keeping this pinned so people are at least aware of the possibility.

Link to post
Share on other sites
  • esaj changed the title to !!! Firmware or hardware problems with KS18L, wheels locking up while trolleying
  • Chriull unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...