Jump to content
GMOne

Speed2Increase and how to change max Ninebot speed

Recommended Posts

Hi.. ive to try update my ninebot one s2 with st link v2 and your software.. but i dont know, after ive finished upgrading... my device dont want to turn on.. 

Maybe i ve failed update fw... any suggest to rollback firmware? 

Now i cant connect my device with st link program

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, Adi Sugiharto said:

Hi.. ive to try update my ninebot one s2 with st link v2 and your software.. but i dont know, after ive finished upgrading... my device dont want to turn on.. 

Maybe i ve failed update fw... any suggest to rollback firmware? 

Now i cant connect my device with st link program

 

2018-11-27 19.13.20.jpg

2018-11-27 19.13.00.jpg

2018-11-27 19.12.31.jpg

Share this post


Link to post
Share on other sites

Sadly you followed a kind of unofficial procedure with ST-Link V2, that I never had written, and I never had suggested to use. I don't understand saving few bucks only... A Chinese version of the interface costs 10$.

You previously read your firmware so you can send it to me and I can check it. In the meanwhile I suggest to you to buy the suggested interface.

GMOne

Share this post


Link to post
Share on other sites
17 hours ago, Adi Sugiharto said:

Now i cant connect my device with st link program

If you don’t do it yourself, I can help with the recovery.

Hint. Use under reset.

  • Upvote 1

Share this post


Link to post
Share on other sites

Its ok bro @GMOne n @MRN76.. i got it.

I repeat procedur from begin, fix soldering and test with multimeter.. i got FW 1.0.8 searching from google and flash it to mainboard with ST-Link V2.

Hardwork for 3 days and Ive successfull upgrade my ninebot one s2 l, it has 30km/h now.

Thanks GMOne for patch tool for S2

 

2018-11-28 13.56.53.png

  • Upvote 2

Share this post


Link to post
Share on other sites

FYI ( @GMOne )

The decision was taken that firmware mods are not allowed in this forum.

The forum rules were just changed to reflect this:





So this topic will be removed soon.

Sorry for any inconvinience caused.

Edited by Chriull

Share this post


Link to post
Share on other sites
18 hours ago, Chriull said:

FYI ( @GMOne )

The decision was taken that firmware mods are not allowed in this forum.

The forum rules were just changed to reflect this:





So this topic will be removed soon.

Sorry for any inconvinience caused.

No problem sir! 😉

Even though this topic has become quite mixed about arguments, I understand your policies and I agree with you.

See you in other topics! 😜

  • Like 2

Share this post


Link to post
Share on other sites
On 11/29/2018 at 12:42 PM, GMOne said:

No problem sir! 😉

Even though this topic has become quite mixed about arguments, I understand your policies and I agree with you.

See you in other topics! 😜

Thanks for your nice reply!

We rediscussed our decision and changed our mind, so that it will be enough to "protect the forum" by putting this topic into the Mods & DIY section with the disclaimer here "nor are we liable for the safety of whatever is being posted."

So there will be no removal or other actions for this or similar topics.

If you like, you could support as a bit in our "liability/forum protection" effort by maybe writing a small disclaimer once introducing some mods, too. (something like firmware is altered in a way not intended by the manudacturer and especially alters safety features implemented by the manufacturer, this is no recommendation, etc...)

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites

I've flashed the new firmware modified using Speed2Increase and it works! Many thanks @GMOne

My question is only one: it seems that @900W consumption (~26-27kmh), my S2 'bips' and start a little 'tilt backs': it's that behavior correct? I'm ~97kg, and I've read that the peak power of S2 it's about 1200W, it's safe to accelerate even after the 'power' warning?

Share this post


Link to post
Share on other sites
7 hours ago, gigiValliConservigi said:

I've flashed the new firmware modified using Speed2Increase and it works! Many thanks @GMOne

My question is only one: it seems that @900W consumption (~26-27kmh), my S2 'bips' and start a little 'tilt backs': it's that behavior correct? I'm ~97kg, and I've read that the peak power of S2 it's about 1200W, it's safe to accelerate even after the 'power' warning?

It's normal. There are many variables about current limits, not only speed. Your weight is approx like mine, and the behaviour is quite similar. Full charged battery, no slope, no wind, a light food and you will reach the maximum speed you can. 😜

Just out of curiosity I tried to ignore beeps for a little bit (not minutes but 10 seconds and even more) and I didn't meet any problem. But only IMHO... Do not do it. A friend of mine completely ignored it... He told me he felt the unicycle giving him a quite irregular speed, and after quite a lot it gave him a cut-off.

Have a nice ride!

 

GMOne

 

Do not forget a little donation... 😜

  • Like 1

Share this post


Link to post
Share on other sites
hi Guys
I use ST-Link V2 he has only 4 cables soldered to the points
I did everything like ........... described. I do not know what to do with the RST cable
as soon as I open the program it shows the following ............
please help me
Edited by Bastjan Knieps

Share this post


Link to post
Share on other sites

It is not clear what the program shows. Show screenshots of the problem.
I connected several times without the RESET wire. Connection happened from the first time. To do this, bring STLink to the nest, but not insert. Click in the program icon CONNECT and immediately insert STlink.

Edited by IhKa

Share this post


Link to post
Share on other sites

Check, you have all correctly connected and soldered. If, for some reason, you do not connect without the RESET, you need to solder the RESET wire to the leg 18 inside the STLink. To disassemble it, you need to pull the case in different directions.

RESET.thumb.png.51d7b12fe50b38843383409b948f6d42.png

Share this post


Link to post
Share on other sites
10 hours ago, Bastjan Knieps said:

The program keeps showing that

20181220_232830-min.jpg

Set in the settings mode - connect under reset and  hardware reset.

Connect the programmer with the VCC pin disconnected.

Click connect and immediately insert the VCC pin. From the first time it may not work, but from 3-5 times you will succeed.

 

2018-12-21_120834.png

Share this post


Link to post
Share on other sites
32 minutes ago, Bastjan Knieps said:

Please look at my photos

Upload space on this forum is very limited - it is better to use some upload service like imgur and just put a link here. Some of these sites, like imgur allow direct links so pictures can be embedded here.

Share this post


Link to post
Share on other sites

Hey @GMOne ,

We were able to finally flash my friend's S2 and it has the new speed!! It took such a long time, and I almost lost hope, but with your help and some resiliency, we were able to do it!

I've sent you some coffee money as a token of our appreciation!

Also, I have a couple of tips, for those that may run into any similar complications in the future. With the Chinese J-Link V8 version that we got from AliExpress, you did NOT have to do any modifications. All the pins were already set to 3.3V, except for the 5V supply, but we were able to just use the Vtref pin which was already set to 3.3V. Make sure to use a meter to check the voltage to see what your J-Link is doing. If the voltage is correct, you can just connect the correct emulator pins to the proper connections on through soldering and that should work. 

Also, please use this https://j-link-arm.software.informer.com/4.2/  software to get the proper version of J-Link to use with your Chinese J-Link clone. This will prevent you from bricking your emulator like we did the first time. We had to buy 2 J-Link emulators from China which is why it took us so long.

Finally, the last mistake we made, was not carefully reading the settings for the Segger J-Flash ARM 4.2 setup. Make sure your project settings match the screenshot that GMOne provided EXACTLY. You will have to modify the MCU and a few other default project settings to make it match, otherwise the emulator will not be able to connect to the board. 

Hope this helps others in the future, and good luck!

  • Upvote 1

Share this post


Link to post
Share on other sites

Sebastianknieps90

MRN76 gave you the right recommendations for setting up without RESET. Do not connect the RESET that is on the ST-Link connector. After clicking on the CONNECT icon, there is a period of time to get into, a little earlier, a little later.

Share this post


Link to post
Share on other sites

 

 

Hello people tried again today like MRN76 on its side describes with the program v4.20 now it shows the following

 

 

 In the test with the St link v2 does not work with the reset I'm not what I'm supposed to do there is always the same

 

20190110_201548-min.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×