Jump to content
GMOne

Speed2Increase and how to change max Ninebot speed

Recommended Posts

11 hours ago, GaperMaster said:

Ok, I do not have a multimeter, but I will borrow one from a friend. A few questions.

1) Which pin should I measure with respect to ground? The power pin (Vcc)? I am using the pdf below that you provided for reference. I will report what voltage I find after I borrow the multimeter. 

2) Also, when you say the Chinese interface is different because it has a bridge at the bottom near the connector. Are you talking about the bridge indicated in my picture (It has a red arrow pointing to it)? 

3) Notice in my final connection picture, I have removed the additional board which had the 3.3 to VTref bridge (red x in the picture). I have not done any soldering to the J-link at all. I plugged all the wires directly into the Chinese V-link as it came directly from the box. 

4) Thank you so much for all your help. 

1464150533_Howtoconnect.pdf

j-link mod updates.jpg

1) Yes the Vcc pin. I think you won't have any voltage. You have to internally bridge two pins of the connector, the first two near the red arrow, as solution;

2) Yes, but do not modify it before measuring voltage, and doing the bridge;

3) Nothing to declare ?;

4) You're welcome!

  • Like 1

Share this post


Link to post
Share on other sites

I'm curious to give this a try on my S2, actually almost wanted to buy a InMotion V8 to get the 30kph as i constantly run on the limiter on the S2 :D

So this mod just seems perfect for me :wub: BUT can anyone tell how drastically the range drops? given you stay >25kph for longer distances

Share this post


Link to post
Share on other sites
1 hour ago, rothman said:

I'm curious to give this a try on my S2, actually almost wanted to buy a InMotion V8 to get the 30kph as i constantly run on the limiter on the S2 :D

So this mod just seems perfect for me :wub: BUT can anyone tell how drastically the range drops? given you stay >25kph for longer distances

My range dropped from 32 to 27 when i almost always go to the maximum speed. So nothing drastic about me... ;-) But of course it depends on the batteries you have, and you treated well in the past... :-P

Share this post


Link to post
Share on other sites
21 hours ago, GMOne said:

1) Yes the Vcc pin. I think you won't have any voltage. You have to internally bridge two pins of the connector, the first two near the red arrow, as solution;

2) Yes, but do not modify it before measuring voltage, and doing the bridge;

3) Nothing to declare ?;

4) You're welcome!

@GMOne

I checked the voltage using my friend's multimeter from Vcc to a ground pin in the jlink and the voltage reads 3.3V. 

This should be correct right? However when we try connect to the device with JFlash it still says "Could flash devices. Failed to connect." 

Maybe since it is a different Chinese clone we should use a different version of JFlash?

Share this post


Link to post
Share on other sites
5 hours ago, GaperMaster said:

@GMOne

I checked the voltage using my friend's multimeter from Vcc to a ground pin in the jlink and the voltage reads 3.3V. 

This should be correct right? However when we try connect to the device with JFlash it still says "Could flash devices. Failed to connect." 

Maybe since it is a different Chinese clone we should use a different version of JFlash?

Please check the voltage at the chip, between Vcc and gnd soldering points...

 

Have you set the program correctly? May you take a screenshot of settings and the error?

Edited by GMOne

Share this post


Link to post
Share on other sites

Hi GMOne and thanks so much for this excellent mod!!! I was waiting for such a mod for months and nearly ready to buy a faster wheel :) 

I wanna try it as soon as possible so I'm looking for a J-link with a fast delivery option but except the genuine Segger EDU available on Farnelll for 55€ for example, all Chinese copy take weeks and weeks to deliver... do you know a better way? Else I'm gonna buy this one I can't wait any longer ;)

By the way I'm wondering what will happen when the app will want to upgrade the firmware to the next official release ? 

Etienne

Share this post


Link to post
Share on other sites
2 hours ago, E.T. said:

Hi GMOne and thanks so much for this excellent mod!!! I was waiting for such a mod for months and nearly ready to buy a faster wheel :) 

I wanna try it as soon as possible so I'm looking for a J-link with a fast delivery option but except the genuine Segger EDU available on Farnelll for 55€ for example, all Chinese copy take weeks and weeks to deliver... do you know a better way? Else I'm gonna buy this one I can't wait any longer ;)

By the way I'm wondering what will happen when the app will want to upgrade the firmware to the next official release ? 

Etienne

Hi Etienne!

Please pay attention that EDU version now cannot flash through J-Flash, it's not supported anymore. You can flash with EDU version through J-Flash Lite, a very rough interface with only few settings. Sadly I suggest you to take the Chinese version. Maybe you can buy it on AliExpress and choose fast delivery with a courier you like...

As alternative you can take a trip to Italy!

?

  • Like 1

Share this post


Link to post
Share on other sites

That's a shame if official EDU is not abble to Flash.. are you sure J Flash light won't do the job? Else i will definitively find another chinese way......

:ph34r:

Share this post


Link to post
Share on other sites
2 hours ago, who_the said:

Is it possible to extend this project to the Z10?

Probably it's my first aim now. I extended it to E, E+, C+ and other models. I only need (time) to modify the patcher. To be honest (especially about Z10 case) I need some support... ?

https://ko-fi.com/D1D0FI5A

 

 

  • Like 2

Share this post


Link to post
Share on other sites
48 minutes ago, GMOne said:

Probably it's my first aim now. I extended it to E, E+, C+ and other models. I only need (time) to modify the patcher. To be honest (especially about Z10 case) I need some support... ?

https://ko-fi.com/D1D0FI5A

 

 

Just sent you some support! Thank you!

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, who_the said:

Just sent you some support! Thank you!

Really thank you!

Share this post


Link to post
Share on other sites

@E.T.i Etienne, I'm in Alsace in france, if you are interested, you could borow my J-Link or even come in so I can help you with the flash... let me know

Edited by Krom68

Share this post


Link to post
Share on other sites

@GMOne

Hi GMOne, sorry, been really busy, but I took the screen shot of the JLINK flash error IMG_0789.thumb.JPG.d8c2c960366f88f6ec1214f5f8c1ce5e.JPG

I measured each pin on the board with respect to GND, only 1 pin is not at 3.3V, and it's the SWDIO pin, it's sitting at a VERY low voltage, i'm not sure if this is the problem or not:

IMG_0792.thumb.JPG.450b14b66249695eeac6132323dba3a4.JPG

Thanks!

Share this post


Link to post
Share on other sites
On 10/1/2018 at 9:57 AM, Krom68 said:

@E.T.i Etienne, I'm in Alsace in france, if you are interested, you could borow my J-Link or even come in so I can help you with the flash... let me know

Hi Krom68,  That's very kind of you ! However I live in charente maritime so it would be quite far driving :roflmao:

Anyway I ordered a chinese copy and I hope it will arrive soon...

Thanks a lot for your kindness!!

 

I now just have to sharpen my soldering iron whose end is a bit fat..

>> So how is your new wheel with this promising mod? Is the new high speed sufficient to avoid buying another wheel ? 

@GMOne. > can not wait to test your mod a offer you a hot coffee :w00t2:

 

Share this post


Link to post
Share on other sites
19 hours ago, GaperMaster said:

@GMOne

Hi GMOne, sorry, been really busy, but I took the screen shot of the JLINK flash error IMG_0789.thumb.JPG.d8c2c960366f88f6ec1214f5f8c1ce5e.JPG

I measured each pin on the board with respect to GND, only 1 pin is not at 3.3V, and it's the SWDIO pin, it's sitting at a VERY low voltage, i'm not sure if this is the problem or not:

IMG_0792.thumb.JPG.450b14b66249695eeac6132323dba3a4.JPG

Thanks!

Noticing few things:

1) you upgraded your Chinese interface, so you're using an old j-Flash with a newer firmware so they are probably incompatible;

To solve it

https://gronlier.fr/blog/2015/07/unbrick-and-update-an-j-link-v8-clone/

Please read and follow it carefully. When you will have downgraded your interface please update it with 4.20a version, do not use a newer version.

2) you didn't set your program for right CPU, please read my guide carefully too ?

3) multimeter cannot measure signals. If Vcc is 3.3V is ok, the other signals cannot be measured ( you would read a kind of average value).

Be patient, take your time, don't worry!

GMOne

 

Share this post


Link to post
Share on other sites
On 10/2/2018 at 6:26 PM, E.T. said:

Hi Krom68,  That's very kind of you ! However I live in charente maritime so it would be quite far driving :roflmao:

Anyway I ordered a chinese copy and I hope it will arrive soon...

Thanks a lot for your kindness!!

 

I now just have to sharpen my soldering iron whose end is a bit fat..

>> So how is your new wheel with this promising mod? Is the new high speed sufficient to avoid buying another wheel ? 

Too bad, and the chineese J-link is so cheap that it not even cover the shipping cost should I have sent you mine...

Concerning the Moded S2... I have to say that it is fantastic.

No drawback at all, just goes faster and now you can ride relaxes at 25kph without constant tiltback / beeping and you have this little extra boost should you need to pass a groupe of bycicles.

However My Z10 just arrived a week after I flashed my S2 and I have to admit that the S2 now look like a little toy compared to the Z :p

On 10/2/2018 at 6:26 PM, E.T. said:

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi GMOne,

I'm facing some troubles with my alibaba seller.. I think I will never receive my j-link copy. As I really want to achieve your mod I will try to do it with a friend who works in embeded electronic development. The problem we have now is that his j-link are too old to support swd protocol and the only equivalent he has is an official ulink2 wich involve using uvision software but it has no reliable way to dump the original firmware... The imported .hex file we got is not each time the same.. So in order to make sure that we do not burn everything using a bad firmware could you send me an exemple to compare?

Thx a lot for your work !

Share this post


Link to post
Share on other sites
On 10/9/2018 at 7:47 PM, E.T. said:

Hi GMOne,

I'm facing some troubles with my alibaba seller.. I think I will never receive my j-link copy. As I really want to achieve your mod I will try to do it with a friend who works in embeded electronic development. The problem we have now is that his j-link are too old to support swd protocol and the only equivalent he has is an official ulink2 wich involve using uvision software but it has no reliable way to dump the original firmware... The imported .hex file we got is not each time the same.. So in order to make sure that we do not burn everything using a bad firmware could you send me an exemple to compare?

Thx a lot for your work !

Of course I have no problems to send you a copy of whatever firmware you like, but you cannot trust to an interface which always dumps a different file. And you cannot use it to write anything to mC.

I can help you if you send to me some dumps, so I can check what's happened.

You can find my mail into my program.

 

GMOne

Share this post


Link to post
Share on other sites

Hi GMOne !

I had to be patient, I finally received my chinese J-link copy yesterday and did the mod directly! :w00t2:

As soon as my s2 was ready I checked with the ninebot app and the limit was already set at 30km/h ! 

I tryed it at 2:00 AM with 50% battery and 10% personal energy but I couldn't reach 30km/h, I was suddenly stopped by rapid beeps around 27-28km/h... :shock2: Was a little bit scared as I never experimented such beeps and feeling through the pedals (no tilt back and no single beep warning) and decided to go sleeping and charge s2 batteries...

Today is another day, I just come back from 12km trip with full charged batteries and everything is excellent!!! I could reach the 30km/h max speed according to ninebot app at the early beginning!!!:clap3:

The only strange thing is that despite of my quite light weight (<60kg), I was able to reach 30km/h only during the first minutes riding then I faced rapidly power rapid beeps keeping me below 29 then 28 and around 27.5 with 60% battery left.. Ninebot app still displaying 30km/h limit.. My cells may be tired with 2200km traveled ? quickly ninebot power security overtake the app limit to be safe.. > has someone experimented the same effect ? I read someone weighing 100 kg explaining quite the same but with nearly half weight that's surprising...

Anyway you did an excellent job GMOne!!!!!!!!!!!!! and I of course offered you some french coffee!!!!! :cheers:

I can now ride my S2 constantly around 26 km/h with an significant boost margin !!!! YEAAAAHH!

  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, E.T. said:

Hi GMOne !

I had to be patient, I finally received my chinese J-link copy yesterday and did the mod directly! :w00t2:

As soon as my s2 was ready I checked with the ninebot app and the limit was already set at 30km/h ! 

I tryed it at 2:00 AM with 50% battery and 10% personal energy but I couldn't reach 30km/h, I was suddenly stopped by rapid beeps around 27-28km/h... :shock2: Was a little bit scared as I never experimented such beeps and feeling through the pedals (no tilt back and no single beep warning) and decided to go sleeping and charge s2 batteries...

Today is another day, I just come back from 12km trip with full charged batteries and everything is excellent!!! I could reach the 30km/h max speed according to ninebot app at the early beginning!!!:clap3:

The only strange thing is that despite of my quite light weight (<60kg), I was able to reach 30km/h only during the first minutes riding then I faced rapidly power rapid beeps keeping me below 29 then 28 and around 27.5 with 60% battery left.. Ninebot app still displaying 30km/h limit.. My cells may be tired with 2200km traveled ? quickly ninebot power security overtake the app limit to be safe.. > has someone experimented the same effect ? I read someone weighing 100 kg explaining quite the same but with nearly half weight that's surprising...

Anyway you did an excellent job GMOne!!!!!!!!!!!!! and I of course offered you some french coffee!!!!! :cheers:

I can now ride my S2 constantly around 26 km/h with an significant boost margin !!!! YEAAAAHH!

Hi! First of all I want to thank you, I received your kind and grateful coffee! Thanks a lot, I really believe in an altruistic and thankful world and relationships.

S2 is really a very good device, far better than the E+. Better quality and better software. A frequent beep doesn't mean you're going to fall off the unicycle, it means that you reached the limit, not the speed limit. Some parameters are checked: current limit, temperature limit for example. The software behaves well, and you don't need to worry too much. You will fall only if despite the frequent beeps you will try to accelerate even more for many many seconds.

I never fell off from the unicycle, and the only case I know is about a friend of mine who was listening to the music and it wanted to go always to the maximum limit. Even if it felt the S2 pulling it back (during the beeps).

I don't want to change any other limit, they are safe for you and your unicycle.

Enjoy yourself as much as you can, and feel free to ask whatever you want!

GMOne

Share this post


Link to post
Share on other sites

Sorry guys! We had a problem! We don't know how to reach the motherboard. Here I show you where we are! I know it can seems a stupid question but can someone help us? Thanks a lot!

IMG_20181020_235309.jpg

Share this post


Link to post
Share on other sites

If you disassembled the other side too you can quite (not completely!) pull out gently the wheel, and unscrew the four screws around the back metal side of the board. The board is behind it.

Share this post


Link to post
Share on other sites

Hi every one,

GMONE, thanks for the advices you give in this topic. i'm thinking about try this patch on my S2, to start, im gonna buy this Jlink :

https://www.ebay.fr/itm/292765356398

is it the good one ? its not the cheaper but faster than chinese shipping..

I will keep you posted about my work in the further weeks, and for sure offer you a coffee !! thanks again for your work

etienne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×