Jump to content
unehimself

Error Charging the airwheel x3

Recommended Posts

I got my airwheel x3 yesterday that I ordered from a company in China through Aliexpress. I turned it ON but it stopped, turned all the lights on and beeped. Today I figured I would give it a try to charge the battery. Connecting the charger to the unit worked good at first. Charger showed red light at first and green light when finished. Now.. When I attempted to put the airwheel ON, it went fast forward for about 2dm and then it just stopped and beeped. I turned it OFF and tried to turn it ON again, but nothing happened. I connected the charger to the airwheel once again, but this time the red light blinked and the wheel started to vibrate 1 time per second. I've been searching all over the Internet trying to find out what the problem can be. I've been thinking that the problem could be the charger and I'm thinking about ordering a new one. I have emailed the company about this problem but I have not recieved an answer yet. 

Anybody else with this problem while charging? The airwheel does not show any sign of life by the way, its completely dead. 

Share this post


Link to post
Share on other sites

When you say it went fast forward what do you mean? You're not supposed to turn them on unless they are roughly upright and in contact with the ground or some othe surface. Otherwise they spin like mad trying to find they're balance and eventually cut out.

Edited by Gimlet

Share this post


Link to post
Share on other sites

When you say it went fast forward what do you mean? You're not supposed to turn them on unless they are roughly upright and in contact with the ground or some othe surface. Otherwise they spin like mad trying to find they're balance and eventually cut out.

Like.. an "attack". However.. Now the charger is blinking red, and the wheel is having a "spasm" every other second. I was going to have charger plugged in during the night, but I'm afraid it might set on fire or something. Going to do some researching tomorrow again. 

Share this post


Link to post
Share on other sites

So you turned it on originally whilst holding it up in the air?

If so it wouldn't be able to balance itself and would have spun up to top speed whilst trying and then gone into shut down. Just the same as the lift tests we do when checking out the top speeds on wheels with apps.

It should reset itself when you turn it off and on again. If it doesn't try standing it upright on the ground and turning it on whilst it's still plugged in to the charger, that can sometimes reset some wheels.

Share this post


Link to post
Share on other sites

I did that once, just to see what would happen.

Biggest problem now is that it wont turn on at all. When charger is plugged in the LED on the charger is blinking red and the wheel just vibrates. It doesnt really show any sign of life what so ever (besides the wheel acting like a cat during its REM lol) 

Share this post


Link to post
Share on other sites

Sounds like you need to contact AliExpress and get a replacement/refund.

Share this post


Link to post
Share on other sites

Sounds like you need to contact AliExpress and get a replacement/refund.

I've been having some contact with the guy I ordered it from. Been sending pictures and a video trying to explain everything. He said he would contact me again after speaking to his boss on monday. Hopefully I will get a replacement.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...