Jump to content

KS14D Speed unlocking problems


Juggler
 Share

Recommended Posts

I am now the proud owner of a KS14D having ridden a Ninebot One E+ for 18 mths.

I have installed the old green app on my Android phone but after entering the serial number and unlock code I get the message "Failure!"

Does the serial number have to be input with or without spaces? 

The app shows an example SN. like this  E0-D1-58-19-FD-C8 but the only number I can find is on the underside of the pedals and looks like this.  KS14 D2 B 170916 B 012??

Thanks in anticipation

Link to comment
Share on other sites

@juggler : the serialnumber is the Bluetooth ?mac? address (shown by the app when scanning for the wheel)

The unlock code has to be entered without colons

 

Btw - the needed code (?serial number?) Should be given do you by the app while unlocking?

 

Link to comment
Share on other sites

1 hour ago, Chriull said:

@juggler : the serialnumber is the Bluetooth ?mac? address (shown by the app when scanning for the wheel)

The unlock code has to be entered without colons

 

Btw - the needed code (?serial number?) Should be given do you by the app while unlocking?

 

Now I know that the serial number is NOT the number on my wheel pedals ( I thought all products had their serial number printed somewhere on them) I have managed to input the correct unlock code using the bluetooth code as a serial number !!!

Unfortunately while trying to sort the problem out using an old android phone as well as my new one I have discvovered that the new phone will not connect to the device even though I have managed to connect it to my music using bluetooth!

The old phone works fine

Any ideas why the new phone won't connect to the wheel?

Link to comment
Share on other sites

20 minutes ago, Juggler said:

The old phone works fine

Any ideas why the new phone won't connect to the wheel?

Maybe the new one has no BLE, or the wrong bluetooth standard (would be strange with the newer one having less functionality)?

Could als be that your old phone was still conected and by this hindered the new phone somehow? Also as far as i remember multiple connections are possible?

Bluetooth Music and blutooth for "control" are two completely different things. Unfortionately bluetooth music is the one that works flawlesly, just the settings/controll connection makes troubles...

Edited by Chriull
Link to comment
Share on other sites

47 minutes ago, Chriull said:

Maybe the new one has no BLE, or the wrong bluetooth standard (would be strange with the newer one having less functionality)?

Please don't use TLA's

Link to comment
Share on other sites

2 hours ago, US69 said:

IOS update released....version 3.1

Android actual is 1.48

firmware update servers will open next week....

Is this information supposed to help me solve my connection problems?

Link to comment
Share on other sites

2 minutes ago, Chriull said:

Maybe, maybe not - just new app versions are out. Could change nothing for you or it'll just work with them...

I was advised by Kingsong not to use the latest app as it has bugs. They suggested using the older green one which I am using now

Link to comment
Share on other sites

19 minutes ago, Juggler said:

I was advised by Kingsong not to use the latest app as it has bugs. They suggested using the older green one which I am using now

Ah. - ok.

How "old" is this advice? I have tried the "almost very new" android apk version 1.47 and unlocking worked with my KS16S. This vetsion 1.48 mentioned by @US69 is brand new and i know nothing about... Maybe also the ios version 3.1 seems brand new...

ps.: for eventual firmware updates (as @US69 also posted) once the update servers are online again the new versions will be needed. Also i won't recommend to try new firmwares before there are at least some positive reports! (question is just, who starts to try them out... ;) ) Normally with KS there are no(t too much) troubles with firmware updates - i remember just one major prob reported here...

Edited by Chriull
Link to comment
Share on other sites

1 hour ago, Chriull said:

 

ps.: for eventual firmware updates (as @US69 also posted) once the update servers are online again the new versions will be needed. Also i won't recommend to try new firmwares before there are at least some positive reports! (question is just, who starts to try them out... ;) ) Normally with KS there are no(t too much) troubles with firmware updates - i remember just one major prob reported here...

Afaik there was "only" (and for the first time with KS Firmware) a Problem with the current 14S Firmware, as These has bricked 2 KS14S boards...(1.04 if i remember correctly)

I guess this might also be the reason for the Firmware Servers still beeing down.

Other Firmware Versions, example 18S have been a bit longer out without any Problems...in contrary:  Smoothening the ride, as some others stated...

1 hour ago, Juggler said:

Is this information supposed to help me solve my connection problems?

Yip, i had generell Connection/login Problems also....only working after trying several times.

Now the new IOS version it works like a charme :-) (Ok, one time the app crashed...but hey, it's a chinese Garage production )

 

Other than that, beside optics and user Interface,  i cant say any bad about the KS app anymore.

Testing Darkness app beta with KS Speed Setting and alarms....so i had to use the KS app very often now for checking what Darkness has done, Speed Settings, alarms, etc etc...all works!

 

Link to comment
Share on other sites

5 hours ago, Chriull said:

How "old" is this advice? I have tried the "almost very new" android apk version 1.47 and unlocking worked with my KS16S. This vetsion 1.48 mentioned by @US69 is brand new and i know nothing about... Maybe also the ios version 3.1 seems brand new...

 

This advise from King song was 4 days ago:-
 
"The easiest way is to use the stable app version ("green version"), as the new app ("white version") has some bugs that are being fixed right now."
 
Here you can download the green app:
Link to comment
Share on other sites

12 minutes ago, Juggler said:
This advise from King song was 4 days ago:-
 
"The easiest way is to use the stable app version ("green version"), as the new app ("white version") has some bugs that are being fixed right now."
 
Here you can download the green app:

yes,sure,but today the new app update was released......

Link to comment
Share on other sites

Well I've finally found out why the app wouldn't connect to my new phone !!!

I just went back to the KS website an saw this comment:-

Android / BlackBerry:

Heads up! After you downloaded and installed the app, go to your Android Settings / Apps / kingsong / Permissions, then grant permissions for Location and Storage. Otherwise connecting to the unicycle will not be possible.  

It now works !!!

I'm not going to use the "NEW" app until everyone including Kingsong has proved it's working correctly.

While we're on the subject of apps, I wondered why it is not possible to turn down the volume of the horn sound (it's way too loud for the pavement) or even have a choice of say a bell which is a bit more polite when approaching pedestrians from behind.

It would also be nice to be able to turn off ALL the lights (including the battery level when stationary) so as to be able to ride on the footpath at night without drawing attention to yourself. It's not legal so why advertise it?

Thanks to all the contributors for their input to my problem

 

Link to comment
Share on other sites

I have just gone to:-

https://www.electricunicycles.eu/new_kingsong_mobile_app_for_electric_unicycles-c__290 website and downloaded the " The newest mobile app for KingSong products. " to my old phone. (I use it as a test bed for new apps before loading them onto my new phone). The version number in  1.42  !!!!!  not 1.47or 1.48

Edited by Juggler
error
Link to comment
Share on other sites

26 minutes ago, Juggler said:

I have just gone to:-

https://www.electricunicycles.eu/new_kingsong_mobile_app_for_electric_unicycles-c__290 website and downloaded the " The newest mobile app for KingSong products. " to my old phone. (I use it as a test bed for new apps before loading them onto my new phone). The version number in  1.42  !!!!!  not 1.47or 1.48

My last version always tried to download the new version from the link provided in 

 

Could be that there is now version 1.48 hostet instead of 1.47

Link to comment
Share on other sites

2 hours ago, Chriull said:

Could be that there is now version 1.48 hostet instead of 1.47

i have written in another thread...1.48 needs another week unfortunatly.

the IOS app is updated and works...any special questions? pm me!

2 hours ago, Juggler said:

The version number in  1.42  !!!!!  not 1.47or 1.48

what does that prove now? that this 7th party website does not have the latest app i guess???

 

Edited by US69
Link to comment
Share on other sites

On 4/26/2018 at 10:12 AM, Chriull said:

@juggler : the serialnumber is the Bluetooth ?mac? address (shown by the app when scanning for the wheel)

The unlock code has to be entered without colons

 

Btw - the needed code (?serial number?) Should be given do you by the app while unlocking?

 

Thank you, I think I have unclocked it by now...

For  it is already showing now my stop speed as being 60km/h  for like 5 derivations I mean for like the first beep, second and stuff it goes all the way to 60 does this mean it is unlocked? 

In other words the top speeds for the second and third beeps are showing 60 km am hour...

Is that it? when your wheel is unlocked?

Link to comment
Share on other sites

Having spent 2 days trying to get my KS14D to connect to my phone (still using an old version 1.42!) I went out for a test ride and initially found the wheel to be very responsive almost twitchy compared to my Ninebot One. I managed to get up to my set limit of 27 kph and found it surprisingly fast.

Unfortunately i spent half my time re connecting the app to the wheel. Then after only 6.2 miles indicated by Strava cycling app I got the slow down message !! The wheel developed a high pitch whistling sound whilst riding. The battery percentage was showing only 65% !!! What is going on with this wheel?

Not happy at all

Link to comment
Share on other sites

1 hour ago, Juggler said:

Having spent 2 days trying to get my KS14D to connect to my phone (still using an old version 1.42!) I went out for a test ride and initially found the wheel to be very responsive almost twitchy compared to my Ninebot One. I managed to get up to my set limit of 27 kph and found it surprisingly fast.

Unfortunately i spent half my time re connecting the app to the wheel. Then after only 6.2 miles indicated by Strava cycling app I got the slow down message !! The wheel developed a high pitch whistling sound whilst riding. The battery percentage was showing only 65% !!! What is going on with this wheel?

Not happy at all

Which firmware is on the 14D?

I guess you have an older firmware, on this the wheel is very restrictive with speed reducement, which starts at 50%(which you can reach very soon because of voltage drop under load)...

They have made this speed reducement better on the latest firmware(starting reduce at 35%) ....unfortunatly the firmware servers are down till next week.

Nonetheless...even with the new firmware, it will still "just" be a 340/420wh wheel with only 2 parallel battery systems, 16s2p....

What i mean is there is a reason for this speed reducements....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...