Jump to content

Search the Community

Showing results for tags 'footplate'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Electric Unicycle Forums
    • Forum Rules (and topics relating to this forum)
    • General Discussion
    • Videos
    • Reviews
    • Which Electric Unicycle to get?
    • Learning to Ride
    • Advanced Skills and Tricks
    • Riding Safety and Protective Gear
    • Apps and App-related Gadgets
    • Mods, Repairs, & DIY
    • Tires
    • Local Group Meet Ups
    • Private Sales (secondhand)
    • Commercial Advertisements
    • Video-Making and Gear
    • Off Topic Discussion
    • Testing Only
  • Brand-Specific Forums (euc only)
    • Gotway
    • Inmotion
    • Inmotion Official Announcements and Information
    • IPS
    • IRON Korea and Rockwheel
    • King Song
    • King Song Official Announcements and Information
    • Ninebot
    • Veteran
  • Inactive EUC brands
    • Airwheel
    • Firewheel
    • Solowheel
    • Uniwheel
  • One-Wheeled Skateboards
    • One-Wheeled Skateboards
  • Two-Wheeled Self-Balancing PEVs
    • Ninebot Mini, Segway MiniPRO, Xiaomi Mini, Airwheel S8 or equivalent
    • Segway (or equivalent)
    • Hoverboard
    • Commercial Advertisements (Ninebot Mini & equivalent only)
  • Non-Self-Balancing PEVs
    • e-Scooters
    • Other Non-Self-Balancing PEVs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


EUC

Found 2 results

  1. Hey all, I'm trying to determine if this is an issue with the latest firmware update, a problem with the control board, or another issue entirely. Most recently I have noticed that my Z10's center of balance is making more drastic changes at low speeds. When I start the unit up and begin making small movements, I can feel the sensor reset slightly and at times have had the footplate tilt back and forward a significant amount before slowly resetting. This isn't as extreme as the issue linked in the post below, but is significantly different than when I got the unit. Again it hasn't affected me too much at higher speeds. Is it possible for the control board to slowly wear out?
  2. Scratched up my Z10 pedals plenty and am looking to replace them and the trolley handle. Ninebot doesn't seem to be offering any official replacement parts unless I'm looking in the wrong place. Has anyone bought some off AliExpress or other sites? I'm a little sketched as I don't know if they are actually Ninebot official parts, and I'd like to trust what's under my feet at 27mph. Linked a couple below. Link Link
×
×
  • Create New...