Jump to content

mke

Newest Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mke

  • Rank
    Newbie

Profile Information

  • Location
    boston mass
  • EUC
    King Song 14C

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. has anyone out here heard of or have done a battery replacement....the batteries imbedded in this model ...there's got to be someway to take it out...was having problems w/ this model and a rep. from e-wheels told me it was most likely the battery....that its mostly just spent. now i have to find a battery and try to get the old one out....took the panels off so its exposed but it wont budge? any advice/answers...........thanks so much...........mike
  2. hey....does any one know how to take the side covers (the ones w/the padding on top)off to be able to get at the battery and mother board? they have a seam around them but they wont pop off?and i cant find any screws other than the ones that hold the 2 pieces of the body itself together....i know it can be done, ive seen pictures of it removed...any ideas friends......thank you......mike
  3. thank you for your answers....now tell me please i found a compatible charger but it go's from flickering red to flickering (slightly) green and yet the 14c flashes red w/beeping and thats (according to the manual)happens when the battery level goes below 5%?????any ideas????also if i leave the the charge in place for a few hours the lights com on voice actives---power on voice, and the gyroscope kicks in but then when i disconnect the charger it stops and only the rear light flickers, and even that stops after a while......and the charger stays green??and i tried 2 different chargers and they
  4. thank you for your answers....now tell me please i found a compatible charger but it go's from flickering red to flickering (slightly) green and yet the 14c flashes red w/beeping and thats (according to the manual)happens when the battery level goes below 5%?????any ideas????also if i leave the the charge in place for a few hours the lights com on voice actives---power on voice, and the gyroscope kicks in but then when i disconnect the charger it stops and only the rear light flickers red??......thanks so much!!!
  5. i have been trying for weeks to find....they all seem to be consistent w/the voltage of 67.2 but vary w/the amperage? some say 2A others say 1.75...even a 4A was listed but they are also never clear that it is for the 14C which i know is an older model but there has to be something out there for it??....Thanks so Much.......mike
×
×
  • Create New...