Jump to content

snuckit

Newest Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About snuckit

  • Rank
    Newbie

Profile Information

  • Location
    Seattle

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Something is really wrong with my KS 18XL. I went to update the KS App to 1.13 As the firmware was updating, white lights, one at a time, would light up, showing the progress. After the firmware update to 1.13 was complete (maybe?) all the white lights remained lit, the power was on and the wheel seemed locked up. It was hard to move it back and forth. I could not get any response from it. All lights remained lit. I could not turn it off. I restarted my phone to see if it would reload the firmware - no change I deleted and reloaded the KS App (Blue) - no change I finally removed the case and unplugged the battery - both sides - lights went out. But, Now I can't get my wheel to power up and stay powered up The Bluetooth on my iPhone says it is connected to KSMusic but no Sign of my wheel in the devices but I can access the app If I hold the power button down I hear the speakers click on, the voice announces “bluetooth connected” and the KS APP seems to connect. But, as soon as I release the power button, the speakers make that click sound again and and the APP disconnects. The only way the wheel stays on ( or at least in a limited form) is if I keep my finger on the power button. When I keep my finger pressed on the power button I can access the app and see what the stats are. The firmware stat says Version 0.00 So, something is really wrong with my wheel and it seems and I cannot use my wheel at this point, at all. Any Thoughts? Does anyone have any details on how to downgrade the firmware back to 1.12 using an iPhone or get past the "current one is the latest version - I know it" screen so I can try and get any firmware in this thing?
  2. Something is really wrong with my KS 18XL. I went to update the KS App to 1.13 As the firmware was updating, white lights, one at a time, would light up, showing the progress. After the firmware update to 1.13 was complete (?) all the white lights remained lit, the power was on and the wheel seemed locked up. It was hard to move it back and forth. I could not get any response from it. All lights remained lit. I restarted my phone to see if it would reload the firmware - no change I deleted and reloaded the KS App (Blue) - no change I finally removed the case and unplugged the battery - both sides - lights went out. But, Now I can't get my wheel to power up and stay powered up The Bluetooth on my iPhone says it is connected to KSMusic but no Sign of my wheel in the devices but I can access the app If I hold the power button down I hear the speakers click on, the voice announces “bluetooth connected” and the KS APP seems to connect. But, as soon as I release the power button, the speakers click again and and the APP disconnects. The only way the wheel stays on ( or at least in a limited form) is if I keep my finger on the power button. When I keep my finger pressed on the power button I can access the app and see what the stats are. The firmware stat says Version 0.00 So, something is really wrong with my wheel and it seems and I cannot use my wheel at this point, at all. Any Thoughts?
×
×
  • Create New...